ocaml

The OCaml compiler (virtual package)
Description

This package requires a matching implementation of OCaml, and polls it to initialise specific variables like ocaml:native-dynlink

Install
Dependencies
ocaml-system
>= "4.03.0" & < "4.03.1~"
ocaml-variants
>= "4.03.0" & < "4.03.1~"
Reverse Dependencies
0install
!= "2.8" & < "2.15.1"
acgtk
< "1.5.1"
aifad
< "2.1.0"
alba
< "0.4.1"
alcotest
< "0.4.6" | >= "0.4.10"
alt-ergo
< "2.0.0"
altgr-ergo
< "2.3.0"
amf
< "0.1.2"
amqp-client
>= "1.0.0" & < "2.0.0"
ancient
>= "0.9.1"
angstrom
< "0.13.0"
angstrom-async
< "0.11.1"
ao
< "0.2.2"
arakoon
>= "1.8.6"
archimedes
>= "0.4.18"
arp
< "0.2.1"
astring
< "0.8.4"
async
< "109.19.00" | >= "113.24.00" & != "113.33.03" & < "v0.10.0"
async_core
< "109.19.00"
async_extended
>= "113.24.00" & != "113.33.03" & < "v0.10.0"
async_extra
< "109.19.00" | = "113.24.00" | = "113.33.00+4.03" | = "v0.9.0"
async_find
!= "111.28.00" & != "113.33.03" & < "v0.10.0"
async_inotify
!= "113.00.00" & != "113.33.03" & < "v0.10.0"
async_js
< "v0.10.0"
async_kernel
>= "113.24.00" & != "113.33.03" & < "v0.10.0"
async_parallel
>= "113.24.00" & != "113.33.03" & < "v0.10.0"
async_rpc_kernel
>= "113.24.00" & != "113.33.03" & < "v0.10.0"
async_shell
!= "109.28.03" & != "113.33.03" & < "v0.10.0"
async_smtp
< "112.35.00" | >= "113.24.00" & != "113.33.03" & < "v0.10.0"
async_ssl
< "112.35.00" | = "113.24.00" | >= "113.33.06" & < "v0.10.0"
async_unix
< "109.19.00" | = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.10.0"
atd
< "2.3.3"
atdgen
>= "1.9.1" & < "2.3.3"
atdj
< "2.3.3" | >= "20151001.01"
atds
< "2.3.3"
atomic
< "base"
aws
< "1.2"
aws-ec2
< "1.2"
aws-s3
< "2.0.0"
aws-sdb
< "1.2"
aws-ssm
< "1.2"
aws-sts
< "1.2"
b0
< "0.0.1"
bap
= "0.9.5" | >= "1.0.0" & < "1.6.0"
bap-abi
< "1.6.0"
bap-api
< "1.6.0"
bap-arm
< "1.6.0"
bap-beagle
< "1.6.0"
bap-bil
< "1.6.0"
bap-c
< "1.6.0"
bap-cache
< "1.6.0"
bap-callsites
< "1.6.0"
bap-cxxfilt
< "1.6.0"
bap-demangle
< "1.6.0"
bap-dwarf
< "1.6.0"
bap-elf
< "1.5.0"
bap-frames
< "2.1.2"
bap-frontc
< "1.6.0"
bap-frontend
< "1.6.0"
bap-future
< "1.6.0"
bap-ida
< "1.6.0"
bap-llvm
< "1.6.0"
bap-mc
< "1.6.0"
bap-microx
< "1.6.0"
bap-mips
< "1.6.0"
bap-objdump
< "1.6.0"
bap-phoenix
< "1.6.0"
bap-piqi
< "1.6.0"
bap-powerpc
< "1.6.0"
bap-primus
< "1.6.0"
bap-print
< "1.6.0"
bap-report
< "1.6.0"
bap-run
< "1.6.0"
bap-server
< "0.3.0"
bap-ssa
< "1.6.0"
bap-std
< "1.6.0"
bap-strings
< "1.6.0"
bap-taint
< "1.6.0"
bap-trace
< "1.6.0"
bap-traces
< "1.6.0"
bap-veri
< "0.2.3"
bap-x86
< "1.6.0"
bare
< "1.6.0"
base
< "v0.10.0"
base-bytes
>= "base"
base64
!= "2.3.0"
batteries
>= "2.5.0"
bau
>= "0.0.2"
beluga
>= "0.8.1" & < "1.0"
benchmark
>= "1.3.1"
bignum
< "112.35.00" | >= "113.24.00" & != "113.33.03" & < "v0.10.0"
bigstringaf
< "0.9.0"
bimage
< "0.2.1"
bimage-gtk
< "0.2.1"
bimage-sdl
< "0.2.1"
bin_prot
< "109.15.00" | = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.10.0"
bindlib
< "6.0.0"
biocaml
!= "0.10.0" & < "0.11.0"
bisect
>= "1.3"
bisect_ppx
>= "1.1.0"
bistro
< "0.5.0"
bitcoinml
< "0.4.1"
bitstring
>= "2.0.4" & < "4.0.0"
bjack
< "0.1.6"
bloomf
< "0.2.0"
bogue
< "20200630"
bolt
>= "1.3"
bos
< "0.2.1"
brotli
< "1.3.0"
cairo
>= "0.4.2"
calculon
< "0.7"
calendar
!= "2.03.1"
caml2html
>= "1.4.4"
camlimages
>= "4.1.2" & != "4.2.1" & < "4.2.5"
camllib
>= "1.3.1"
camlon
< "3.0.0"
camlp4
>= "4.02.0-1modular-implicits" & < "4.04+1"
camlp5
>= "6.15" & != "7.09" & < "8.00.03"
camlpdf
>= "2.1.1" & < "2.5"
camltc
!= "0.9.2"
camlzip
>= "1.05" & < "1.11"
camomile
!= "1.0.0"
capnp
< "2.1.0" | >= "3.0.0"
capnp-rpc
< "1.2"
capnp-rpc-net
< "0.9.0"
caqti
< "0.10.0"
caqti-dynload
< "0.10.2"
cbor
< "0.5"
certify
< "0.3.0"
cfg
< "2.1.0"
cfstream
< "1.3.0"
chamo
= "2.03"
charrua-client
< "0.11.0"
charrua-unix
< "1.0.0"
checkseum
< "0.1.1"
cil
>= "1.7.3"
cinaps
< "v0.10.0"
clangml
!= "3.8.0" & < "4.0.0" | >= "4.1.0" & < "4.3.0"
cmdliner
< "1.1.0"
coccinelle
!= "1.0.0-rc23"
codept
>= "0.9.1"
cohttp
< "1.2.0"
cohttp-async
< "1.1.1"
cohttp-lwt
< "1.2.0"
cohttp-mirage
< "1.2.0"
cohttp-top
< "1.2.0"
colombe
!= "0.2.0"
command_rpc
< "v0.10.0"
comparelib
< "113.00.00"
conduit
!= "3.0.0"
conduit-async
!= "3.0.0"
conduit-lwt
!= "3.0.0"
conex
< "0.11.0"
conex-nocrypto
< "0.11.0"
configurator
< "v0.10.0"
coq
>= "8.5.0~camlp4" & < "8.10.0"
coqide
< "8.10.0"
core
>= "113.24.00" & != "113.33.00" & != "113.33.02" & != "113.33.03" & < "v0.10.0"
core-lwt
< "0.3.0"
core_bench
!= "112.35.00" & != "113.33.00" & != "113.33.03" & < "v0.10.0"
core_extended
>= "108.00.02" & < "109.19.00" | = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.10.0"
core_kernel
= "113.24.00" | = "113.33.01+4.03" | >= "v0.9.0" & < "v0.10.0"
core_profiler
>= "113.24.00" & != "113.33.03" & < "v0.10.0"
cow
>= "1.0.0" & != "2.0.0"
cpdf
< "2.4"
crowbar
< "0.2"
crunch
< "2.2.0"
cry
< "0.6.5"
cryptokit
>= "1.10" & < "1.17"
csexp
>= "1.1.0"
cstruct
< "1.8.0" | >= "2.0.0" & < "6.1.0"
cstruct-async
< "6.1.0"
cstruct-lwt
< "6.1.0"
cstruct-sexp
< "6.1.0"
cstruct-unix
< "3.5.0"
csv
>= "1.2.4"
csvfields
< "v0.10.0"
csvprovider
>= "1.2"
ctypes
>= "0.4.0"
cubicle
>= "1.0.2"
custom_printf
>= "111.21.00" & < "113.00.00"
decompress
< "0.9.1"
depyt
< "0.3.0"
deriving
>= "0.7.1"
devkit
= "0.4"
digestif
< "1.1.0"
dns
< "4.0.0"
dolmen
< "0.5"
dropbox
< "0.2"
dssi
< "0.1.3"
dtools
< "0.4.2"
duff
< "0.5"
dune-configurator
= "1.11.4" | >= "2.7.0" & < "3.0.2"
duppy
< "0.9.0"
duration
< "0.1.2"
dyntype
>= "0.8.3"
earley
< "3.0.0"
easy-format
< "1.3.3"
ecaml
< "v0.10.0"
eigen
< "0.1.4" | >= "0.1.6" & != "0.3.2"
eliom
< "6.4.0"
elpi
< "1.3.1"
email_message
< "112.35.00" | = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.10.0"
encore
< "0.6"
enumerate
< "111.08.00"
eqaf
< "0.8"
erssical
< "1.1.0"
extlib
>= "1.5.3"
extprot
>= "1.1.2"
extunix
< "0.3.1"
ez_cmdliner
< "0.2.0"
ez_config
< "0.2.0"
ez_file
< "0.2.0"
ezjsonm
>= "0.4.3" & < "1.2.0"
FrontC
< "4.0.0"
faad
< "0.5.0"
faraday-async
< "0.7.2"
fat-filesystem
< "0.14.0"
fdkaac
< "0.3.2"
feather
< "0.2.0"
ffmpeg
< "0.2.0"
fftw3
>= "0.7.2"
fiat-p256
< "0.2.0"
fieldslib
< "109.19.00" | = "113.24.00" | = "v0.9.0"
flow
>= "0.3"
flow_parser
< "0.159.0"
flowtype
>= "0.25.0" & < "0.72.0"
fluent-logger
< "1.1.0"
fmt
< "0.8.7"
frama-c
>= "10.0" & < "20.0"
freetds
< "0.7"
frei0r
< "0.1.2"
frenetic
< "5.0.0"
fstar
< "0.9.5.0"
functoria
>= "1.1.0" & < "3.0.1"
gasoline
>= "0.3.0"
gdal
!= "0.8.0"
gen-bs
< "0.1.0"
gen_js_api
< "1.0.4"
genprint
< "0.3"
get_line
< "5.0.0"
gettext
>= "0.3.7"
gg
< "1.0.0"
git
!= "1.4.3" & != "1.7.2" & < "2.1.3"
git-http
< "2.1.3"
git-mirage
< "2.1.3"
git-unix
< "2.1.3"
github
< "4.4.0"
github-jsoo
< "4.4.0"
github-unix
< "4.4.0"
glMLite
< "0.03.53"
goblint-cil
< "1.8.0"
gpr
< "1.3.0"
graphics
< "3.07" | = "4.03.0"
graphlib
< "1.6.0"
grenier
< "0.11"
gsl
< "1.20.0"
hack_parallel
< "1.0.0"
hardcaml
< "v0.12.0"
hdf5
>= "0.1.2" & < "0.1.5"
headache
< "1.04"
herdtools7
< "7.54"
herelib
< "112.35.00"
hevea
< "2.35"
hex
< "1.5.0"
higlo
< "0.8"
hkdf
< "1.0.3"
horned_worm
>= "0.3.1"
ibx
< "0.8.1"
imagelib
< "20200929"
imaplet-lwt
< "0.1.15"
immutable
>= "0.0.6"
incr_dom
< "v0.10.0"
incr_map
< "v0.10.0"
incr_select
< "v0.10.0"
incremental
>= "113.24.00" & != "113.33.03" & < "v0.10.0"
incremental_kernel
!= "113.33.03" & < "v0.10.0"
inferno
< "20211222"
integers
!= "0.5.0"
io-page
< "3.0.0"
iocaml
>= "0.4.6"
iocaml-kernel
>= "0.4.6"
iocamljs-kernel
< "0.4.3" | >= "0.4.6"
ipaddr
!= "2.7.1" & < "3.0.0"
iri
< "0.5.0"
irmin
< "0.9.0" | >= "0.9.5" & != "0.9.10" & < "2.0.0"
irmin-mirage
< "2.0.0"
irmin-pack
< "2.3.0"
javalib
< "3.1"
jekyll-format
< "0.2.0"
jenga
< "109.19.00" | >= "113.24.00" & != "113.33.00" & != "113.33.03" & < "v0.10.0"
jhupllib
< "0.2.1"
jingoo
< "1.3.0"
js-build-tools
>= "113.33.04"
js_of_ocaml
>= "2.8" & < "3.10.0"
js_of_ocaml-ocamlbuild
!= "3.5.2" & < "3.10.0"
json-wheel
< "1.0.6+safe-string"
junit
< "2.0.1"
junit_ounit
< "2.0.1"
jupyter
< "2.3.2"
kafka
>= "0.3"
kaputt
>= "1.2"
ke
< "0.6"
ketrew
>= "1.1.1"
key-parsers
< "0.10.0"
kicadsch
< "0.4.0"
kinetic-client
< "0.0.11"
lablgtk
< "2.18.6"
lablqml
< "0.7"
labltk
< "8.06.2"
lacaml
< "10.0.1"
ladspa
< "0.2.0"
lambda-term
< "3.2.0"
lame
< "0.3.4"
landmarks
< "1.4"
lascar
< "0.6-alpha"
lastfm
< "0.3.3"
lbfgs
!= "0.8.5"
lbvs_consent
< "2.0.0"
lens
< "1.2.1"
letters
< "0.1.1"
leveldb
!= "1.0.3" & < "1.3.0"
libsvm
!= "0.9.3"
liquidsoap
< "1.4.0"
lmdb
>= "1.0"
lo
< "0.2.0"
loga
< "0.0.5"
logtk
< "2.0"
lustre-v6
< "6.101.7"
lutin
!= "2.70.4"
lwt
= "2.4.5" | >= "2.5.2"
lwt_log
< "1.1.1"
lz4_chans
>= "3.0.0"
mad
< "0.5.0"
mariadb
< "1.1.4"
mdx
>= "1.2.0" & < "2.0.0"
memcad
< "1.1.0"
menhir
!= "20211125"
merlin
>= "2.5.0" & != "3.3.4~4.10preview1" & != "3.3.7~4.11preview1" & < "4.1-411"
metapp
< "0.3.0"
metaquot
< "0.3.0"
mikmatch
= "1.0.8"
milter
>= "1.0.1"
mindstorm
< "0.8"
minicaml
< "0.3.1"
minisat
!= "0.3"
mirage
< "3.0.7"
mirage-block
< "1.2.0"
mirage-clock
< "2.0.0"
mirage-device
< "1.2.0"
mirage-dns
< "3.1.2"
mirage-flow
< "1.5.0"
mirage-fs
< "1.2.0"
mirage-fs-lwt
< "1.2.0"
mirage-fs-unix
>= "1.1.1" & < "1.4.1"
mirage-kv
< "2.0.0"
mirage-kv-lwt
< "2.0.0"
mirage-logs
< "1.2.0"
mirage-nat
< "1.1.0"
mirage-net
< "1.2.0"
mirage-net-unix
!= "2.2.0" & < "2.5.0"
mirage-net-xen
>= "1.4.2" & < "1.8.1"
mirage-qubes
< "0.8.0"
mirage-random
< "1.2.0"
mirage-solo5
< "0.3.0"
mirage-stack
< "1.2.0"
mirage-time
< "1.3.0"
mirage-types
< "3.0.7"
mirage-unix
< "3.0.8"
mirage-vnetif
< "0.4.1"
mirage-xen
>= "2.6.0" & < "3.0.6"
mirage-xen-ocaml
>= "2.6.0" & < "3.0.4"
mirage-xen-posix
< "3.1.0" | >= "3.3.0"
mlbdd
< "0.7.2"
mlcuddidl
< "3.0.7"
mldonkey
>= "3.1.6"
mm
>= "0.3.0" & < "0.5.0"
mock
< "0.1.1"
mock-ounit
< "0.1.1"
modelica_ml
>= "0.2.0"
molenc
>= "7.0.1" & < "15.4.0"
monads
< "1.6.0"
morbig
< "0.10.3"
mpi
< "1.05"
msgpck
< "1.5"
mtime
< "1.4.0"
mysql
>= "1.2.1"
naboris
< "0.1.0"
netchannel
< "1.8.1"
nocrypto
>= "0.2.0"
notty
< "0.2.2"
npy
< "0.0.7"
nsq
< "0.2.4"
num
< "1.0"
OCanren
< "0.2.0"
OCanren-ppx
< "0.3.0~alpha1"
oasis
>= "0.4.6"
obeam
< "0.1.0" | = "0.1.2"
obelisk
< "0.5.0"
objsize
>= "0.18"
obus
>= "1.1.7" & < "1.2.0"
obytelib
< "1.2" | >= "1.6"
ocaml-basics
>= "0.5.0"
ocaml-lua
>= "1.6" & < "1.8"
ocaml-makefile
< "6.39.2"
ocaml-manual
= "4.03.0"
ocaml-migrate-parsetree
!= "1.3.0~4.08.0+beta2"
ocaml-monadic
>= "0.3.2" & < "0.4.0"
ocaml-r
< "0.4.0"
ocaml-src
= "4.03.0"
ocaml-top
< "1.1.0" | >= "1.1.4"
ocaml-variants
>= "4.03.0+32bit" & < "4.03.1+trunk"
ocaml-version
< "3.0.0"
ocaml-xdg-basedir
< "transition"
ocaml_plugin
< "112.35.00" | >= "113.24.00" & != "113.33.00" & != "113.33.03" & < "v0.10.0"
ocamlclean
!= "2.2"
ocamlcodoc
< "1.0.1"
ocamldap
>= "2.2"
ocamldot
< "1.1"
ocamlfind
>= "1.5.1"
ocamllint
>= "0.3.0"
ocamlnet
>= "4.1.2"
ocamlpp
>= "1.1"
ocamlscript
< "3.0.0"
ocamlspot
= "4.03.0.2.3.1"
ocamltter
< "2.0.1" | = "2.1.1" | >= "4.1.0"
ocapic
= "3.3"
ocf
= "0.5.0"
ocolor
>= "1.1"
ocp-browser
!= "1.2.1"
ocp-build
= "1.99.14-beta" | >= "1.99.16-beta"
ocp-indent
< "0.9.2" | >= "1.4.2"
ocp-index
>= "1.1.4"
ocplib_stuff
< "0.3.0"
ocsigen-i18n
< "3.2.0"
ocsigen-start
< "1.2.0"
odate
< "0.6"
odepack
>= "0.6.3"
odig
< "0.0.5"
ogen
!= "0.1.2"
ogg
!= "0.6.0" & < "0.7.0"
ogre
< "1.6.0"
ojs-base
< "0.3.0" | = "0.5.0"
omd
< "2.0.0~alpha1"
omod
< "0.0.3"
omonad
= "0.3.1" | = "0.3.3"
oni
>= "1.0.12"
opam-core
!= "2.0.0~rc"
opam_bin_lib
< "0.9.5"
opasswd
< "0.9.3" | >= "1.3.1"
opium
< "0.17.0"
opium_kernel
< "0.17.0"
optint
< "0.0.3"
opus
< "0.2.0"
orakuda
< "2.0.0"
orm
>= "0.7.0"
osc
< "0.2.0"
osdp
< "1.0.0"
ospec
>= "0.3.1"
otfm
< "0.4.0"
otr
>= "0.3.2" & < "0.3.6"
ounit
< "2.2.0"
ounit-lwt
< "2.2.0"
ounit2
< "2.2.3"
ounit2-lwt
< "2.2.3"
override
>= "0.2.0" & < "0.4.0"
owee
< "0.3"
owl
< "0.2.0"
pa_bench
< "113.00.00"
pa_ounit
< "112.35.00"
pa_test
< "112.24.00"
parse-argv
< "0.2.0"
parsexp
< "v0.10.0"
parsexp_io
< "v0.10.0"
patdiff
!= "113.00.00" & != "113.33.03" & < "v0.10.0"
patience_diff
!= "112.24.00" & != "113.33.03" & < "v0.10.0"
pattern
= "0.2.0"
pbkdf
< "1.1.0"
pcap-format
< "0.6.0"
pcre
< "7.3.0"
pfff
>= "0.37.1" & < "0.39.1"
pgocaml
< "3.1"
pipebang
< "113.00.00"
pkcs11
< "0.18.0"
pla
< "2.0"
planck
>= "2.2.0"
planets
>= "0.1.14"
plist
< "1.0.0"
plotkicadsch
< "0.4.0"
podge
< "0.8.0"
pomap
< "4.0.0"
portaudio
= "0.2.1"
posix-getopt
< "2.0.0"
posixat
< "v0.10.0"
postgresql
< "4.1.0"
ppx_assert
>= "113.24.00" & != "113.33.03" & < "v0.10.0"
ppx_ast
< "v0.9.2"
ppx_base
< "v0.10.0"
ppx_bench
= "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.10.0"
ppx_bigarray
>= "2.0.0"
ppx_bin_prot
>= "113.24.00" & != "113.33.00" & != "113.33.03" & < "v0.10.0"
ppx_bitstring
>= "1.0.1" & < "4.0.0"
ppx_blob
>= "0.2"
ppx_compare
= "113.24.00" | = "113.33.00+4.03" | = "v0.9.0"
ppx_compose
< "0.2.1"
ppx_const
< "2.0"
ppx_conv_func
= "113.24.00" | = "113.33.00+4.03" | = "v0.9.0"
ppx_core
>= "113.33.00+4.03" & != "113.33.03" & < "v0.10.0"
ppx_cstruct
< "6.0.0"
ppx_cstubs
< "0.6.0"
ppx_csv_conv
= "113.24.00" | = "113.33.00+4.03" | = "v0.9.0"
ppx_custom_printf
= "113.24.00" | = "113.33.00+4.03" | = "v0.9.0"
ppx_defer
< "0.5.0"
ppx_deriving
>= "3.3" & < "4.2" | >= "4.3" & < "5.0"
ppx_deriving_protobuf
>= "2.4" & < "3.0.0"
ppx_deriving_yojson
< "2.0" | >= "3.0" & < "3.3"
ppx_driver
= "113.24.00" | >= "113.33.00+4.03" & < "113.33.03" | >= "v0.9.0" & < "v0.10.0"
ppx_enumerate
= "113.24.00" | = "113.33.00+4.03" | = "v0.9.0"
ppx_expect
!= "113.33.00" & != "113.33.01" & != "113.33.03" & < "v0.10.0"
ppx_fail
= "113.24.00" | = "113.33.00+4.03" | = "v0.9.0"
ppx_fields_conv
= "113.24.00" | = "113.33.00+4.03" | = "v0.9.0"
ppx_getenv
= "1.2"
ppx_hash
< "v0.10.0"
ppx_here
>= "113.24.00" & != "113.33.03" & < "v0.10.0"
ppx_import
< "1.5-3-gbd627d5"
ppx_include
>= "1.1"
ppx_inline_test
= "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.10.0"
ppx_jane
!= "113.33.03" & < "v0.10.0"
ppx_js_style
< "v0.10.0"
ppx_jsobject_conv
>= "0.2.1" & < "0.5.0"
ppx_let
!= "113.33.00" & != "113.33.03" & < "v0.10.0"
ppx_meta_conv
>= "2.4.0" & < "2.5.0"
ppx_metaquot
< "v0.10.0"
ppx_monadic
>= "1.0.4"
ppx_monoid
< "0.3.2"
ppx_optcomp
= "113.24.00" | = "113.33.00+4.03" | = "v0.9.0"
ppx_optional
< "v0.10.0"
ppx_orakuda
>= "3.0.0" & < "3.0.2"
ppx_pipebang
= "113.24.00" | = "113.33.00+4.03" | = "v0.9.0"
ppx_regexp
>= "0.3.0"
ppx_sexp_conv
>= "113.24.00" & != "113.33.03" & < "v0.10.0"
ppx_sexp_message
!= "113.33.00" & != "113.33.03" & < "v0.10.0"
ppx_sexp_value
= "113.24.00" | = "113.33.00+4.03" | = "v0.9.0"
ppx_test
>= "1.4.0" & < "1.7.0"
ppx_tools
= "4.03.0" | = "5.0+4.03.0"
ppx_traverse
< "v0.10.0"
ppx_type_conv
= "113.24.00" | >= "113.33.00+4.03" & != "113.33.03" & < "v0.9.1"
ppx_typerep_conv
= "113.24.00" | = "113.33.00+4.03" | = "v0.9.0"
ppx_tyre
>= "0.4.3"
ppx_variants_conv
= "113.24.00" | = "113.33.00+4.03" | = "v0.9.0"
ppx_xml_conv
>= "113.24.00" & != "113.33.03" & < "v0.10.0"
ppxfind
>= "1.2"
ppxx
= "1.3.0"
pratter
>= "1.1"
ptime
< "1.0.0"
ptmap
!= "2.0.4"
pulseaudio
< "0.1.4"
py
< "1.1"
qbf
< "0.3"
qcheck
< "0.18"
qcheck-core
< "0.18"
qfs
< "0.12"
quickcheck
!= "1.0.0"
randomconv
< "0.1.1"
rdbg
< "1.184.1"
rdf
< "0.7.0" | = "0.11.0"
re2
< "112.35.00" | = "113.24.00" | = "113.33.00+4.03" | >= "v0.9.0" & < "v0.10.0"
react
< "1.2.2"
reactiveData
< "0.2.2"
reason
>= "1.11.0"
redirect
>= "0.1.1"
refl
< "0.4.0"
regular
< "1.6.0"
res
< "5.0.0"
rfc1951
< "0.9.1"
rfc6287
< "1.0.4"
rfsm
< "1.6-alpha-3"
riakc_ppx
!= "3.1.2"
river
< "0.2"
rml
>= "1.09.00" & < "1.09.06"
rpc
< "1.3.0" | >= "1.9.51" & < "5.9.0"
rpc_parallel
>= "113.24.00" & != "113.33.03" & < "v0.10.0"
rpclib-async
!= "6.0.0"
rpclib-lwt
!= "6.0.0"
rresult
< "0.7.0"
salsa20
< "1.1.0"
samplerate
< "0.1.5"
sawja
< "1.5.8"
scrypt-kdf
< "1.1.0"
sedlex
>= "1.99.3" & < "2.3"
sendmail
>= "0.2.0"
sendmail-lwt
>= "0.2.0"
seq
< "base"
session
< "0.5.0"
sexp_pretty
< "v0.10.0"
sexplib
= "113.33.00+4.03" | >= "v0.9.0" & < "v0.9.3"
sha
< "1.13" | >= "1.15.1"
shcaml
>= "0.2.0"
shexp
< "v0.10.0"
slacko
< "0.14.1"
slap
>= "3.0.1"
sparrow
< "0.2"
spawn
!= "v0.10.0" & != "v0.11.0" & < "v0.15.0"
spdx_licenses
< "1.1.0"
speex
< "0.4.0"
spelll
!= "0.3"
spoc
= "20170724"
spotlib
>= "2.4.1" & < "4.0.0"
sqlite3
< "4.2.0"
srt
< "0.1.1"
stdint
!= "0.6.0"
stdio
< "v0.10.0"
stog
= "0.11.1" | >= "0.13.0" & < "0.19.0"
stog-writing
< "0.19.0"
syndic
!= "1.6.0"
systemverilog
< "0.0.2"
taglib
< "0.3.7"
tar
< "2.0.0"
tar-mirage
< "0.9.0"
tcpip
< "4.0.0"
tensorflow
< "0.0.11"
terminal_size
< "0.2.0"
text
>= "0.8.0"
text-tags
< "1.6.0"
textutils
!= "112.17.00" & != "113.33.03" & < "v0.10.0"
tgls
< "0.8.6"
theora
< "0.4.0"
tidy
< "5-0.2"
tiny_httpd
< "0.8"
tiny_json
< "1.1.5"
tip-parser
< "0.5"
tls
< "0.10.2"
toml
< "7.0.0"
toml_cconv
< "7.0.0"
tophide
>= "1.0.4"
topkg
< "1.0.5"
topkg-care
< "1.0.5"
toplevel_expect_test
< "113.33.02" | >= "v0.9.1" & < "v0.10.0"
topological_sort
< "v0.10.0"
trax
< "0.4.0"
treeprint
>= "2.1.1"
tuntap
< "1.6.1"
type_conv
>= "113.00.02"
typerep
< "112.35.00" | = "113.24.00" | = "v0.9.0"
typerep_extended
!= "113.00.00" & != "113.33.03"
typerex-attic
>= "1.0.2"
typpx
= "1.1.3"
tyxml-jsx
< "4.5.0"
tyxml-ppx
< "4.5.0"
uecc
>= "0.3"
uint
>= "1.1.5" & < "2.0.1"
unionFind
< "20220107"
unison
>= "2.48.15v4" & < "2.52.0"
unmagic
< "1.0.3"
uri
< "2.1.0"
uritemplate
>= "0.2.0"
utop
>= "1.19.1"
uuidm
< "0.9.8"
variantslib
!= "109.15.03" & != "113.33.03" & < "v0.10.0"
vcardgen
< "1.2"
vchan
< "4.0.0"
vchan-unix
< "4.0.0"
vchan-xen
< "4.0.0"
virtual_dom
< "v0.10.0"
visitors
< "20210127"
vmnet
< "1.3.2"
vpt
< "5.0.0"
wasm
< "1.1"
webdav
>= "1.1.5"
websocket
< "2.12"
why
>= "2.32"
why3
< "1.3.0"
why3-coq
< "1.3.0"
why3-ide
< "1.3.0"
wyrd
>= "1.4.6"
x509
< "0.6.3"
xapi-rrd
< "1.8.2"
xen-gnt
< "4.0.1"
xen-gnt-unix
< "4.0.1"
xenctrl
>= "0.9.29"
xenstore
< "2.0.0"
xmldiff
< "0.6.0"
xmlm
< "1.4.0"
xtmpl
= "0.10" | >= "0.14.0" & < "0.18.0"
yaml
!= "0.2.1" & < "3.0.0"
z3
< "4.8.14"
zarith
>= "1.3" & < "1.12"
zenon
< "0.8.5"
zero
< "109.19.00"
zlist
< "0.4.0"
zmq
< "4.0-1" | >= "4.0-7" & < "5.1.1" | >= "5.1.3"
zmq-async
< "5.1.0"
zmq-lwt
< "5.1.1" | >= "5.1.3"
zxcvbn
< "2.3+2"