ppx_tools_versioned

A variant of ppx_tools based on ocaml-migrate-parsetree
README

Tools for authors of syntactic tools (such as ppx rewriters).

This package is licensed by LexiFi under the terms of the MIT license.

The tools are installed as a findlib package called 'ppx_tools'.
Executables are thus accessible through the ocamlfind driver (e.g.:
ocamlfind ppx_tools/dumpast).

Main contributors:

  • Alain Frisch

  • Peter Zotov (whitequark)

  • Gabriel Radanne (Drup)

ppx_metaquot

A ppx filter to help writing programs which manipulate the Parsetree,
by allowing the programmer to use concrete syntax for expressions
creating Parsetree fragments and patterns deconstructing Parsetree
fragments. See the top of ppx_metaquot.ml for a description of the
supported extensions.

Usage:

ocamlfind ocamlc -c -package ppx_tools.metaquot my_ppx_code.ml

Ast_mapper_class

This module implements an API similar to Ast_mapper from the
compiler-libs, i.e. a generic mapper from Parsetree to Parsetree
implemeting a deep identity copy, which can be customized with a
custom behavior for each syntactic category. The difference with
Ast_mapper is that Ast_mapper_class implements the open recursion
using a class.

Install
Sources
5.4.0.tar.gz
md5=3e809a11cae99f57c051d3d0100311f6
Dependencies
ocaml-migrate-parsetree
>= "1.7.0" & < "2.0.0"
dune
>= "1.0"
ocaml
>= "4.02.0"
Reverse Dependencies
bisect_ppx
>= "1.3.0" & < "2.6.0"
bitstring
>= "3.0.0" & < "4.0.0"
cstruct
= "2.4.1"
eliom
>= "6.8.0" & < "8.9.0"
elpi
>= "1.0.5" & < "1.11.0"
frenetic
>= "5.0.0" & < "5.0.3"
graphql_ppx
>= "0.7.1" & < "1.2.2"
hdf5
>= "0.1.5"
js_of_ocaml
>= "3.0" & < "3.8.0"
learn-ocaml
>= "0.13.0"
lwt
>= "3.1.0" & < "4.0.0"
lwt_ppx
< "2.0.2"
memtrace_viewer
< "v0.15.0"
ocaml-monadic
>= "0.4.0" & < "0.5"
pgocaml
>= "3.1" & < "4.0"
pgocaml_ppx
< "4.3.0"
ppx_bitstring
>= "2.0.0" & < "4.0.0"
ppx_cstruct
>= "3.0.1" & < "6.0.0"
ppx_cstubs
< "0.6.0"
ppx_defer
>= "0.3.0" & < "0.5.0"
ppx_hardcaml
>= "1.3.0"
ppx_implicits
>= "0.2.0"
ppx_import
>= "1.5-3-gbd627d5" & < "1.9.0"
ppx_monadic
>= "1.1.0"
ppx_monoid
>= "0.3.2"
ppx_orakuda
>= "3.1.0"
ppx_regexp
>= "0.3.1" & < "0.5.0"
ppxx
>= "2.0.0" & < "2.5.0"
sedlex
>= "2.0" & < "2.3"
tyxml-jsx
< "4.5.0"
tyxml-ppx
>= "4.3.0" & < "4.5.0"
tyxml-syntax
< "4.5.0"