camlp-streams

The Stream and Genlex libraries for use with Camlp4 and Camlp5
README

The camlp-streams package provides two library modules:

  • Stream: imperative streams, with in-place update and memoization of the latest element produced.

  • Genlex: a small parameterized lexical analyzer producing streams of tokens from streams of characters.

The two modules are designed for use with Camlp4 and Camlp5:

  • The stream patterns and stream expressions of Camlp4/Camlp5 consume and produce data of type 'a Stream.t.

  • The Genlex tokenizer can be used as a simple lexical analyzer for Camlp4/Camlp5-generated parsers.

The Stream module can also be used by hand-written recursive-descent parsers, but is not very convenient for this purpose.

The Stream and Genlex modules have been part of the OCaml standard library for a long time, and have been distributed as part of the core OCaml system. They will be removed from the OCaml standard library at some future point, but will be maintained and distributed separately in this camlp-streams package.

Install
Published
27 Jun 2022
Sources
v5.0.1.tar.gz
md5=afc874b25f7a1f13e8f5cfc1182b51a7
sha512=2efa8dd4a636217c8d49bac1e4e7e5558fc2f45cfea66514140a59fd99dd08d61fb9f1e17804997ff648b71b13820a5d4a1eb70fed9d848aa2abd6e41f853c86
Dependencies
odoc
with-doc
ocaml
>= "4.02.3"
dune
>= "2.7"
Reverse Dependencies
atdgen-runtime
>= "2.3.3" & < "2.10.0"
biniou
>= "1.2.2"
camlp5
>= "8.00.03"
cca
>= "0.6.2"
dream
>= "1.0.0~alpha4"
lambdapi
>= "2.2.1"
odoc-parser
>= "1.0.1"
pratter
>= "1.2.1"
redis-sync
>= "0.6"
tar
>= "2.0.1"