either

Compatibility Either module
README


Projects that want to use the Either module defined in OCaml 4.12.0 while
staying compatible with older versions of OCaml should use this library
instead. On OCaml versions 4.12 and above, this library defines an alias
Either to the standard library's definition of the module. Otherwise, it
provides an equivalent definition of Either.

Depending on this library

Opam libraries depending on this module are encouraged to use a conditional
dependency:

depends: [
  ("ocaml" {>= "4.12.0"} | "either")
]

This ensures that any dependencies of your library that don't need pre-4.12
compatibility will never transitively depend on either.

Acknowledgements

This repository structure is mostly copied from
JaneStreet/result, which provides a
compatibility result type. Thanks to the OCaml maintainers for their
improvements to the standard library.

Install
Published
19 Nov 2020
Sources
either-1.0.0.tbz
sha256=bf674de3312dee7b7215f07df1e8a96eb3d679164b8a918cdd95b8d97e505884
sha512=147854c09f897dd028b18a9f19acea8666107aaa7b1aab3c92f568af531364f57298edcaf3897d74246d3857d52e9bfb7ad0fc39220d988d9f14694ca1d5e9ed
Dependencies
dune
>= "2.0"
Reverse Dependencies
containers
>= "3.6.1"
ocamlformat
= "0.19.0~4.13preview" | >= "0.20.0"
ocamlformat-rpc
>= "0.20.0" & < "0.21.0"
repr
>= "0.2.1"