ocaml

The OCaml compiler (virtual package)
Description

This package requires a matching implementation of OCaml, and polls it to initialise specific variables like ocaml:native-dynlink

Install
Dependencies
ocaml-system
>= "4.00.1" & < "4.00.2~"
ocaml-variants
>= "4.00.1" & < "4.00.2~"
Reverse Dependencies
0install
< "2.12.1"
abella
= "2.0.3"
acpc
!= "1.1.1"
ago
>= "0.4"
aifad
< "2.1.0"
alberto
< "0.3"
alcotest
!= "0.3.1" & < "0.4.8"
alsa
< "0.3.0"
alt-ergo
< "1.30"
altgr-ergo
< "1.30"
ancient
< "0.9.1"
ansi-parse
< "0.4.0"
ao
< "0.2.2"
arakoon
< "1.8.6"
archimedes
>= "0.4.15"
ascii85
>= "0.4"
async
< "112.17.00"
async-zmq
< "0.1.0"
async_extended
< "112.17.00"
async_extra
< "112.17.00"
async_find
< "113.24.00"
async_inotify
< "113.24.00"
async_kernel
< "112.17.00"
async_parallel
< "112.17.00"
async_shell
< "113.24.00"
async_smtp
< "113.24.00"
async_ssl
< "112.17.00"
async_unix
< "112.17.00"
atd
< "1.13.0"
atdgen
< "1.13.0"
atdj
>= "20151001.01"
aws
< "1.0.1"
aws-ec2
< "1.2"
aws-s3
< "2.0.0"
aws-sdb
< "1.2"
aws-ssm
< "1.2"
aws-sts
< "1.2"
bap-abi
< "1.4.0"
bap-api
< "1.4.0"
bap-arm
< "1.4.0"
bap-beagle
< "1.4.0"
bap-c
< "1.4.0"
bap-cache
< "1.4.0"
bap-callsites
< "1.4.0"
bap-cxxfilt
< "1.4.0"
bap-demangle
< "1.4.0"
bap-dwarf
< "1.4.0"
bap-elf
< "1.5.0"
bap-frames
< "2.1.1"
bap-frontc
< "1.4.0"
bap-frontend
< "1.4.0"
bap-future
< "1.4.0"
bap-ida
< "1.4.0"
bap-mc
< "1.4.0"
bap-microx
< "1.4.0"
bap-objdump
< "1.4.0"
bap-phoenix
< "1.4.0"
bap-piqi
< "1.4.0"
bap-primus
< "1.4.0"
bap-print
< "1.4.0"
bap-run
< "1.4.0"
bap-ssa
< "1.4.0"
bap-strings
< "1.4.0"
bap-taint
< "1.4.0"
bap-trace
< "1.4.0"
bap-traces
< "1.4.0"
bap-x86
< "1.4.0"
base-bytes
< "base"
base64
< "2.3.0"
batteries
>= "1.5.0" & != "2.3.0"
beluga
< "1.0"
bencode
< "2.0"
bibtex2html
< "1.99"
bignum
< "112.17.00"
bigstring
< "0.2"
bin_prot
< "112.17.00"
bindlib
< "6.0.0"
biniou
< "1.0.13"
biocaml
< "0.4.0" | = "0.9.0" | = "0.10.1"
bisect
< "1.3.1"
bistro
< "0.2.0"
bitcoinml
< "0.4.1"
bitstring
< "3.0.0"
bitv
!= "1.3"
bjack
< "0.1.6"
bolt
>= "1.3"
bookaml
< "3.0"
bst
>= "3.0.0"
bytearray
< "1.0.2"
cairo
>= "0.4.2"
cairo2
< "0.6"
calendar
!= "2.03.1"
caml2html
>= "1.4.3"
camlidl
< "1.07"
camlimages
< "4.2.0"
camllib
< "1.3.1"
camlp4
< "4.02+1" | = "4.02.0-1modular-implicits"
camlp5
>= "6.07" & != "6.15" & < "7.00"
camlpdf
< "2.5"
camltc
< "0.9.3"
camlzip
< "1.06"
camomile
< "0.8.6"
caqti-dynload
< "0.10.2"
cbor
< "0.5"
cconv
< "0.4"
ccss
< "1.6"
cfg
< "2.1.0"
cfstream
< "1.2.0"
cgi
< "0.9"
chamo
< "2.03"
channel
< "1.1.1"
choice
< "0.4"
clangml
< "0.5.2" | = "3.7.0.2"
cmdliner
< "1.0.0"
cohttp
< "0.13.0"
combine
>= "0.42"
conduit
< "0.6.0"
conf-ida
< "0.3"
config-file
< "1.2.1"
containers
>= "0.4" & < "1.0"
coq
!= "8.5.0~camlp4" & != "8.5.2~camlp4" & < "8.6"
coqide
< "8.6"
core
>= "109.07.00" & < "112.17.00"
core_bench
< "112.17.00"
core_extended
>= "108.00.02" & < "112.17.00"
core_kernel
< "111.11.00"
cow
< "2.0.0"
cpdf
< "2.3"
cppo
< "1.6.6"
crunch
< "2.0.0"
cry
< "0.6.4"
cryptokit
< "1.11"
cstruct
< "1.6.0"
csv
< "2.0"
ctypes
< "0.6.0" | = "0.9.1"
cubicle
< "1.1.2"
curses
< "1.0.9"
custom_printf
< "112.06.00"
datalog
< "0.6"
decoders
< "0.3.0"
delimcc
< "2017.03.02"
depext
>= "0.3"
deriving
< "0.8.1"
dispatch
< "0.4.1"
dns
< "0.17.0"
docker-api
< "0.2"
dockerfile
< "1.2.0"
dog
= "0.2.0"
dolmen
< "0.4"
dose3
< "6.1"
dssi
< "0.1.3"
dtools
< "0.4.2"
dune
>= "2.0.0" & != "2.9.2"
duppy
< "0.7.0"
duration
< "0.1.2"
dyntype
>= "0.8.3"
easy-format
< "1.3.0"
eliom
< "5.0.0"
email_message
< "112.17.00"
erssical
< "1.1.0"
exenum
< "0.86"
extlib
>= "1.5.3"
extprot
< "1.4.0"
extunix
< "0.3.1"
ezjsonm
< "1.1.0"
ezjsonm-lwt
!= "1.0.0"
FrontC
< "4.0.0"
faad
< "0.5.0"
facile
< "1.1.4"
fat-filesystem
< "0.11.0" | = "0.12.1"
fdkaac
< "0.3.2"
feather
< "0.2.0"
ffmpeg
< "0.2.0"
fftw3
< "0.8"
fiat-p256
< "0.2.0"
fieldslib
< "113.24.00"
fileutils
< "0.6.1"
fix
< "20181206"
flac
< "0.1.3"
fluent-logger
< "1.1.0"
frama-c
>= "8.0" & < "14.0"
freetds
< "0.5.2"
frei0r
< "0.1.2"
frenetic
< "2.0.0"
functory
< "0.6"
gammu
< "0.9.4"
gapi-ocaml
!= "0.3.1" & < "0.3.5"
gen
< "0.5.3"
gen-bs
< "0.1.0"
get_line
< "5.0.0"
getopts
< "0.4.0"
gettext
< "0.4.1"
gg
< "0.9.0"
git-unix
< "1.10.0"
github
< "1.1.0"
github-hooks
< "0.1.1"
glMLite
< "0.03.53"
gnuplot
< "0.5.1"
gpr
< "1.3.0"
graphics
< "3.07" | = "4.00.1"
grib
< "0.11.0"
gsl
< "1.20.0"
gstreamer
< "0.3.0"
headache
< "1.04"
heptagon
< "1.03.03"
herelib
< "112.35.00"
hevea
< "2.35"
hex
!= "0.2.0" & < "1.4.0"
hll
< "3.16"
ibx
< "0.8.0"
imagelib
< "20171028"
integers
< "0.3.0"
integration1d
< "0.5.1"
interval
< "1.5"
io-page
< "2.0.0"
io-page-unix
< "2.0.0"
io-page-xen
< "2.0.0"
iocaml
= "0.4.6"
iocaml-kernel
= "0.4.6"
ipaddr
< "2.6.0"
irc-client
< "0.6.0" | >= "0.7.0"
irc-client-lwt
>= "0.7.0"
irc-client-tls
>= "0.7.0"
irmin-mirage
< "2.0.0"
irrlicht
< "0.0.5"
iter
< "1.3"
javalib
< "2.3.4"
jbuilder
>= "transition"
jenga
< "112.17.00"
jhupllib
< "0.2.1"
jingoo
< "1.2.16"
json-wheel
< "1.0.6+safe-string"
jsonm
< "1.0.0"
KaSim
< "4.0.0"
kafka
< "0.3"
lablgl
< "1.06"
lablgtk
< "2.18.6"
lacaml
< "9.0.0"
ladspa
< "0.2.0"
lambdasoup
< "0.6.4"
lame
< "0.3.4"
lastfm
< "0.3.3"
launchd
< "1.3"
lazy-trie
< "1.2.0"
lbvs_consent
< "2.0.0"
ldap
< "2.4.1"
ledit
< "2.04"
leveldb
< "1.2.0"
libevent
< "0.8.1"
libsvm
< "0.9.3"
lilis
< "0.2.1"
linenoise
!= "1.0.0" & < "1.3.1"
liquidsoap
< "1.3.4"
lo
< "0.2.0"
lutils
< "1.44"
lutin
>= "2.71.10"
lwt
>= "2.4.0" & < "2.4.7"
lwt_log
< "1.1.1"
lwt_ppx
< "1.1.0"
lz4_chans
>= "3.0.0"
mad
< "0.5.0"
magic-mime
< "1.0.1"
markup
< "0.8.2"
mbr-format
< "0.3"
menhir
< "20141215"
merlin
= "1.3.1" | >= "1.4" & < "2.5.0"
mesh
< "0.9.0"
mesh-easymesh
< "0.9.0"
mesh-triangle
< "0.9.0"
meta_conv
< "1.1.3"
mikmatch
< "1.0.7"
mindstorm
< "0.8"
minicaml
< "0.3.1"
minicli
>= "5.0.0"
minisat
< "0.3"
mirage
< "2.0.0"
mirage-clock
< "2.0.0"
mirage-console
< "2.2.0" | = "2.3.3"
mirage-console-lwt
!= "2.3.2" & < "2.3.4"
mirage-device
< "1.2.0"
mirage-flow
< "1.5.0"
mirage-fs
< "1.0.0"
mirage-http
< "3.1.0"
mirage-nat
< "1.1.0"
mirage-net
< "1.1.1"
mirage-profile
>= "0.3" & < "0.7.0"
mirage-random
< "1.2.0"
mirage-time
< "1.3.0"
mirage-types
< "2.0.0" | >= "3.0.0" & < "3.0.7"
mirage-unix
< "2.0.0"
mirage-vnetif
< "0.4.1"
mirage-xen
< "2.0.0"
mixture
>= "0.2.1"
mkaudio
>= "1.1.0" & < "1.1.2"
mlbdd
< "0.7.2"
mlcuddidl
< "3.0.0"
mldonkey
>= "3.1.3"
mlgmpidl
< "1.2.5" | >= "1.2.6-1"
mlpost
< "0.8.2"
mm
< "0.5.0"
mmap
= "1.1.0"
mock
< "0.1.1"
mock-ounit
< "0.1.1"
molenc
>= "7.0.1" & < "15.4.0"
monads
< "1.4.0"
mparser
< "1.3"
mpp
!= "0.2.0" & < "0.3.2"
mpris
< "0.2.0"
msat
>= "0.3" & < "0.8"
msgpack
< "1.1.0"
mustache
>= "0.0.2" & < "1.0.1"
nbd
< "2.0.1"
nonstd
< "0.0.3"
num
< "1.0"
OCanren
< "0.2.0"
OCanren-ppx
< "0.3.0~alpha1"
oasis
>= "0.3.0"
obeam
= "0.1.2"
objsize
< "0.18"
obus
< "1.1.8"
ocal
< "0.2.0"
ocaml-expat
< "1.0.0"
ocaml-http
< "0.1.6"
ocaml-indent
< "1.2.1"
ocaml-lua
< "1.3"
ocaml-makefile
< "6.39.2"
ocaml-protoc
< "1.2.0"
ocaml-r
< "0.4.0"
ocaml-src
= "4.00.1"
ocaml-top
< "1.1.5"
ocaml-variants
>= "4.00.1+BER" & < "4.01.0+32bit"
ocaml-xdg-basedir
< "transition"
ocaml_plugin
< "112.17.00"
ocamlbuild
< "0.9.0"
ocamlclean
< "2.1"
ocamldap
>= "2.2"
ocamldot
< "1.1"
ocamleditor
< "1.12.0"
ocamlfind
>= "1.3.2"
ocamlfuse
< "2.7.1-cvs7"
ocamlgraph
< "2.0.0"
ocamlnet
>= "3.6.0" & < "4.1.7"
ocamlpp
< "1.1"
ocamlscript
< "3.0.0"
ocamlspot
< "4.01.0.2.2.0"
ocamltter
< "2.1.2"
ocapic
< "3.3"
ocp-browser
< "1.1.6"
ocp-build
!= "1.99.20-beta"
ocp-index
!= "1.1.0" & < "1.1.3"
ocp-pp
< "1.99.19-beta"
ocurl
< "0.8.2"
odate
< "0.6"
odepack
>= "0.6.3" & < "0.6.9"
ogen
< "0.1.2"
ogg
< "0.5.2" | = "0.6.1"
ogre
< "1.4.0"
olinq
< "0.3"
omake
< "0.9.8.7"
omd
< "1.3.1"
oni
< "1.0.11"
opam-publish
< "2.0.0"
opam2web
< "1.4.0"
openflow
< "0.2.0"
opus
< "0.2.0"
orakuda
< "1.2.0"
osc
< "0.1.4"
osdp
< "1.0.0"
ospec
>= "0.3.1"
otags
= "4.00.1"
otfm
< "0.2.0"
ott
< "0.29"
ounit
< "2.1.2"
override
>= "0.2.0" & < "0.3.0"
owl
< "0.2.0"
pa_ounit
< "112.17.00"
pa_test
< "112.24.00"
packet
< "0.4.0"
parany
>= "7.0.2" & < "12.0.2"
parmap
< "1.1.1"
patdiff
< "113.24.00"
patience_diff
< "112.24.00"
pbkdf
< "0.3.0"
pcap-format
< "0.5.2"
pcre
< "7.3.0"
pfff
< "0.29"
pgocaml
< "2.3"
piqi
< "0.7.6"
piqilib
< "0.6.14"
planck
>= "2.0.1" & < "2.2.0"
plotkicadsch
>= "0.2.0" & < "0.4.0"
pomap
< "4.0.0"
portaudio
< "0.2.2"
posix-getopt
< "2.0.0"
postgresql
< "4.1.0"
pprint
< "20171003"
ppx_bitstring
< "1.0.1"
ppx_blob
>= "0.3.0"
ppx_deriving_protobuf
!= "2.5" & < "2.7"
ppx_sexp_conv
>= "113.33.00" & < "113.33.01+4.03"
printbox
< "0.2"
proverif
< "2.01"
ptmap
!= "2.0.4"
pulseaudio
< "0.1.4"
pxp
< "1.2.8"
qbf
< "0.3"
qcheck
< "0.8"
qfs
< "0.5"
qtest
< "2.9"
randomconv
< "0.1.1"
rashell
>= "0.2.0"
rdf
< "0.9.0"
re
< "1.7.2"
re2
< "112.35.00"
react
< "1.2.1"
reactiveData
< "0.2.2"
records
>= "0.2.0" & < "0.5.0"
redis
< "0.2.1"
release
!= "1.0.2"
res
< "5.0.0"
rml
< "1.09.05"
root1d
< "0.5"
rope
< "0.6"
rpc
< "5.9.0"
rpc_parallel
< "112.17.00"
rpclib-async
!= "6.0.0"
rpclib-lwt
!= "6.0.0"
safepass
< "2.0"
samplerate
< "0.1.5"
sawja
< "1.5.3"
seq
< "base"
session
< "0.4.0"
sexplib
< "112.06.00"
sha
< "1.10"
shared-block-ring
>= "2.3.0" & < "3.0.0"
shine
< "0.2.2"
slap
< "1.0.0" | >= "2.0.1"
sodium
< "0.3.0"
sosa
< "0.2.0"
speex
< "0.4.0"
spelll
< "0.3"
spotinstall
< "1.2.0"
spotlib
>= "2.0.1" & < "2.3.0"
sqlexpr
< "0.6.1"
sqlgg
< "0.4.3"
sqlite3
< "4.2.0"
srt
< "0.1.1"
ssl
< "0.5.6"
stdint
< "0.6.0"
stog
< "0.10.0"
stog-rdf
< "0.15.0"
stog-writing
< "0.13.0"
stringext
< "1.5.0"
sundialsml
< "3.1.1p0"
syslog
< "2.0.0"
taglib
< "0.3.6"
tar-format
< "0.3.0"
tcpip
< "2.1.0"
tdk
!= "0.1.1"
text
>= "0.6"
text-tags
< "1.4.0"
textutils
< "112.17.00"
tgls
< "0.8.3"
theora
< "0.4.0"
thrift
< "0.10.0"
tiny_json
< "1.1.5"
tip-parser
< "0.5"
tophide
= "1.0.2"
treeprint
< "1.0.3"
trie
< "1.0.0"
tsdl
< "0.9.1"
tsdl-image
< "0.1.2"
tsdl-mixer
< "0.3.0"
tsdl-ttf
< "0.3"
tuntap
< "1.3.0"
type_conv
< "112.01.00"
typerep
< "112.17.00"
tyxml
< "4.0.0"
uint
< "2.0.1"
unison
< "2.51.4"
unix-errno
< "0.3.0"
unix-fcntl
< "0.3.0"
uri
< "1.9.2"
uritemplate
>= "0.2.0"
usb
< "1.3.1"
user-setup
>= "0.5"
utop
!= "1.6" & < "1.16"
uucd
< "4.0.0"
uucp
!= "1.0.0" & < "2.0.0"
uuidm
< "0.9.6"
uunf
< "1.0.0"
uutf
< "1.0.0"
variantslib
< "113.24.00"
vcardgen
< "1.2"
vchan
< "2.1.0"
vg
< "0.8.1"
vhd-format
< "0.8.0"
vlq
>= "0.2.0"
vmnet
< "1.3.2"
vorbis
< "0.7.1"
vpt
< "5.0.0"
webdav
< "1.1.5"
weberizer
< "0.7.8"
websocket
< "0.9.1"
why
>= "2.32" & < "2.35"
why3
< "0.86"
why3-base
< "0.86"
wyrd
>= "1.4.6"
xapi-rrd
>= "1.0.0" & < "1.8.2"
xen-evtchn
< "2.1.0"
xen-gnt
< "3.0.1"
xen-gnt-unix
< "3.0.1"
xenstore
< "1.3.0"
xmldiff
< "0.3.0"
xmlm
< "1.3.0"
xmlplaylist
< "0.1.5"
xtmpl
< "0.10"
yojson
>= "1.1.6" & < "1.3.0"
z3
< "4.8.14"
zarith
< "1.12"
zed
< "1.5"
zenon
< "0.8.4"
zlist
< "0.4.0"
zmq
< "5.1.0"
zmq-async
< "5.1.0"
zmq-lwt
< "5.1.0"