package cohttp

  1. Overview
  2. No Docs
HTTP library for Lwt, Async and Mirage

Install

Dune Dependency

Authors

Maintainers

Sources

v0.18.1.tar.gz
sha256=4b0cc28f12a78341c3cc97041d657ac8d82f559eb01c47a838e1da345a4a3de4
md5=ac7ab4d8cec28358e0ad0f610754c607

Description

There are several optional dependencies which activate functionality:

  • Lwt: opam install lwt cohttp
  • Lwt and SSL: opam install lwt ssl cohttp
  • Async: opam install async cohttp
  • Async and SSL: opam install async_ssl cohttp

Tags

org:mirage org:xapi-project

Published: 10 Jun 2015

Dependencies (13)

  1. ocamlbuild build
  2. magic-mime
  3. base64 >= "2.0.0" & < "3.0.0"
  4. stringext
  5. conduit >= "0.7.0" & < "0.16.0"
  6. sexplib >= "109.53.00" & < "113.01.00"
  7. fieldslib >= "109.20.00" & < "113.01.00"
  8. uri >= "1.9.0" & < "2.0.0"
  9. re
  10. cmdliner build & >= "0.9.4"
  11. ocamlfind build
  12. base-bytes
  13. ocaml >= "4.01.0" & < "5.0"

Dev Dependencies (2)

  1. alcotest with-test
  2. ounit with-test

Used by (74)

  1. aws-async
  2. aws-lwt
  3. aws-s3 < "1.1.0" | >= "2.0.0" & < "4.0.0"
  4. awsm-codegen
  5. azblob-async
  6. azure-cosmos-db
  7. bap = "0.9.9"
  8. bt
  9. c3
  10. calculon-web < "0.5"
  11. canary
  12. cca >= "0.6.2"
  13. cohttp-async >= "1.1.1" & < "2.2.0"
  14. cohttp-lwt-jsoo = "1.0.2"
  15. cohttp-mirage >= "2.0.0" & != "2.1.1" & < "2.5.5"
  16. cohttp-top >= "1.1.0" & < "2.2.0"
  17. comby-semantic
  18. cowabloga >= "0.0.9"
  19. datakit < "0.10.0"
  20. dog < "0.2.1"
  21. dropbox
  22. frenetic >= "3.3.0" & < "5.0.5"
  23. git = "1.4.10" | >= "1.5.0" & < "1.10.0"
  24. git-cohttp
  25. git-paf < "3.5.0"
  26. git-unix < "1.10.0" | = "1.11.1"
  27. github >= "1.0.0" & < "3.0.1"
  28. github-hooks < "0.2.0"
  29. github-jsoo < "3.0.1"
  30. hockmd
  31. http_router
  32. imaplet-lwt >= "0.1.3" & < "0.1.14"
  33. influxdb-async
  34. influxdb-lwt
  35. iocaml < "0.4.9"
  36. ip2location
  37. ip2locationio
  38. irmin >= "0.9.0" & != "0.11.1" & < "1.0.0"
  39. irmin-cli
  40. irmin-graphql >= "2.3.0"
  41. irmin-http >= "2.3.0"
  42. irmin-mirage-git >= "2.3.0" & < "2.8.0"
  43. irmin-unix < "0.9.9" | >= "2.3.0"
  44. ketrew >= "1.1.0" & < "3.0.0"
  45. letsencrypt < "0.3.0"
  46. links
  47. magic-trace
  48. merge-queues >= "0.2.0"
  49. message-switch >= "0.10.5.1"
  50. mirage-http = "2.0.0" | >= "2.4.0" & < "3.2.0"
  51. mirage-www >= "1.1.0"
  52. mirror
  53. nsq >= "0.2.4"
  54. ocamlapi
  55. oframl
  56. opium >= "0.10.1" & < "0.16.0"
  57. opium_kernel >= "0.18.0"
  58. podge < "0.7.0"
  59. ppx_netblob
  60. prof_spacetime < "0.2.0"
  61. quests
  62. river < "0.2"
  63. slacko < "0.13.0"
  64. sociaml-facebook-api >= "0.4.1"
  65. spotify-web-api < "0.2.1"
  66. syndic >= "1.4" & < "1.6.0"
  67. transmission-rpc
  68. usbmux < "1.3.2"
  69. vhd-tool >= "0.7.6"
  70. webmachine < "0.4.0"
  71. websocket >= "0.9.1" & != "2.2" & < "2.10"
  72. xapi-idl
  73. xe >= "0.6.3"
  74. xen-api-client >= "0.9.8"

Conflicts (5)

  1. js_of_ocaml >= "3.0"
  2. lwt >= "2.5.0"
  3. lwt < "2.4.7"
  4. async >= "113.00.00"
  5. async < "111.25.00"
OCaml

Innovation. Community. Security.