package datakit

  1. Overview
  2. No Docs
Orchestrate applications using a Git-like dataflow

Install

Dune Dependency

Authors

Maintainers

Sources

datakit-0.9.0.tbz
md5=46e4fcd1e9c05e4587ae1663518a8c74

Description

DataKit is a tool to orchestrate applications using a Git-like dataflow. It revisits the UNIX pipeline concept, with a modern twist: streams of tree-structured data instead of raw text. DataKit allows you to define complex build pipelines over version-controlled data.

DataKit is currently used as the coordination layer for HyperKit, the hypervisor component of Docker for Mac and Windows, and for the [DataKitCI][] continuous integration system.

Published: 15 Feb 2017

Dependencies (30)

  1. datakit-server >= "0.9.0" & < "0.10.0"
  2. prometheus-app
  3. irmin-watcher >= "0.2.0"
  4. mtime < "1.0.0"
  5. asl >= "0.10"
  6. win-eventlog
  7. logs >= "0.5.0"
  8. hvsock >= "0.8.1" & < "0.14.0"
  9. named-pipe >= "0.4.0"
  10. cohttp
  11. mirage-flow < "2.0.0"
  12. conduit < "0.99"
  13. lwt >= "2.7.0"
  14. result
  15. cstruct >= "2.2"
  16. camlzip >= "1.06"
  17. irmin = "0.12.0"
  18. mirage-types < "3.0.0"
  19. uri
  20. mirage-tc
  21. git >= "1.9.3"
  22. asetmap
  23. fmt
  24. astring
  25. rresult
  26. cmdliner < "1.0.0"
  27. topkg build
  28. ocamlbuild build
  29. ocamlfind build
  30. ocaml >= "4.02.0"

Dev Dependencies (3)

  1. alcotest with-test & >= "0.7.0" & < "0.8.0"
  2. datakit-github with-test & >= "0.9.0" & < "0.10.0"
  3. datakit-client with-test & >= "0.9.0" & < "0.10.0"

Used by (2)

  1. datakit-bridge-github < "0.10.0"
  2. datakit-ci < "0.10.0"

Conflicts

None

OCaml

Innovation. Community. Security.