package bap-std

  1. Overview
  2. No Docs
The Binary Analysis Platform Standard Library

Install

Dune Dependency

Authors

Maintainers

Sources

v2.4.0.tar.gz
md5=b8b1aff8c6846f2213eafc54de07b304

Description

Provides the main BAP library.

Published: 12 Dec 2021

Dependencies (34)

  1. conf-which
  2. conf-m4
  3. conf-perl
  4. conf-clang
  5. conf-gmp
  6. mmap
  7. result
  8. monads = "2.4.0"
  9. ogre = "2.4.0"
  10. cmdliner >= "0.9.8"
  11. zarith
  12. uuidm
  13. utop build & >= "2.0.0"
  14. uri
  15. regular = "2.4.0"
  16. ppx_bap >= "v0.14" & < "v0.15"
  17. ocamlfind >= "1.5.6" & < "2.0"
  18. oasis build & >= "0.4.7"
  19. graphlib = "2.4.0"
  20. fileutils
  21. bin_prot >= "v0.14" & < "v0.15"
  22. core_kernel >= "v0.14" & < "v0.15"
  23. camlzip >= "1.07"
  24. bap-relation = "2.4.0"
  25. bap-plugins = "2.4.0"
  26. bap-main = "2.4.0"
  27. bap-bundle = "2.4.0"
  28. bap-core-theory = "2.4.0"
  29. bitvec-order = "2.4.0"
  30. bitvec = "2.4.0"
  31. bap-knowledge = "2.4.0"
  32. bap-future = "2.4.0"
  33. base-unix
  34. ocaml >= "4.08.0"

Dev Dependencies

None

Used by (88)

  1. bap-abi = "2.4.0"
  2. bap-analyze = "2.4.0"
  3. bap-api = "2.4.0"
  4. bap-arm = "2.4.0"
  5. bap-beagle = "2.4.0"
  6. bap-beagle-strings = "2.4.0"
  7. bap-bil = "2.4.0"
  8. bap-byteweight = "2.4.0"
  9. bap-byteweight-frontend = "2.4.0"
  10. bap-c = "2.4.0"
  11. bap-cache = "2.4.0"
  12. bap-callgraph-collator = "2.4.0"
  13. bap-callsites = "2.4.0"
  14. bap-constant-tracker = "2.4.0"
  15. bap-core < "2.5.0"
  16. bap-cxxfilt = "2.4.0"
  17. bap-demangle = "2.4.0"
  18. bap-dependencies = "2.4.0"
  19. bap-disassemble = "2.4.0"
  20. bap-dump-symbols = "2.4.0"
  21. bap-dwarf = "2.4.0"
  22. bap-elementary = "2.4.0"
  23. bap-elf = "2.4.0"
  24. bap-flatten < "2.5.0"
  25. bap-frames >= "2.1.2"
  26. bap-frontc = "2.4.0"
  27. bap-frontend = "2.4.0"
  28. bap-fsi-benchmark = "2.4.0"
  29. bap-ghidra < "2.5.0"
  30. bap-glibc-runtime = "2.4.0"
  31. bap-llvm = "2.4.0"
  32. bap-mc = "2.4.0"
  33. bap-microx = "2.4.0"
  34. bap-mips = "2.4.0"
  35. bap-objdump = "2.4.0"
  36. bap-optimization = "2.4.0"
  37. bap-patterns < "2.5.0"
  38. bap-phoenix = "2.4.0"
  39. bap-piqi = "2.4.0"
  40. bap-powerpc = "2.4.0"
  41. bap-primus = "2.4.0"
  42. bap-primus-dictionary = "2.4.0"
  43. bap-primus-exploring-scheduler = "2.4.0"
  44. bap-primus-greedy-scheduler = "2.4.0"
  45. bap-primus-limit = "2.4.0"
  46. bap-primus-lisp = "2.4.0"
  47. bap-primus-loader = "2.4.0"
  48. bap-primus-mark-visited = "2.4.0"
  49. bap-primus-powerpc = "2.4.0"
  50. bap-primus-print = "2.4.0"
  51. bap-primus-promiscuous = "2.4.0"
  52. bap-primus-propagate-taint = "2.4.0"
  53. bap-primus-random = "2.4.0"
  54. bap-primus-region = "2.4.0"
  55. bap-primus-round-robin-scheduler = "2.4.0"
  56. bap-primus-symbolic-executor = "2.4.0"
  57. bap-primus-systems = "2.4.0"
  58. bap-primus-taint = "2.4.0"
  59. bap-primus-test = "2.4.0"
  60. bap-primus-track-visited = "2.4.0"
  61. bap-primus-wandering-scheduler = "2.4.0"
  62. bap-primus-x86 = "2.4.0"
  63. bap-print = "2.4.0"
  64. bap-radare2 = "2.4.0"
  65. bap-raw = "2.4.0"
  66. bap-recipe-command = "2.4.0"
  67. bap-relocatable = "2.4.0"
  68. bap-report = "2.4.0"
  69. bap-riscv = "2.4.0"
  70. bap-run = "2.4.0"
  71. bap-saluki >= "bap-1.6"
  72. bap-specification = "2.4.0"
  73. bap-ssa = "2.4.0"
  74. bap-stub-resolver = "2.4.0"
  75. bap-symbol-reader = "2.4.0"
  76. bap-systemz = "2.4.0"
  77. bap-taint = "2.4.0"
  78. bap-taint-propagator = "2.4.0"
  79. bap-term-mapper = "2.4.0"
  80. bap-thumb = "2.4.0"
  81. bap-toplevel < "2.5.0"
  82. bap-trace = "2.4.0"
  83. bap-traces = "2.4.0"
  84. bap-trivial-condition-form = "2.4.0"
  85. bap-veri = "0.2.4"
  86. bap-warn-unused = "2.4.0"
  87. bap-x86 = "2.4.0"
  88. fkie-cad-cwe-checker < "0.2"

Conflicts (2)

  1. jbuilder = "1.0+beta18"
  2. fileutils = "0.5.0"
OCaml

Innovation. Community. Security.