package uri

  1. Overview
  2. Docs
RFC3986 URI/URL parsing library

Install

Dune Dependency

Authors

Maintainers

Sources

v1.9.2.tar.gz
md5=e6dd39352b1b501cb905ef7d198d38f0

Description

RFC3986 URI/URL parsing library

Dependencies (9)

  1. ocamlbuild build
  2. stringext >= "1.4.0"
  3. base-bytes
  4. ppx_sexp_conv >= "113.33.01"
  5. ppx_deriving
  6. sexplib >= "109.53.00"
  7. re
  8. ocamlfind build
  9. ocaml >= "4.02.2" & < "4.06.0"

Dev Dependencies (1)

  1. ounit with-test & >= "1.0.2"

  1. amqp-client-async >= "2.1.0"
  2. amqp-client-lwt >= "2.1.0"
  3. arakoon >= "1.9.0"
  4. archetype < "0.1.5" | >= "1.2.10"
  5. async_js >= "v0.10.0" & < "v0.12.0"
  6. aws >= "1.0.0" & < "1.2"
  7. aws-s3 >= "4.0.0"
  8. azblob
  9. azure-cosmos-db
  10. bap >= "0.9.4" & < "1.0.0"
  11. bap-bundle
  12. bap-byteweight >= "2.2.0"
  13. bap-plugins >= "2.2.0"
  14. bap-server < "0.2.0"
  15. bap-std
  16. bap-trace >= "2.2.0"
  17. bap-traces
  18. bap-veri
  19. biocaml >= "0.4.0"
  20. bt
  21. builder-web
  22. calculon-web
  23. capnp-rpc-lwt >= "0.2"
  24. capnp-rpc-net
  25. caqti < "2.0.1"
  26. carbon
  27. cohttp >= "0.10.1" & < "1.2.0"
  28. cohttp-async < "1.2.0"
  29. cohttp-eio
  30. conduit >= "0.6.0" & != "3.0.0"
  31. cookie
  32. cow >= "0.5.4"
  33. datakit < "0.12.2"
  34. datakit-bridge-github < "0.12.2"
  35. datakit-ci < "0.12.2"
  36. datakit-client < "0.11.0"
  37. datakit-github
  38. datakit-server < "0.11.0"
  39. dns < "0.7.0" | >= "0.15.0" & < "4.0.0"
  40. dropbox < "0.2"
  41. ezresto
  42. facebook-sdk
  43. gemini
  44. git < "3.0.0"
  45. git-mirage >= "3.7.0"
  46. git-paf
  47. git-unix >= "3.0.0"
  48. github >= "0.3.1"
  49. gitlab
  50. hvsock >= "2.0.0"
  51. hyper
  52. icalendar
  53. ip2locationio
  54. irmin
  55. irmin-cli
  56. irmin-git >= "2.3.0"
  57. irmin-http >= "2.3.0"
  58. irmin-mirage-git >= "2.3.0"
  59. irmin-mirage-graphql >= "2.3.0"
  60. irmin-server
  61. irmin-unix >= "2.3.0"
  62. json-data-encoding
  63. ketrew
  64. lambda-runtime
  65. letsencrypt >= "0.3.0"
  66. links >= "0.9"
  67. liquidsoap >= "2.1.1" & < "2.2.0"
  68. liquidsoap-core
  69. mechaml
  70. message-switch
  71. minima-theme
  72. mirage-block-unix >= "2.4.0"
  73. monorobot
  74. moss
  75. nbd >= "2.0.1"
  76. nbd-tool
  77. obi
  78. ocplib-json-typed
  79. oidc
  80. omigrate
  81. opam-query
  82. opam2web >= "1.3.0"
  83. opamfu
  84. opium_kernel < "0.17.1"
  85. paf
  86. paf-cohttp
  87. piaf
  88. rdf >= "0.10.0" & < "0.12.0"
  89. resto
  90. resto-acl
  91. resto-cohttp-client
  92. resto-cohttp-self-serving-client
  93. scgi
  94. sentry
  95. sociaml-facebook-api
  96. sociaml-oauth-client
  97. sociaml-tumblr-api
  98. spotify-web-api
  99. stog >= "0.17.0" & < "0.19.0"
  100. syndic
  101. textrazor
  102. tezos-stdlib-unix < "7.4"
  103. tezos-test-helpers >= "10.2" & < "14.0"
  104. trakeva >= "0.1.0"
  105. validate
  106. vhd-tool
  107. wamp
  108. xapi-idl
  109. xe
  110. xen-api-client
  111. xentropyd

Conflicts

None