package core_kernel

  1. Overview
  2. Docs
Industrial strength alternative to OCaml's standard library

Install

Dune Dependency

Authors

Maintainers

Sources

v0.11.1.tar.gz
md5=2946775ce7660e026996d55da9c10b83

Description

The Core suite of libraries is an industrial strength alternative to OCaml's standard library that was developed by Jane Street, the largest industrial user of OCaml.

Core_kernel is the system-independent part of Core.

Published: 14 Jul 2018

README

Portable standard library for OCaml

Core is an industrial-strength alternative to the OCaml standard library. It was developed by Jane Street, which is the largest industrial user of OCaml.

Core_kernel is the system-independent part of Core, Jane Street's industrial-strength alternative to the OCaml standard library. It is aimed for cases when the full Core is not available, such as in Javascript. It provides an overlay on the usual namespace, so the best way to use it is to start your file with:

open Core_kernel

Relationship to Core and Base

In sum:

  • Base: Minimal stdlib replacement. Portable and lightweight and intended to be highly stable.

  • Core_kernel: Extension of Base. More fully featured, with more code and dependencies, and APIs that evolve more quickly. Portable, and works on Javascript.

  • Core: Core_kernel extended with UNIX APIs.

While Core is an extension of Core_kernel, you can think of Core_kernel as an extension of Base. Many of Core_kernel's modules are extensions of modules in Base, where the Core_kernel version adds bin_io support or locks in an API with Stable. Some modules, like Core_kernel.Map, extend their Base equivalents to follow Core conventions for the use of comparators.

Please report bugs and feature requests on GitHub. For everything else you can contact us at ocaml-core@googlegroups.com.

You can find all of Jane Street's open-source libraries on GitHub.

Documentation can be found here.

Dependencies (20)

  1. ocaml-migrate-parsetree >= "1.0" & < "2.0.0"
  2. jbuilder >= "1.0+beta18.1"
  3. variantslib >= "v0.11" & < "v0.12"
  4. typerep >= "v0.11" & < "v0.12"
  5. stdio >= "v0.11" & < "v0.12"
  6. splittable_random >= "v0.11" & < "v0.12"
  7. sexplib >= "v0.11" & < "v0.12"
  8. ppx_sexp_message >= "v0.11" & < "v0.12"
  9. ppx_sexp_conv >= "v0.11" & < "v0.12"
  10. ppx_jane >= "v0.11" & < "v0.12"
  11. ppx_inline_test >= "v0.11" & < "v0.12"
  12. ppx_hash >= "v0.11" & < "v0.12"
  13. ppx_base >= "v0.11" & < "v0.12"
  14. ppx_assert >= "v0.11" & < "v0.12"
  15. jane-street-headers >= "v0.11" & < "v0.12"
  16. fieldslib >= "v0.11" & < "v0.12"
  17. configurator >= "v0.11" & < "v0.12"
  18. bin_prot >= "v0.11" & < "v0.12"
  19. base >= "v0.11" & < "v0.12"
  20. ocaml >= "4.04.1" & < "4.12.0"

Dev Dependencies

None

Used by (73)

  1. alcotest-async < "1.6.0"
  2. async_durable = "v0.11.0"
  3. async_kernel >= "v0.11.0" & < "v0.12.0"
  4. async_rpc_kernel = "v0.11.0"
  5. aws-s3-async = "3.0.0"
  6. bap-build < "2.1.0"
  7. bap-bundle < "2.1.0"
  8. bap-demangle >= "1.6.0" & < "2.1.0"
  9. bap-frames >= "2.1.2"
  10. bap-future >= "1.6.0" & < "2.1.0"
  11. bap-ida >= "1.6.0" & < "2.1.0"
  12. bap-mc = "2.0.0"
  13. bap-plugins < "2.1.0"
  14. bap-primus-powerpc < "2.1.0"
  15. bap-raw < "2.1.0"
  16. bap-server >= "0.3.0"
  17. bap-std >= "1.6.0" & < "2.1.0"
  18. bap-strings >= "1.6.0" & < "2.1.0"
  19. bap-veri >= "0.2.3" & < "0.2.5"
  20. bare >= "1.6.0" & < "2.1.0"
  21. bignum = "v0.11.0"
  22. biocaml = "0.9.0"
  23. capnp >= "3.0.0" & != "3.2.0" & < "3.3.0"
  24. caqti-async >= "1.2.0" & < "1.9.0"
  25. cfstream >= "1.3.0"
  26. clp_operations
  27. comby-kernel
  28. comby-semantic
  29. core >= "v0.11.0" & < "v0.12.0"
  30. core-lwt >= "0.3.0"
  31. core_extended = "v0.11.0"
  32. cstruct-async >= "3.0.2" & < "6.1.0"
  33. cwe_checker
  34. ecaml = "v0.11.0"
  35. email_message = "v0.11.0"
  36. expect_test_helpers_kernel = "v0.11.0"
  37. flowtype >= "0.87.0"
  38. git < "1.3.0"
  39. graphlib >= "1.6.0" & < "2.1.0"
  40. hack_parallel = "1.0.0"
  41. incr_dom = "v0.11.0"
  42. incr_map = "v0.11.0"
  43. incr_select = "v0.11.0"
  44. incremental_kernel >= "v0.11.0"
  45. irmin < "0.9.0"
  46. jsonxt
  47. lablqt
  48. libsvm = "0.9.3" | >= "0.10.0"
  49. mlt_parser = "v0.11.0"
  50. mmseg < "transition"
  51. monads >= "1.6.0" & < "2.1.0"
  52. ogre >= "1.6.0" & < "2.1.0"
  53. oloop
  54. opium >= "0.12.0" & < "0.15.0"
  55. patience_diff = "v0.11.0"
  56. plotkicadsch >= "0.2.0" & < "0.8.0"
  57. polars
  58. portmidi
  59. protocol_version_header = "v0.11.0"
  60. re2 = "v0.11.0"
  61. record_builder = "v0.11.0"
  62. reed-solomon-erasure
  63. regular >= "1.6.0" & < "2.1.0"
  64. sociaml-facebook-api
  65. sociaml-oauth-client
  66. sociaml-tumblr-api >= "0.2.0"
  67. splay_tree = "v0.11.0"
  68. text-tags >= "1.6.0" & < "2.1.0"
  69. textutils_kernel = "v0.11.0"
  70. tidy >= "1-4.9.30-0.1.1"
  71. toplevel_expect_test = "v0.11.0"
  72. topology >= "0.4.0"
  73. travesty < "0.3.0"

Conflicts (1)

  1. jbuilder = "1.0+beta19"
OCaml

Innovation. Community. Security.