core

Industrial strength alternative to OCaml's standard library
README

Core is an industrial-strength alternative to the OCaml standard
library. It was developed by Jane Street, which is the largest
industrial user of OCaml.

Core provides an overlay on the usual namespace, so the best way to
use Core is to start your file with:

open Core

In the case of bugs, feature requests and similar, you can contact us at
opensource@janestreet.com. You can find all of Jane Street's
open-source libraries on
our github account. Documentation can
be found
here.

Install
Sources
core-v0.11.3.tbz
md5=89ca9e9aa9f1742790efb5016cc5d69b
Dependencies
ppxlib
>= "0.1.0" & < "0.9.0"
ocaml-migrate-parsetree
>= "1.0" & < "2.0.0"
jbuilder
>= "1.0+beta18.1"
stdio
>= "v0.11" & < "v0.12"
spawn
>= "v0.12"
sexplib
>= "v0.11" & < "v0.12"
ppx_jane
>= "v0.11" & < "v0.12"
ppx_assert
>= "v0.11" & < "v0.12"
core_kernel
>= "v0.11" & < "v0.12"
configurator
>= "v0.11" & < "v0.12"
base
>= "v0.11" & < "v0.12"
ocaml
>= "4.04.1" & < "4.12.0"
Reverse Dependencies
alcotest-async
>= "1.3.0" & < "1.6.0"
arakoon
>= "1.9.17"
async
= "v0.11.0"
async-zmq
>= "0.1.0"
async_extended
>= "v0.11.0"
async_extra
< "108.00.02" | >= "v0.11.0" & < "v0.12.0"
async_find
= "v0.11.0"
async_inotify
= "v0.11.0"
async_parallel
>= "v0.11.0"
async_sendfile
= "v0.11.0"
async_shell
= "v0.11.0"
async_smtp
= "v0.11.0"
async_ssl
= "v0.11.0"
async_unix
< "108.00.02" | = "v0.11.0"
aws-s3
< "1.1.0" | >= "2.0.0" & < "4.0.0"
bistro
< "0.2.0" | = "0.4.0"
capnp
>= "3.0.0" & < "3.3.0"
caqti-async
< "1.2.0"
cohttp-async
>= "1.1.1"
command_rpc
= "v0.11.0"
conduit-async
>= "1.2.0"
core_bench
= "v0.11.0"
core_extended
= "v0.11.0"
core_profiler
= "v0.11.0"
cstruct-async
>= "6.1.0"
csvfields
= "v0.11.0"
email_message
= "v0.11.0"
facebook-sdk
>= "0.3.1"
flow
< "0.2"
frenetic
= "2.0.0" | >= "3.1.0" & < "5.0.0" | = "5.0.3"
gnuplot
= "0.5.3"
gpr
!= "1.2.2" & < "1.5.0"
hack_parallel
!= "1.0.0"
horned_worm
>= "0.3.1" & < "0.3.7"
ibx
< "0.5.9" | = "0.7.2" | >= "0.8.0"
incremental
= "v0.11.0"
jenga
>= "v0.11.0"
libsvm
< "0.9.3"
line-up-words
< "v0.12.0"
ocaml_plugin
= "v0.11.0"
openflow
>= "0.3.0" & < "0.9.0"
opium
< "0.12.0"
osbx
< "1.1.1"
ox
>= "1.1.0"
patdiff
= "v0.11.0"
pg_query
< "0.9.6"
ppx_bitstring
< "1.3.0"
ppx_rapper
< "1.0.1"
primes
< "1.3.5"
resource_cache
< "v0.12.0"
riakc
>= "1.0.0"
riakc_ppx
!= "3.1.3"
rpc_parallel
= "v0.11.0"
satyrographos
< "0.0.2.7"
sifun
< "3.0.0"
textutils
= "v0.11.0"
tldr
< "0.3.0"
tube
< "4.1.1"