package lwt

  1. Overview
  2. No Docs
A cooperative threads library for OCaml

Install

Authors

Maintainers

Sources

2.4.6.tar.gz
md5=46d7efc6326628cca3f4a28628920176

Description

This library is part of the Ocsigen project. See:

http://ocsigen.org/lwt

Published: 15 Oct 2014

Dev Dependencies

None

  1. 0install != "2.12.3"
  2. alcotest-lwt
  3. alcotest-mirage
  4. ambient-context-lwt
  5. amqp-client >= "0.9.0" & < "1.0.2" | >= "1.1.0"
  6. amqp-client-lwt
  7. angstrom-lwt-unix
  8. anthill
  9. anycache-lwt
  10. arakoon < "1.8.6"
  11. archi-lwt
  12. arp >= "2.3.1"
  13. arp-mirage < "2.0.0" | >= "2.2.0"
  14. awa-lwt
  15. awa-mirage < "0.2.0"
  16. aws < "1.0.0"
  17. aws-s3-lwt
  18. awsm-lwt
  19. azure-cosmos-db
  20. baardskeerder
  21. balancer
  22. bap < "1.0.0"
  23. bap-server < "0.2.0"
  24. bimage-lwt
  25. biocaml >= "0.3.0" & < "0.5.0"
  26. bistro < "0.5.0"
  27. brotli < "1.2.0"
  28. brozip
  29. bt
  30. builder
  31. bun >= "0.3.3"
  32. c3
  33. calculon
  34. camltc < "0.9.5"
  35. canary
  36. capnp-rpc-lwt < "1.2.3"
  37. capnp-rpc-unix >= "0.9.0" & < "1.2.3"
  38. caqti-lwt < "0.11.0"
  39. carton-git
  40. carton-lwt
  41. charrua-client-lwt < "1.2.0"
  42. charrua-client-mirage < "1.2.0"
  43. charrua-core < "0.3"
  44. charrua-unix >= "0.3" & < "0.9"
  45. cmdtui-lambda-term
  46. coclobas != "0.0.1"
  47. cohttp = "0.11.1"
  48. cohttp-lwt != "1.0.0" & < "2.0.0" | = "2.5.8"
  49. cohttp-mirage
  50. comby
  51. comby-semantic
  52. conan-lwt
  53. conduit-lwt = "3.0.0"
  54. core-lwt < "0.2.0"
  55. cowabloga != "0.1.0"
  56. crunch >= "2.0.0"
  57. cstruct-lwt < "3.0.0" | >= "3.0.2"
  58. ctypes >= "0.6.0" & < "0.6.2"
  59. curly < "0.2.0"
  60. current_docker < "0.6.4"
  61. current_examples < "0.6.4"
  62. current_git < "0.6.4"
  63. current_github < "0.6.4"
  64. current_gitlab < "0.6.4"
  65. current_ocluster < "0.2"
  66. current_slack < "0.6.4"
  67. current_web < "0.6.4"
  68. DkSDKFFIOCaml_Std
  69. dap
  70. data-encoding < "0.1.1"
  71. datakit < "0.9.0"
  72. datakit-client = "0.11.0"
  73. datakit-github < "0.9.0"
  74. datakit-server < "0.11.0"
  75. dht < "0.2.0"
  76. distributed < "0.4.0"
  77. dkim-mirage
  78. dns < "0.5.0" | >= "0.6.1" & < "0.15.2" | >= "0.19.1" & < "1.0.0"
  79. dnssd
  80. docker_hub
  81. dog
  82. dream
  83. dream-httpaf
  84. dream-pure
  85. dropbox
  86. dune_watch
  87. earlybird < "1.0.0"
  88. eliom = "6.3.0"
  89. eris-lwt
  90. ezcurl-lwt
  91. ezirmin
  92. ezjsonm >= "0.4.2" & < "0.5.0"
  93. ezresto
  94. facebook-sdk
  95. faraday-lwt
  96. faraday-lwt-unix < "0.6.0"
  97. fat-filesystem
  98. fiber-lwt
  99. flow
  100. frenetic < "2.0.0"
  101. fswatch_lwt
  102. gamepad
  103. gdb
  104. gdbprofiler < "0.3"
  105. git < "1.4.4" | >= "3.0.0"
  106. git-paf
  107. git-unix = "1.11.1" | >= "3.0.0" & < "3.10.0"
  108. github
  109. github-hooks
  110. github-unix >= "4.4.0"
  111. gitlab-unix
  112. gluten-lwt < "0.4.0"
  113. gluten-lwt-unix < "0.4.0"
  114. gluten-mirage < "0.4.0"
  115. graphql-lwt
  116. gufo
  117. h2-lwt < "0.10.0"
  118. h2-lwt-unix < "0.10.0"
  119. h2-mirage
  120. happy-eyeballs-lwt
  121. happy-eyeballs-mirage
  122. hardcaml < "1.1.0"
  123. hardcaml-examples >= "0.3.0"
  124. hardcaml-framework
  125. hardcaml-waveterm
  126. hiredis = "0.4"
  127. http-lwt-client
  128. http-multipart-formdata >= "2.0.0" & < "3.0.0"
  129. http2https
  130. i3ipc
  131. imaplet-lwt
  132. influxdb-lwt
  133. inotify >= "2.4"
  134. inquire < "0.3.0"
  135. iocaml
  136. iocaml-kernel >= "0.4.3"
  137. iocamljs-kernel
  138. ip2location
  139. ip2locationio
  140. ipv6-multicast < "0.9"
  141. irc-client-lwt-ssl >= "0.7.0"
  142. irc-client-tls
  143. irmin < "0.9.3"
  144. irmin-bench < "2.7.0"
  145. irmin-chunk < "2.7.0"
  146. irmin-containers < "2.7.0"
  147. irmin-fs >= "2.3.0" & < "2.7.0"
  148. irmin-git >= "2.3.0" & < "2.7.0"
  149. irmin-graphql >= "2.3.0" & < "2.7.0"
  150. irmin-http >= "2.3.0" & < "2.7.0"
  151. irmin-indexeddb
  152. irmin-layers < "2.7.0"
  153. irmin-mem >= "2.3.0"
  154. irmin-mirage-git >= "2.3.0" & < "2.7.0"
  155. irmin-mirage-graphql >= "2.3.0" & < "2.7.0"
  156. irmin-pack < "2.7.0"
  157. irmin-test >= "2.3.0" & < "2.7.0"
  158. irmin-unix >= "2.3.0" & < "2.7.0"
  159. irmin-watcher = "0.2.0" | >= "0.4.0"
  160. iso-filesystem
  161. jitsu
  162. joolog
  163. jose < "0.9.0"
  164. js_of_ocaml < "3.0"
  165. js_of_ocaml-lwt
  166. jsoo_broadcastchannel >= "2.0.0"
  167. jsoo_storage
  168. jupyter < "1.0.2"
  169. jupyter-archimedes < "2.3.2"
  170. jupyter-kernel
  171. KaSim >= "4.0.0"
  172. kafka >= "0.3" & < "0.5"
  173. kafka_lwt
  174. ke >= "0.5"
  175. ketrew
  176. kinetic-client < "0.0.9"
  177. lablqml < "0.6"
  178. lambda-runtime
  179. lambda-term < "1.11"
  180. launchd
  181. libres3
  182. links < "0.7.3"
  183. lwt-binio
  184. lwt-dllist
  185. lwt-exit
  186. lwt-parallel < "0.1.2"
  187. lwt-pipe
  188. lwt-pipeline < "0.2"
  189. lwt-watcher
  190. lwt-zmq
  191. lwt_camlp4
  192. lwt_eio < "0.4"
  193. lwt_log < "1.1.0"
  194. lwt_named_threads
  195. lwt_ppx
  196. lwt_ppx_let
  197. macaque_lwt
  198. maki >= "0.1.1"
  199. mariadb < "0.5.1"
  200. markup = "0.7.6"
  201. markup-lwt
  202. mbr-format
  203. mdx
  204. mechaml
  205. metrics-influx < "0.4.0"
  206. metrics-lwt >= "0.2.0" & < "0.4.0"
  207. metrics-mirage
  208. metrics-unix >= "0.2.0" & < "0.4.0"
  209. mindstorm-lwt
  210. mirage < "0.9.1" | >= "0.10.0" & < "2.7.0"
  211. mirage-block < "1.0.0"
  212. mirage-block-ccm
  213. mirage-block-ramdisk
  214. mirage-block-solo5
  215. mirage-block-unix < "2.5.0"
  216. mirage-block-xen
  217. mirage-bootvar-solo5 >= "0.2.0"
  218. mirage-bootvar-unix
  219. mirage-bootvar-xen >= "0.4.0"
  220. mirage-clock-freestanding < "3.0.0"
  221. mirage-clock-lwt
  222. mirage-clock-unix >= "1.2.0" & < "3.0.0"
  223. mirage-console >= "2.1.1" & < "2.2.0"
  224. mirage-console-lwt
  225. mirage-console-solo5 >= "0.2.0"
  226. mirage-console-unix >= "2.3.5" & < "3.0.0"
  227. mirage-console-xen >= "5.0.0"
  228. mirage-console-xen-backend < "3.0.1"
  229. mirage-console-xen-cli
  230. mirage-dns < "3.0.0"
  231. mirage-entropy < "0.5.0"
  232. mirage-entropy-unix
  233. mirage-entropy-xen != "0.2.0"
  234. mirage-flow < "1.0.3"
  235. mirage-flow-lwt
  236. mirage-flow-rawlink
  237. mirage-flow-unix < "2.0.0"
  238. mirage-fs-lwt != "1.2.0"
  239. mirage-fs-unix != "1.2.1"
  240. mirage-http
  241. mirage-http-unix
  242. mirage-http-xen
  243. mirage-kv-lwt
  244. mirage-kv-unix
  245. mirage-logs
  246. mirage-nat < "3.0.0"
  247. mirage-net-fd
  248. mirage-net-lwt
  249. mirage-net-macosx
  250. mirage-net-solo5
  251. mirage-net-unix
  252. mirage-net-xen
  253. mirage-os-shim >= "3.0.0"
  254. mirage-profile
  255. mirage-protocols-lwt
  256. mirage-qubes
  257. mirage-qubes-ipv4
  258. mirage-random-stdlib >= "0.1.0"
  259. mirage-solo5
  260. mirage-stack-lwt
  261. mirage-time-lwt
  262. mirage-time-unix < "2.0.0"
  263. mirage-types-lwt < "3.7.1"
  264. mirage-unix < "3.0.0" | >= "3.0.8"
  265. mirage-vnetif
  266. mirage-vnetif-stack
  267. mirage-www >= "1.1.0"
  268. mirage-xen < "3.0.0" | >= "3.0.6"
  269. mirror
  270. mpris = "0.1.1"
  271. mqtt < "0.0.2"
  272. mrmime >= "0.5.0"
  273. multipart-form-data >= "0.2.0"
  274. multipart_form >= "0.2.0" & < "0.4.0"
  275. multipart_form-lwt
  276. nanomsg
  277. nbd < "2.1.3" | = "3.0.0"
  278. netchannel
  279. nocrypto >= "0.5.4"
  280. noise
  281. nottui-lwt
  282. nproc
  283. nsq < "0.2.4"
  284. obigstore
  285. obrowser
  286. obuilder < "0.4"
  287. obus < "1.1.8"
  288. ocaml-variants >= "4.00.1+mirage-unix" & < "4.00.1+open-types"
  289. ocluster < "0.2"
  290. ocluster-api < "0.2"
  291. ocplib-concur
  292. ocplib-resto
  293. ocsigen-start = "1.1.0" | >= "4.1.0" & < "4.7.0"
  294. ocsigen-toolkit = "1.1.0"
  295. ocsigenserver < "2.7"
  296. odoc >= "2.0.0" & < "2.1.0"
  297. ojquery
  298. ojs-base < "0.3.0"
  299. opam-compiler
  300. opam-publish = "0.3.5"
  301. opam-sync-github-prs
  302. openflow < "0.2.0"
  303. opium >= "0.11.0" & < "0.19.0"
  304. opium_kernel
  305. order-i3-xfce
  306. oskel >= "0.3.0"
  307. ounit-lwt < "2.2.0"
  308. ounit2-lwt < "2.2.7"
  309. ox < "1.1.0"
  310. paf
  311. paf-cohttp
  312. pcap-format >= "0.3.3" & < "0.5.0"
  313. pgx_lwt
  314. pgx_lwt_mirage
  315. pgx_lwt_unix < "2.0"
  316. plotkicadsch < "0.2.0" | >= "0.4.0"
  317. ppx_defer >= "0.4.0"
  318. ppx_netblob
  319. ppx_rapper_lwt
  320. ppx_sqlexpr
  321. prof_spacetime
  322. pvem_lwt_unix < "0.0.2"
  323. qcow < "0.11.0"
  324. qcow-format
  325. qcow-tool
  326. qfs >= "0.5" & < "0.7"
  327. quests
  328. receive-mail
  329. redis-lwt < "0.5"
  330. release < "1.1.1"
  331. resp >= "0.10.0"
  332. resp-mirage >= "0.10.0"
  333. resp-unix >= "0.10.0"
  334. resto
  335. riak
  336. ringo-lwt
  337. river >= "0.2"
  338. rpc >= "1.5.1" & < "7.1.0"
  339. rpclib-js
  340. sanddb >= "0.3.0"
  341. scgi
  342. sendmail-lwt
  343. session-cohttp-lwt
  344. session-cookie-lwt
  345. session-postgresql-lwt < "0.4.1"
  346. sessions
  347. shared-block-ring
  348. shared-memory-ring < "2.0.0"
  349. shared-memory-ring-lwt
  350. skkserv-lite
  351. slacko < "0.13.0"
  352. sociaml-facebook-api
  353. sociaml-oauth-client
  354. sociaml-tumblr-api
  355. spin < "0.6.0"
  356. spotify-cli
  357. spotify-web-api < "0.2.1"
  358. sqlexpr
  359. statsd-client
  360. syndic >= "1.4" & < "1.6.0"
  361. tar-format >= "0.4.1"
  362. tar-mirage < "2.2.0"
  363. tar-unix
  364. tezos-p2p >= "11.0" & < "13.0"
  365. tezos-stdlib < "9.0"
  366. themoviedb
  367. tlstunnel < "0.2.0"
  368. transmission-rpc
  369. tube < "4.0"
  370. tuntap >= "1.0.0" & < "2.0.0"
  371. typerex-lldb
  372. u2f
  373. usb < "1.3.1"
  374. uspf
  375. uspf-lwt
  376. utop >= "1.4.0"
  377. vchan >= "0.9.6" & < "2.0.3"
  378. vercel
  379. vhd-format < "0.9.1"
  380. vhd-format-lwt < "0.12.0"
  381. vhd-tool
  382. vmnet
  383. vpnkit < "0.1.1"
  384. vue-jsoo < "0.3"
  385. webauthn
  386. websocket < "0.9.1"
  387. websocket-lwt = "2.11"
  388. xapi-idl
  389. xe
  390. xe-unikernel-upload
  391. xen-api-client
  392. xen-block-driver
  393. xen-evtchn != "1.0.7"
  394. xen-evtchn-unix
  395. xen-gnt
  396. xenctrl
  397. xenstore
  398. xenstore_transport
  399. xentropyd
  400. yurt = "0.4"
  401. zbar
  402. zmq-lwt < "5.1.4"

Conflicts (3)

  1. ssl >= "0.5.0"
  2. react < "1.0.0"
  3. ocaml-variants = "4.02.1+BER"