ounit2-lwt

OUnit testing framework (Lwt)
README


OUnit is a unit test framework for OCaml. It allows one to easily create
unit-tests for OCaml code. It is loosely based on HUnit, a unit testing
framework for Haskell. It is similar to JUnit, and other XUnit testing
frameworks.

Features:

  • colored output

  • JUnit report generation

  • HTML report generation

Installation

The recommended way to install ounit is via the opam package manager:

$ opam install ounit2

Documentation

API documentation is
available online.

Examples

Transition to ounit2

In the past OUnit used the ocamlfind package name "oUnit". It is uncommon to
use uppercase letters in ocamlfind package name. It caused some problems during
the transition to "dune". It was also not the same name as the OPAM package. As
of version 2.2, the opam package ounit and the ocamlfind package oUnit are
renamed to ounit2 (the same for both the ocamlfind and opam packages).

To do the transition for your own tests:

  • in OPAM, the library should now depends on "ounit2" or "ounit2-lwt"

  • in dune files/OASIS/Makefile/pkg.ml replace "oUnit" by "ounit2" and
    "ounit-lwt" to "ounit2-lwt".

We will keep OPAM packages "ounit"/"ounit-lwt" for the transition.

Install
Sources
ounit-2.2.6.tbz
sha256=0690fb1e0e90a18eed5c3566b3cc1825d98b0e8c7d51bb6b846c95c45a615913
sha512=d7cb36a1fe245d02afab606cd1ee755a178ee4cb18fbbfec1df32baa88fa90ef6c9a50d9fd5bde46c7fd9c481f2debe4bafac75c4e3bdfbdb63fc18b0ccce3cc
Dependencies
ounit2
= version
dune
>= "1.11.0"
ocaml
>= "4.04.0"
Reverse Dependencies
ounit-lwt
>= "2.2.6"
tar-mirage
>= "2.0.0"