core_kernel

Industrial strength alternative to OCaml's standard library
README

Core is an industrial-strength alternative to the OCaml standard
library. It was developed by Jane Street, which is the largest
industrial user of OCaml.

Core_kernel is the system-independent part of Core. It is aimed for
cases when the full Core is not available, such as in Javascript. It
provides an overlay on the usual namespace, so the best way to use
Core is to start your file with:

open Core_kernel

Please report bugs and feature requests on
GitHub. For everything
else you can contact us at ocaml-core@googlegroups.com.

You can find all of Jane Street's open-source libraries on
GitHub.

Documentation can be found
here.

Install
Published
19 Dec 2017
Sources
core_kernel-v0.10.0.tar.gz
md5=a825f5c79d9e9b228e450ce4a439f107
Dependencies
ocaml-migrate-parsetree
>= "0.4" & < "2.0.0"
jbuilder
>= "1.0+beta12"
variantslib
>= "v0.10" & < "v0.11"
typerep
>= "v0.10" & < "v0.11"
stdio
>= "v0.10" & < "v0.11"
sexplib
>= "v0.10" & < "v0.11"
ppx_sexp_message
>= "v0.10" & < "v0.11"
ppx_sexp_conv
>= "v0.10" & < "v0.11"
ppx_jane
>= "v0.10" & < "v0.11"
ppx_inline_test
>= "v0.10" & < "v0.11"
ppx_hash
>= "v0.10" & < "v0.11"
ppx_driver
>= "v0.10" & < "v0.11"
ppx_base
>= "v0.10" & < "v0.11"
ppx_assert
>= "v0.10" & < "v0.11"
jane-street-headers
>= "v0.10" & < "v0.11"
fieldslib
>= "v0.10" & < "v0.11"
configurator
>= "v0.10" & < "v0.11"
bin_prot
>= "v0.10" & < "v0.11"
base
>= "v0.10" & < "v0.11"
ocaml
>= "4.04.1" & < "4.12.0"
Reverse Dependencies
async_durable
< "v0.11.0"
async_kernel
= "v0.10.0"
async_rpc_kernel
= "v0.10.0"
aws-s3-async
= "3.0.0"
bignum
= "v0.10.0"
biocaml
= "0.8.0"
capnp
>= "3.0.0" & < "3.2.1"
caqti-async
>= "1.3.0" & < "1.9.0"
cfstream
>= "1.1.2" & != "1.2.1" & < "1.3.0"
core
= "v0.10.0"
core-lwt
= "0.2.0"
core_extended
= "v0.10.0"
cstruct-async
>= "3.0.2" & < "6.1.0"
ecaml
= "v0.10.0"
email_message
= "v0.10.0"
git
< "1.3.0"
hack_parallel
= "1.0.0"
incr_dom
= "v0.10.0"
incr_map
= "v0.10.0"
incr_select
= "v0.10.0"
irmin
< "0.9.0"
libsvm
= "0.9.3" | >= "0.10.0"
mlt_parser
< "v0.11.0"
mmseg
< "transition"
opium
>= "0.12.0" & < "0.15.0"
patience_diff
= "v0.10.0"
plotkicadsch
>= "0.2.0" & < "0.8.0"
re2
>= "v0.10.0" & < "v0.11.0"
record_builder
< "v0.11.0"
splay_tree
< "v0.11.0"
textutils_kernel
< "v0.11.0"
topological_sort
= "v0.10.0"
topology
>= "0.4.0"