package aws-s3

  1. Overview
  2. Docs
Ocaml library for accessing Amazon S3

Install

Dune Dependency

Authors

Maintainers

Sources

4.8.0.tar.gz
md5=c8b19419fba5b964c7e8e9720475f61a
sha512=e34e243833299c59ff7914124c7fda39fbb26c81bb7adc7412a1b0b115d28a821d1fae1c82e03a74307e14c859f0d3289c766556f51050228525fe5e684cd2c0

Description

This library provides access to Amazon Simple Storage Solution (S3). The library supports:

  • Copying file to and from s3
  • List files in S3 (from root)
  • Delete single/multi object in S3
  • HEAD operation on single objects
  • Streaming transfer to and from aws.
  • Multi part upload (including s3 -> s3 copy)
  • Fetching machine role/credentials (though IAM)

The library supports both lwt and async concurrency models.

  • For lwt, please install aws-s3-lwt package
  • For Async, please install aws-s3-async package

Published: 05 Sep 2022

README

Ocaml library for accessing Amazon S3

This library provides access to Amazon Simple Storage Solution (S3).

The following S3 operations are supported:

  • Copying file to and from s3

  • List files in S3 (from root)

  • Delete single/multi object in S3

  • HEAD operation on single objects

  • Streaming transfer to and from aws

  • Multi part upload (including s3 -> s3 copy)

The library also implements fetching credentials through IAM service.

The library supports both lwt and async concurrency models.

  • For lwt, please install aws-s3-lwt package

  • For Async, please install aws-s3-async package

Api

This library is originally based on s3_cp example found at https://github.com/mirage/ocaml-cohttp/blob/master/examples/async/s3_cp.ml, but has diverted (and grown) substantially since.

Dependencies (12)

  1. base64 >= "3.1.0"
  2. cmdliner >= "1.1.0"
  3. yojson
  4. ppx_protocol_conv_json >= "5.0.0"
  5. ppx_protocol_conv_xmlm >= "5.0.0"
  6. ezxmlm >= "1.1.0"
  7. uri
  8. ptime
  9. digestif >= "0.7"
  10. ocaml-inifiles
  11. dune >= "2.0.0"
  12. ocaml >= "4.08.0"

Dev Dependencies (1)

  1. ppx_inline_test with-test

Used by (2)

  1. aws-s3-async >= "4.8.0"
  2. aws-s3-lwt >= "4.8.0"

Conflicts

None