package travesty

  1. Overview
  2. No Docs
Traversable containers, monad extensions, and more

Install

Authors

Maintainers

Sources

travesty-0.7.2.tbz
sha256=49d43ea0e9cef32d493fcc1561fc7480c55d9a2490700e487f4d5c3aff562d61
sha512=1cd77071adfb4583d0fcd27469b97bc64b7278761949aaaf415768aec14f6a1243e14575155c75033a5141a0320b4f56687381dc2bc56432a5ea63ea8613d968

Description

'Travesty' is a library for defining containers with applicative or monadic traversals, inspired by Haskell's Traversable typeclass; it also contains various helpers for monadic code, such as state transformers and extension functions for common monads and containers. It sits on top of Jane Street's Base library and ecosystem.

Published: 25 May 2022

Dependencies (4)

  1. base >= "v0.15.0" & < "v0.16.0"
  2. ppx_jane >= "v0.15.0"
  3. ocaml >= "4.14"
  4. dune >= "3.2"

Dev Dependencies (2)

  1. odoc with-doc
  2. ppx_expect with-test & >= "v0.15.0"

Used by

None

Conflicts

None