reason

Reason: Meta Language Toolchain
README

Getting Started

Community

Come say hi!

We also maintain BuckleTypes, where community members submit Reason/OCaml JavaScript bindings.

Contributing

Documentations

The docs are in the docs folder and the corresponding README there that describes the docs contribution method.

Codebase

See the src folder and the corresponding README.

# On OSX, install opam via Homebrew:
brew update
brew install opam
# On Linux, see here (you will need opam >= 1.2.2): http://opam.ocaml.org/doc/Install.html

opam init
# Add this to your ~/.bashrc (or ~/.zshrc):
#   eval $(opam config env)

opam update
opam switch 4.03.0
eval $(opam config env)
git clone https://github.com/facebook/reason.git
cd reason
opam pin add -y reason-parser reason-parser
opam pin add -y reason .

Note: during the last opam pin step, make sure your local repo is clean. In particular, remove artifacts and node_modules. Otherwise the pinning might go stale or stall due to the big node_modules.

License

See Reason license in LICENSE.txt.

Works that are forked from other projects are under their original licenses.

Editor plugins (which have also been forked) in the editorSupport/ directory
include their own licenses.

Credit

The general structure of refmt repo was copied from @whitequark's m17n
project, including parts of the README that instruct how to use this with the
OPAM toolchain.

Install
Published
02 Jun 2017
Sources
2.0.0.tar.gz
md5=f38f85b3639b2bbfe2d4b538b7c205f2
Dependencies
reason-parser
= "2.0.0"
topkg
>= "0.8.1" & < "0.9"
result
= "1.2"
merlin-extend
>= "0.3" & < "0.4"
utop
>= "1.17"
ocaml
>= "4.02" & < "4.05"
Reverse Dependencies
brotli
>= "2.0.3"
dream
>= "1.0.0~alpha2"
graphql_ppx
>= "0.7.1"
immutable
>= "0.0.6"
rtop
>= "3.3.5" & < "3.7.0"
spin
< "0.6.0"