js_of_ocaml

Compiler from OCaml bytecode to JavaScript
Description

Js_of_ocaml is a compiler from OCaml bytecode to JavaScript. It makes it possible to run pure OCaml programs in JavaScript environment like browsers and Node.js

Install
Published
20 Dec 2022
Authors
Maintainers
Sources
js_of_ocaml-5.0.1.tbz
sha256=7a210f1ca16a742381947dc67c3d8d9f4c94fbf20738744b1353897985b61069 sha512=07a973561190686d56bd5d56d9a275e177716ea8b9720f6acc7ddf8618680844a6d0c798447567ea9542d83bab524c165d076f3cce0769a12fc483ef8cd6a733
Dependencies
odoc with-doc
re >= "1.9.0" & with-test
ppx_expect >= "v0.14.2" & with-test
num with-test
ppxlib >= "0.15"
ocaml >= "4.04"
dune >= "3.2"
Reverse Dependencies
alba >= "0.4.1"
archetype >= "1.2.7"
async_js >= "v0.13.0" & != "v0.15.0"
binaryen >= "0.3.0" & < "0.12.1"
bonsai >= "v0.15.1"
brr = "0.0.3"
eliom = "6.3.0" | >= "6.5.0" & < "6.8.0" | >= "6.9.2" & < "6.10.1" | >= "7.0.0"
ezjs_fetch < "0.2"
ezjs_min < "0.2"
ezjs_push < "0.2"
gen_js_api < "1.0.7"
github-jsoo < "4.0.0"
hardcaml = "1.2.0"
incr_dom >= "v0.15.1"
jsoo_storage >= "1.0.1"
learn-ocaml >= "0.12"
nuscr < "1.1.0"
ocsigen-start >= "1.7.0" & != "2.15.1" & < "2.16.0"
ojs-base >= "0.6.0"
polynomial >= "0.4.0"
ppx_css >= "v0.15.1"
ppx_jsobject_conv >= "0.6.0" & != "0.9.3"
spin >= "0.8.0"
tyxml-lwd >= "0.2"
vg >= "0.9.4"
virtual_dom != "v0.15.0"
xtmpl = "0.18.0"