package eliom

  1. Overview
  2. No Docs
Framework for programming Web sites and client/server Web applications.

Install

Dune Dependency

Authors

Maintainers

Sources

4.1.0.tar.gz
md5=e93ccae5d61ce73e2d0f139cc5e3524d

Description

Eliom is a framework for programming Web sites and client/server Web applications. It introduces new concepts to simplify programming common behaviours and uses advanced static typing features of OCaml to check many properties of the Web site at compile time. If you want to write a Web application, Eliom makes possible to write the whole application as a single program (client and server parts). A syntax extension is used to distinguish both parts and the client side is compiled to JS using Ocsigen Js_of_ocaml.

Published: 02 Oct 2014

Dependencies (11)

  1. ocamlbuild
  2. reactiveData
  3. ipaddr >= "2.1"
  4. ocsigenserver = "2.5"
  5. camlp4 <= "4.02+6"
  6. calendar >= "2.00"
  7. tyxml >= "3.3.0" & < "3.6.0"
  8. js_of_ocaml >= "2.5" & < "3.0"
  9. deriving >= "0.6"
  10. ocamlfind
  11. ocaml >= "4.00.0" & < "5.1"

Dev Dependencies

None

Used by (1)

  1. litiom >= "4.0"

Conflicts

None

OCaml

Innovation. Community. Security.