core

Industrial strength alternative to OCaml's standard library
Description

The Core suite of libraries is an industrial strength alternative to OCaml's standard library that was developed by Jane Street, the largest industrial user of OCaml.

Install
Published
21 Sep 2015
Sources
core-113.00.00.tar.gz
md5=9eca76d553f62f69f93cf9dcc70b0107
Dependencies
variantslib
>= "109.15.00" & < "109.16.00"
sexplib
>= "113.00.00" & < "113.01.00"
pipebang
>= "113.00.00" & < "113.01.00"
pa_test
>= "112.24.00" & < "112.25.00"
pa_structural_sexp
>= "113.00.00" & < "113.01.00"
pa_ounit
>= "113.00.00" & < "113.01.00"
pa_bench
>= "113.00.00" & < "113.01.00"
herelib
>= "112.35.00" & < "112.36.00"
fieldslib
>= "113.00.00" & < "113.01.00"
enumerate
>= "111.08.00" & < "111.09.00"
custom_printf
>= "113.00.00" & < "113.01.00"
core_kernel
>= "113.00.00" & < "113.01.00"
comparelib
>= "113.00.00" & < "113.01.00"
bin_prot
>= "113.00.00" & < "113.01.00"
ocamlfind
>= "1.3.2"
ocaml
>= "4.02.1" & < "4.03"
Reverse Dependencies
alcotest-async
>= "1.3.0" & < "1.6.0"
arakoon
= "1.9.0"
async-zmq
>= "0.1.0"
async_extended
= "113.00.00"
async_extra
< "108.00.02" | = "113.00.00"
async_parallel
= "113.00.00"
async_smtp
= "113.00.00"
async_unix
< "108.00.02" | = "113.00.00"
aws-s3
< "1.1.0"
batsh
< "0.0.4" | >= "0.0.6"
biocaml
= "0.4.0"
bistro
< "0.3.0"
capnp
>= "3.0.0" & < "3.3.0"
caqti-async
< "1.2.0"
cfstream
< "1.1.2"
cohttp-async
>= "1.1.1"
conduit-async
>= "1.2.0" & < "5.1.1"
core_bench
= "112.35.00"
core_extended
= "113.00.00"
core_profiler
= "113.00.00"
email_message
= "113.00.00"
facebook-sdk
>= "0.3.1"
flow
< "0.2"
frenetic
= "2.0.0" | >= "3.1.0" & < "5.0.0"
get_line
= "2.1.0"
gnuplot
< "0.5.1" | = "0.5.3"
gpr
< "1.3.0"
hack_parallel
!= "1.0.0"
hll
< "2.7"
horned_worm
>= "0.3.1" & < "0.3.7"
ibx
< "0.5.9" | = "0.7.2" | = "0.8.0"
incremental
= "113.00.00"
jenga
= "113.00.00"
libsvm
< "0.9.3"
line-up-words
< "v0.11.0"
opass
!= "0.2.1" & < "2.15"
openflow
>= "0.3.0" & < "0.9.0"
opium
< "0.12.0"
ox
>= "1.1.0"
pg_query
< "0.9.6"
planets
>= "0.1.14"
ppx_bitstring
< "1.3.0"
ppx_rapper
< "1.0.1"
primes
< "1.3.5"
re2
= "113.00.00"
riakc
>= "1.0.0"
riakc_ppx
!= "3.1.3"
rpc_parallel
= "113.00.00"
satyrographos
< "0.0.2.7"
sociaml-vcard
< "0.2.1"
textutils
= "112.17.00"
tube
< "4.1.1"