package angstrom

  1. Overview
  2. Docs
Parser combinators built for speed and memory-efficiency

Install

Dune Dependency

Authors

Maintainers

Sources

0.1.1.tar.gz
md5=ecc3dd0accdc39b74c48997eaba5f3e9

Description

Angstrom is a parser-combinator library that makes it easy to write efficient, expressive, and reusable parsers suitable for high-performance applications. It exposes monadic and applicative interfaces for composition, and supports incremental input through buffered and unbuffered interfaces. Both interfaces give the user total control over the blocking behavior of their application, with the unbuffered interface enabling zero-copy IO. Parsers are backtracking by default and support unbounded lookahead.

Published: 21 Jul 2016

Dependencies (6)

  1. ocplib-endian >= "0.6"
  2. result
  3. ocamlbuild build
  4. ocamlfind build
  5. cstruct >= "0.7.0" & < "3.2.0"
  6. ocaml >= "4.02.0" & < "4.06.0"

Dev Dependencies (1)

  1. alcotest with-test & >= "0.4.1" & < "0.8.0"

Used by (17)

  1. angstrom-async < "0.7.0"
  2. angstrom-lwt-unix
  3. angstrom-unix
  4. ansi-parse < "0.4.0"
  5. coin < "0.1.2"
  6. colombe < "0.2.0"
  7. dap
  8. earlybird < "1.0.0"
  9. email_message >= "v0.10.0" & < "v0.14.0"
  10. hpack >= "0.10.0"
  11. icalendar < "0.1.4"
  12. multipart_form-lwt
  13. nosetup
  14. piaf
  15. tldr < "0.3.0"
  16. uuuu < "0.2.0"
  17. vcaml < "v0.14.0"

Conflicts (2)

  1. async >= "v0.10.0"
  2. lwt < "2.4.7"