visitors

An OCaml syntax extension for generating visitor classes
IN THIS PACKAGE
Empty package map

Error log

The package failed to build. The error log from opam follows.

# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
# The following system packages are needed:
libgmp-dev
The following command needs to be run through "sudo":
    apt-get install -qq -yy libgmp-dev
debconf: delaying package configuration, since apt-utils is not installed
Selecting previously unselected package libgmpxx4ldbl:amd64.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 18331 files and directories currently installed.)
Preparing to unpack .../libgmpxx4ldbl_2%3a6.2.1+dfsg-1+deb11u1_amd64.deb ...
Unpacking libgmpxx4ldbl:amd64 (2:6.2.1+dfsg-1+deb11u1) ...
Selecting previously unselected package libgmp-dev:amd64.
Preparing to unpack .../libgmp-dev_2%3a6.2.1+dfsg-1+deb11u1_amd64.deb ...
Unpacking libgmp-dev:amd64 (2:6.2.1+dfsg-1+deb11u1) ...
Setting up libgmpxx4ldbl:amd64 (2:6.2.1+dfsg-1+deb11u1) ...
Setting up libgmp-dev:amd64 (2:6.2.1+dfsg-1+deb11u1) ...
Processing triggers for libc-bin (2.31-13+deb11u3) ...
# OS packages installation successful
# Now letting opam install the packages
[NOTE] Package ocamlfind is already installed (current version is 1.9.5).
[NOTE] Package dune is already installed (current version is 2.0.1).
The following actions will be performed:
  - install cppo                    1.6.9
  - install fix                     20220121
  - install ppx_derivers            1.2.1
  - install menhirLib               20200123
  - install conf-gmp                4
  - install menhirSdk               20200123
  - install ppx_tools               5.1+4.06.0
  - install result                  1.5
  - install seq                     0.2.2
  - install base-bytes              base
  - install num                     1.4
  - install ocamlbuild              0.14.1
  - install stdint                  0.7.0
  - install stdlib-shims            0.3.0
  - install pprint                  20220103
  - install zarith                  1.12
  - install menhir                  20200123
  - install ocaml-migrate-parsetree 1.8.0
  - install yojson                  2.0.2
  - install wasm                    1.0.1
  - install process                 0.2.1
  - install camlp4                  4.06+1
  - install batteries               3.5.1
  - install fileutils               0.6.3
  - install ppxfind                 1.4
  - install ulex                    1.2
  - install ppx_deriving            4.5-1
  - install visitors                20200210
  - install ppx_deriving_yojson     3.5.3
  - install fstar                   0.9.7.0-alpha1
  - install kremlin                 0.9.6.0
===== 31 to install =====

<><> Gathering sources ><><><><><><><><><><><><><><><><><><><><><><><><><><><><>
[batteries.3.5.1] found in cache
Processing  2/31:
[camlp4.4.06+1] found in cache
Processing  3/31:
Processing  4/31:
[cppo.1.6.9] found in cache
Processing  5/31:
[fileutils.0.6.3] found in cache
Processing  6/31:
[fix.20220121] found in cache
Processing  7/31:
Processing  8/31: [fstar.0.9.7.0-alpha1: http]
Processing  9/31: [fstar.0.9.7.0-alpha1: http] [kremlin.0.9.6.0: http]
[menhir.20200123] found in cache
Processing 10/31: [fstar.0.9.7.0-alpha1: http] [kremlin.0.9.6.0: http]
[menhirLib.20200123] found in cache
Processing 11/31: [fstar.0.9.7.0-alpha1: http] [kremlin.0.9.6.0: http]
[menhirSdk.20200123] found in cache
Processing 12/31: [fstar.0.9.7.0-alpha1: http] [kremlin.0.9.6.0: http]
[num.1.4] found in cache
Processing 13/31: [fstar.0.9.7.0-alpha1: http] [kremlin.0.9.6.0: http]
[ocaml-migrate-parsetree.1.8.0] found in cache
Processing 14/31: [fstar.0.9.7.0-alpha1: http] [kremlin.0.9.6.0: http]
[ocamlbuild.0.14.1] found in cache
Processing 15/31: [fstar.0.9.7.0-alpha1: http] [kremlin.0.9.6.0: http]
[pprint.20220103] found in cache
Processing 16/31: [fstar.0.9.7.0-alpha1: http] [kremlin.0.9.6.0: http]
[ppx_derivers.1.2.1] found in cache
Processing 17/31: [fstar.0.9.7.0-alpha1: http] [kremlin.0.9.6.0: http]
[ppx_deriving.4.5-1] found in cache
Processing 18/31: [fstar.0.9.7.0-alpha1: http] [kremlin.0.9.6.0: http]
[ppx_deriving_yojson.3.5.3] found in cache
Processing 19/31: [fstar.0.9.7.0-alpha1: http] [kremlin.0.9.6.0: http]
[ppx_tools.5.1+4.06.0] found in cache
Processing 20/31: [fstar.0.9.7.0-alpha1: http] [kremlin.0.9.6.0: http]
[ppxfind.1.4] found in cache
Processing 21/31: [fstar.0.9.7.0-alpha1: http] [kremlin.0.9.6.0: http]
[process.0.2.1] found in cache
Processing 22/31: [fstar.0.9.7.0-alpha1: http] [kremlin.0.9.6.0: http]
[result.1.5] found in cache
Processing 23/31: [fstar.0.9.7.0-alpha1: http] [kremlin.0.9.6.0: http]
Processing 23/31: [fstar.0.9.7.0-alpha1: http]
[seq.0.2.2] found in cache
Processing 24/31: [fstar.0.9.7.0-alpha1: http]
[stdint.0.7.0] found in cache
Processing 25/31: [fstar.0.9.7.0-alpha1: http]
[stdlib-shims.0.3.0] found in cache
Processing 26/31: [fstar.0.9.7.0-alpha1: http]
[ulex.1.2] found in cache
Processing 27/31: [fstar.0.9.7.0-alpha1: http]
[visitors.20200210] found in cache
Processing 28/31: [fstar.0.9.7.0-alpha1: http]
[wasm.1.0.1] found in cache
Processing 29/31: [fstar.0.9.7.0-alpha1: http]
[yojson.2.0.2] found in cache
Processing 30/31: [fstar.0.9.7.0-alpha1: http]
[zarith.1.12] found in cache
Processing 31/31: [fstar.0.9.7.0-alpha1: http]
[fstar.0.9.7.0-alpha1] downloaded from https://github.com/FStarLang/FStar/archive/V0.9.7.0-alpha1.zip
Processing 31/31:
[ERROR] The sources of the following couldn't be obtained, aborting:
          - kremlin.0.9.6.0:
            https://github.com/FStarLang/kremlin/archive/v0.9.6.0.zip (Bad checksum, expected md5=6a580d0b470484db5637d593a06811be)

'opam install --verbose --yes kremlin.0.9.6.0 base-bytes.base batteries.3.5.1 camlp4.4.06+1 conf-gmp.4 cppo.1.6.9 dune.2.0.1 fileutils.0.6.3 fix.20220121 fstar.0.9.7.0-alpha1 menhir.20200123 menhirLib.20200123 menhirSdk.20200123 num.1.4 ocaml-migrate-parsetree.1.8.0 ocamlbuild.0.14.1 ocamlfind.1.9.5 pprint.20220103 ppx_derivers.1.2.1 ppx_deriving.4.5-1 ppx_deriving_yojson.3.5.3 ppx_tools.5.1+4.06.0 ppxfind.1.4 process.0.2.1 result.1.5 seq.0.2.2 stdint.0.7.0 stdlib-shims.0.3.0 ulex.1.2 visitors.20200210 wasm.1.0.1 yojson.2.0.2 zarith.1.12' failed.