package tls

  1. Overview
  2. Docs

Description

Transport Layer Security (TLS) is probably the most widely deployed security protocol on the Internet. It provides communication privacy to prevent eavesdropping, tampering, and message forgery. Furthermore, it optionally provides authentication of the involved endpoints. TLS is commonly deployed for securing web services (HTTPS), emails, virtual private networks, and wireless networks.

TLS uses asymmetric cryptography to exchange a symmetric key, and optionally authenticate (using X.509) either or both endpoints. It provides algorithmic agility, which means that the key exchange method, symmetric encryption algorithm, and hash algorithm are negotiated.

Read further and our Usenix Security 2015 paper.

Tags

org:mirage

Published: 01 Mar 2018

README

TLS - Transport Layer Security purely in OCaml

0.9.1 Transport Layer Security (TLS) is probably the most widely deployed security protocol on the Internet. It provides communication privacy to prevent eavesdropping, tampering, and message forgery. Furthermore, it optionally provides authentication of the involved endpoints. TLS is commonly deployed for securing web services (HTTPS), emails, virtual private networks, and wireless networks.

TLS uses asymmetric cryptography to exchange a symmetric key, and optionally authenticate (using X.509) either or both endpoints. It provides algorithmic agility, which means that the key exchange method, symmetric encryption algorithm, and hash algorithm are negotiated.

Read further and our Usenix Security 2015 paper.

Documentation

API documentation

Installation

opam install tls will install this library.

Dependencies (12)

  1. x509 >= "0.6.1" & < "0.7.0"
  2. nocrypto >= "0.5.4"
  3. sexplib
  4. cstruct >= "3.0.0" & < "4.0.0"
  5. result < "1.5"
  6. ppx_cstruct >= "3.0.0"
  7. ppx_deriving
  8. ppx_sexp_conv < "v0.11.0"
  9. topkg build
  10. ocamlbuild build
  11. ocamlfind build
  12. ocaml >= "4.02.2" & < "4.12.0"

Dev Dependencies (2)

  1. ounit with-test
  2. cstruct-unix with-test & >= "3.0.0"

Used by (40)

  1. aws-s3-lwt < "3.0.0"
  2. azure-cosmos-db >= "0.1.5" & < "0.2.0"
  3. calculon < "0.5"
  4. capnp-rpc-lwt >= "0.3.1" & < "0.5.0"
  5. capnp-rpc-net < "1.1"
  6. caqti >= "2.1.1"
  7. caqti-mirage >= "2.1.1"
  8. caqti-tls
  9. colombe < "0.2.0"
  10. comby < "1.7.0"
  11. conduit-mirage < "2.1.0"
  12. conduit-tls
  13. current_github < "0.2"
  14. current_slack < "0.3"
  15. datakit-ci >= "0.12.1"
  16. dns-resolver >= "6.0.0"
  17. dropbox >= "0.2"
  18. git >= "2.0.0" & < "3.0.0"
  19. git-mirage >= "2.0.0" & < "3.0.0" | >= "3.6.0"
  20. git-unix = "2.0.0" | >= "2.1.1" & < "3.0.0"
  21. github >= "2.0.0" & < "3.0.0"
  22. github-unix < "3.1.0"
  23. imaplet-lwt >= "0.1.8" & < "0.1.10" | >= "0.1.14"
  24. irc-client-tls < "0.7.1"
  25. letters < "0.3.3"
  26. links >= "0.9.6"
  27. mehari-mirage < "0.2"
  28. mirage-conduit != "2.0.0" & < "2.2.0" | >= "3.0.0"
  29. mirror
  30. opam-publish >= "0.3.5" & < "2.1.0"
  31. paf-cohttp = "0.0.5"
  32. quests
  33. sendmail >= "0.2.0" & < "0.4.1"
  34. sendmail-lwt < "0.4.1"
  35. slacko >= "0.13.0"
  36. syndic >= "1.5" & < "1.6.0"
  37. tezos-node < "9.0"
  38. tls-liquidsoap
  39. tlstunnel >= "0.1.3"
  40. wcs-api = "2017-05-26.02"

Conflicts (7)

  1. mirage-clock >= "3.0.0"
  2. mirage-kv-lwt >= "2.0.0"
  3. ptime < "0.8.1"
  4. sexplib = "v0.9.0"
  5. mirage-types < "3.0.0"
  6. mirage-net-xen < "1.3.0"
  7. lwt < "2.4.8"
OCaml

Innovation. Community. Security.