semver2

Semantic version handling for OCaml
README

Library for handling semantic version numbers (Semver 2.0.0) in OCaml.

Purpose

This library provides basic functions for working with semantic version numbers:

  • Parsing and printing version strings

  • Comparing version numbers for precedence

  • Checking validity of version numbers according to the Semver spec

Please refer to the module documentation for its API.

Local development

The following dependencies are required:

  • ocaml

  • opam

  • m4

  • pkg-config

Opam needs to be initialized:

$ opam init

Library dependencies can be installed with:

$ make install-deps

Make sure to have an updated shell environment:

$ eval $(opam env)

Then you can run the test suite with:

$ make test

Publishing to opam

Whenever a new tag is pushed, you can publish the new version to opam.

The following dependencies are required to build opam-publish:

  • ocaml

  • opam

  • m4

  • pkgconfig

  • openssl

  • gmp

Contributing

Contributions are welcome in the form of issues or pull requests. Please remember to:

  1. Explain the intended purpose of your change and provide enough context for others to follow your reasoning.

  2. Add documentation for new (or existing!) functionality.

  3. Include tests to help ensure correctness of added code.

Copyright and Licensing

(C) 2020 Dividat AG.

Published under MIT license.

Install
Authors
Maintainers
Sources
1.2.0.tar.gz
md5=657c5113dc0b41f11e659fb24e5cf0f9
sha512=c8f45011fc49dea4be5ed30f0a1391a1fa8b862e3f6f06b6f82d5baefbbb6c9aee632fd5bb1ed0a77b764bb59bd704f559bdf713e195976c39034431b2099b8f
Dependencies
odoc
with-doc
yojson
with-test & >= "1.4.1"
ounit
with-test & >= "1.0.2"
angstrom
>= "0.14.0"
dune
>= "1.2.0"
ocaml
>= "4.04.0"
Reverse Dependencies