package radare2

  1. Overview
  2. Docs
On This Page
  1. Error log

radare2 0.0.7

Error log

The package failed to build. The error log from opam follows.

Opam plugin "depext" may require upgrading/reinstalling. Reinstall the plugin on the current switch? [Y/n] y
The following actions will be performed:
  - recompile opam-depext 1.2.1-1

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved opam-depext.1.2.1-1  (cached)
-> removed   opam-depext.1.2.1-1
-> installed opam-depext.1.2.1-1

<><> opam-depext.1.2.1-1 installed successfully <><><><><><><><><><><><><><><><>
=> opam-depext is unnecessary when used with opam >= 2.1. Please use opam install directly instead
# Run eval $(opam env) to update the current shell environment

<><> Carrying on to "opam depext -viy radare2.0.0.7 conf-radare2.0.1 conf-which.1 cppo.1.6.9 dune.3.10.0 seq.base yojson.2.1.0" 

You are using opam 2.1+, where external dependency handling has been integrated: consider calling opam directly, the 'depext' plugin interface is provided for backwards compatibility only
# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
[ERROR] No solution for radare2.0.0.7 & conf-radare2.0.1 & conf-which.1 & cppo.1.6.9 & dune.3.10.0 & seq.base & yojson.2.1.0:   * Missing dependency:
            - conf-radare2
            depends on the unavailable system package 'radare2'. Use `--no-depexts' to attempt installation anyway, or it is possible that a depext package name in the opam file is incorrect.

Command failed: opam --cli=2.1 list --readonly --external '--resolve=radare2.0.0.7,conf-radare2.0.1,conf-which.1,cppo.1.6.9,dune.3.10.0,seq.base,yojson.2.1.0' returned 20