ott

A tool for writing definitions of programming languages and calculi
IN THIS PACKAGE
Empty package map

Error log

The package failed to build. The error log from opam follows.

# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
[ERROR] No solution for ott.0.32: The following dependencies couldn't be met:
          - ott -> ocaml >= 4.02.0 -> ocaml-variants >= 4.02.0
              not available because the package is pinned to version 4.14.0+trunk
          - ott -> ocaml >= 4.02.0 -> ocaml-system >= 4.02.0
              unmet availability conditions, e.g. sys-ocaml-version = "4.02.0"
          - ott -> ocaml >= 4.02.0 -> ocaml-config >= 2 -> ocaml-base-compiler != 3.08
              conflict with the base packages of this switch
          - ott -> ocaml >= 4.02.0 -> ocaml-config >= 2 -> ocaml-system != 3.08
              unmet availability conditions, e.g. sys-ocaml-version = "4.14.0"
          - ott -> ocaml >= 4.02.0 -> ocaml-config >= 2 -> ocaml-variants >= 3.08.0~
              not available because the package is pinned to version 4.14.0+trunk
          - ott -> ocaml >= 4.02.0 -> ocaml-base-compiler (= 4.02.0 | >= 4.02.2 & != 4.03.0 & != 4.04.1 & != 4.06.0 & != 4.07.1 & != 4.10.2)
              conflict with the base packages of this switch


Command failed: opam list --readonly --external '--resolve=ott.0.32' returned 20