mpi

OCaml binding to the Message Passing Interface (MPI)
IN THIS PACKAGE
Empty package map

Error log

The package failed to build. The error log from opam follows.

# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
# The following system packages are needed:
mpi-default-dev
pkg-config
The following command needs to be run through "sudo":
    apt-get install -qq -yy mpi-default-dev pkg-config
debconf: delaying package configuration, since apt-utils is not installed
Selecting previously unselected package libmagic-mgc.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 18283 files and directories currently installed.)
Preparing to unpack .../00-libmagic-mgc_1%3a5.39-3_amd64.deb ...
Unpacking libmagic-mgc (1:5.39-3) ...
Selecting previously unselected package libmagic1:amd64.
Preparing to unpack .../01-libmagic1_1%3a5.39-3_amd64.deb ...
Unpacking libmagic1:amd64 (1:5.39-3) ...
Selecting previously unselected package file.
Preparing to unpack .../02-file_1%3a5.39-3_amd64.deb ...
Unpacking file (1:5.39-3) ...
Selecting previously unselected package libsigsegv2:amd64.
Preparing to unpack .../03-libsigsegv2_2.13-1_amd64.deb ...
Unpacking libsigsegv2:amd64 (2.13-1) ...
Selecting previously unselected package m4.
Preparing to unpack .../04-m4_1.4.18-5_amd64.deb ...
Unpacking m4 (1.4.18-5) ...
Selecting previously unselected package autoconf.
Preparing to unpack .../05-autoconf_2.69-14_all.deb ...
Unpacking autoconf (2.69-14) ...
Selecting previously unselected package autotools-dev.
Preparing to unpack .../06-autotools-dev_20180224.1+nmu1_all.deb ...
Unpacking autotools-dev (20180224.1+nmu1) ...
Selecting previously unselected package automake.
Preparing to unpack .../07-automake_1%3a1.16.3-2_all.deb ...
Unpacking automake (1:1.16.3-2) ...
Selecting previously unselected package libgfortran5:amd64.
Preparing to unpack .../08-libgfortran5_10.2.1-6_amd64.deb ...
Unpacking libgfortran5:amd64 (10.2.1-6) ...
Selecting previously unselected package libgfortran-10-dev:amd64.
Preparing to unpack .../09-libgfortran-10-dev_10.2.1-6_amd64.deb ...
Unpacking libgfortran-10-dev:amd64 (10.2.1-6) ...
Selecting previously unselected package gfortran-10.
Preparing to unpack .../10-gfortran-10_10.2.1-6_amd64.deb ...
Unpacking gfortran-10 (10.2.1-6) ...
Selecting previously unselected package gfortran.
Preparing to unpack .../11-gfortran_4%3a10.2.1-1_amd64.deb ...
Unpacking gfortran (4:10.2.1-1) ...
Selecting previously unselected package libnl-3-200:amd64.
Preparing to unpack .../12-libnl-3-200_3.4.0-1+b1_amd64.deb ...
Unpacking libnl-3-200:amd64 (3.4.0-1+b1) ...
Selecting previously unselected package libnl-route-3-200:amd64.
Preparing to unpack .../13-libnl-route-3-200_3.4.0-1+b1_amd64.deb ...
Unpacking libnl-route-3-200:amd64 (3.4.0-1+b1) ...
Selecting previously unselected package libibverbs1:amd64.
Preparing to unpack .../14-libibverbs1_33.2-1_amd64.deb ...
Unpacking libibverbs1:amd64 (33.2-1) ...
Selecting previously unselected package ibverbs-providers:amd64.
Preparing to unpack .../15-ibverbs-providers_33.2-1_amd64.deb ...
Unpacking ibverbs-providers:amd64 (33.2-1) ...
Selecting previously unselected package javascript-common.
Preparing to unpack .../16-javascript-common_11+nmu1_all.deb ...
Unpacking javascript-common (11+nmu1) ...
Selecting previously unselected package libevent-core-2.1-7:amd64.
Preparing to unpack .../17-libevent-core-2.1-7_2.1.12-stable-1_amd64.deb ...
Unpacking libevent-core-2.1-7:amd64 (2.1.12-stable-1) ...
Selecting previously unselected package libevent-pthreads-2.1-7:amd64.
Preparing to unpack .../18-libevent-pthreads-2.1-7_2.1.12-stable-1_amd64.deb ...
Unpacking libevent-pthreads-2.1-7:amd64 (2.1.12-stable-1) ...
Selecting previously unselected package libpsm-infinipath1.
Preparing to unpack .../19-libpsm-infinipath1_3.3+20.604758e7-6.1_amd64.deb ...
Unpacking libpsm-infinipath1 (3.3+20.604758e7-6.1) ...
Selecting previously unselected package libnuma1:amd64.
Preparing to unpack .../20-libnuma1_2.0.12-1+b1_amd64.deb ...
Unpacking libnuma1:amd64 (2.0.12-1+b1) ...
Selecting previously unselected package libpsm2-2.
Preparing to unpack .../21-libpsm2-2_11.2.185-1_amd64.deb ...
Unpacking libpsm2-2 (11.2.185-1) ...
Selecting previously unselected package librdmacm1:amd64.
Preparing to unpack .../22-librdmacm1_33.2-1_amd64.deb ...
Unpacking librdmacm1:amd64 (33.2-1) ...
Selecting previously unselected package libfabric1.
Preparing to unpack .../23-libfabric1_1.11.0-2_amd64.deb ...
Unpacking libfabric1 (1.11.0-2) ...
Selecting previously unselected package libhwloc15:amd64.
Preparing to unpack .../24-libhwloc15_2.4.1+dfsg-1_amd64.deb ...
Unpacking libhwloc15:amd64 (2.4.1+dfsg-1) ...
Selecting previously unselected package libpciaccess0:amd64.
Preparing to unpack .../25-libpciaccess0_0.16-1_amd64.deb ...
Unpacking libpciaccess0:amd64 (0.16-1) ...
Selecting previously unselected package libicu67:amd64.
Preparing to unpack .../26-libicu67_67.1-7_amd64.deb ...
Unpacking libicu67:amd64 (67.1-7) ...
Selecting previously unselected package libxml2:amd64.
Preparing to unpack .../27-libxml2_2.9.10+dfsg-6.7_amd64.deb ...
Unpacking libxml2:amd64 (2.9.10+dfsg-6.7) ...
Selecting previously unselected package libxnvctrl0:amd64.
Preparing to unpack .../28-libxnvctrl0_460.91.03-1_amd64.deb ...
Unpacking libxnvctrl0:amd64 (460.91.03-1) ...
Selecting previously unselected package ocl-icd-libopencl1:amd64.
Preparing to unpack .../29-ocl-icd-libopencl1_2.2.14-2_amd64.deb ...
Unpacking ocl-icd-libopencl1:amd64 (2.2.14-2) ...
Selecting previously unselected package libhwloc-plugins:amd64.
Preparing to unpack .../30-libhwloc-plugins_2.4.1+dfsg-1_amd64.deb ...
Unpacking libhwloc-plugins:amd64 (2.4.1+dfsg-1) ...
Selecting previously unselected package libpmix2:amd64.
Preparing to unpack .../31-libpmix2_4.0.0-4.1_amd64.deb ...
Unpacking libpmix2:amd64 (4.0.0-4.1) ...
Selecting previously unselected package libucx0:amd64.
Preparing to unpack .../32-libucx0_1.10.1~rc1+really.1.10.0-1_amd64.deb ...
Unpacking libucx0:amd64 (1.10.1~rc1+really.1.10.0-1) ...
Selecting previously unselected package libopenmpi3:amd64.
Preparing to unpack .../33-libopenmpi3_4.1.0-10_amd64.deb ...
Unpacking libopenmpi3:amd64 (4.1.0-10) ...
Selecting previously unselected package libcaf-openmpi-3:amd64.
Preparing to unpack .../34-libcaf-openmpi-3_2.9.2-3_amd64.deb ...
Unpacking libcaf-openmpi-3:amd64 (2.9.2-3) ...
Selecting previously unselected package libcoarrays-dev:amd64.
Preparing to unpack .../35-libcoarrays-dev_2.9.2-3_amd64.deb ...
Unpacking libcoarrays-dev:amd64 (2.9.2-3) ...
Selecting previously unselected package openmpi-common.
Preparing to unpack .../36-openmpi-common_4.1.0-10_all.deb ...
Unpacking openmpi-common (4.1.0-10) ...
Selecting previously unselected package openmpi-bin.
Preparing to unpack .../37-openmpi-bin_4.1.0-10_amd64.deb ...
Unpacking openmpi-bin (4.1.0-10) ...
Selecting previously unselected package libcoarrays-openmpi-dev:amd64.
Preparing to unpack .../38-libcoarrays-openmpi-dev_2.9.2-3_amd64.deb ...
Unpacking libcoarrays-openmpi-dev:amd64 (2.9.2-3) ...
Selecting previously unselected package libevent-2.1-7:amd64.
Preparing to unpack .../39-libevent-2.1-7_2.1.12-stable-1_amd64.deb ...
Unpacking libevent-2.1-7:amd64 (2.1.12-stable-1) ...
Selecting previously unselected package libevent-extra-2.1-7:amd64.
Preparing to unpack .../40-libevent-extra-2.1-7_2.1.12-stable-1_amd64.deb ...
Unpacking libevent-extra-2.1-7:amd64 (2.1.12-stable-1) ...
Selecting previously unselected package libevent-openssl-2.1-7:amd64.
Preparing to unpack .../41-libevent-openssl-2.1-7_2.1.12-stable-1_amd64.deb ...
Unpacking libevent-openssl-2.1-7:amd64 (2.1.12-stable-1) ...
Selecting previously unselected package libevent-dev.
Preparing to unpack .../42-libevent-dev_2.1.12-stable-1_amd64.deb ...
Unpacking libevent-dev (2.1.12-stable-1) ...
Selecting previously unselected package libglib2.0-0:amd64.
Preparing to unpack .../43-libglib2.0-0_2.66.8-1_amd64.deb ...
Unpacking libglib2.0-0:amd64 (2.66.8-1) ...
Selecting previously unselected package libglib2.0-data.
Preparing to unpack .../44-libglib2.0-data_2.66.8-1_all.deb ...
Unpacking libglib2.0-data (2.66.8-1) ...
Selecting previously unselected package libnuma-dev:amd64.
Preparing to unpack .../45-libnuma-dev_2.0.12-1+b1_amd64.deb ...
Unpacking libnuma-dev:amd64 (2.0.12-1+b1) ...
Selecting previously unselected package libltdl7:amd64.
Preparing to unpack .../46-libltdl7_2.4.6-15_amd64.deb ...
Unpacking libltdl7:amd64 (2.4.6-15) ...
Selecting previously unselected package libltdl-dev:amd64.
Preparing to unpack .../47-libltdl-dev_2.4.6-15_amd64.deb ...
Unpacking libltdl-dev:amd64 (2.4.6-15) ...
Selecting previously unselected package libhwloc-dev:amd64.
Preparing to unpack .../48-libhwloc-dev_2.4.1+dfsg-1_amd64.deb ...
Unpacking libhwloc-dev:amd64 (2.4.1+dfsg-1) ...
Selecting previously unselected package libnl-3-dev:amd64.
Preparing to unpack .../49-libnl-3-dev_3.4.0-1+b1_amd64.deb ...
Unpacking libnl-3-dev:amd64 (3.4.0-1+b1) ...
Selecting previously unselected package libnl-route-3-dev:amd64.
Preparing to unpack .../50-libnl-route-3-dev_3.4.0-1+b1_amd64.deb ...
Unpacking libnl-route-3-dev:amd64 (3.4.0-1+b1) ...
Selecting previously unselected package libibverbs-dev:amd64.
Preparing to unpack .../51-libibverbs-dev_33.2-1_amd64.deb ...
Unpacking libibverbs-dev:amd64 (33.2-1) ...
Selecting previously unselected package libjs-jquery.
Preparing to unpack .../52-libjs-jquery_3.5.1+dfsg+~3.5.5-7_all.deb ...
Unpacking libjs-jquery (3.5.1+dfsg+~3.5.5-7) ...
Selecting previously unselected package libjs-jquery-ui.
Preparing to unpack .../53-libjs-jquery-ui_1.12.1+dfsg-8+deb11u1_all.deb ...
Unpacking libjs-jquery-ui (1.12.1+dfsg-8+deb11u1) ...
Selecting previously unselected package zlib1g-dev:amd64.
Preparing to unpack .../54-zlib1g-dev_1%3a1.2.11.dfsg-2_amd64.deb ...
Unpacking zlib1g-dev:amd64 (1:1.2.11.dfsg-2) ...
Selecting previously unselected package libpmix-dev:amd64.
Preparing to unpack .../55-libpmix-dev_4.0.0-4.1_amd64.deb ...
Unpacking libpmix-dev:amd64 (4.0.0-4.1) ...
Selecting previously unselected package libopenmpi-dev:amd64.
Preparing to unpack .../56-libopenmpi-dev_4.1.0-10_amd64.deb ...
Unpacking libopenmpi-dev:amd64 (4.1.0-10) ...
Selecting previously unselected package libtool.
Preparing to unpack .../57-libtool_2.4.6-15_all.deb ...
Unpacking libtool (2.4.6-15) ...
Selecting previously unselected package mpi-default-dev.
Preparing to unpack .../58-mpi-default-dev_1.13_amd64.deb ...
Unpacking mpi-default-dev (1.13) ...
Selecting previously unselected package pkg-config.
Preparing to unpack .../59-pkg-config_0.29.2-1_amd64.deb ...
Unpacking pkg-config (0.29.2-1) ...
Selecting previously unselected package shared-mime-info.
Preparing to unpack .../60-shared-mime-info_2.0-1_amd64.deb ...
Unpacking shared-mime-info (2.0-1) ...
Selecting previously unselected package xdg-user-dirs.
Preparing to unpack .../61-xdg-user-dirs_0.17-2_amd64.deb ...
Unpacking xdg-user-dirs (0.17-2) ...
Setting up javascript-common (11+nmu1) ...
Setting up libpciaccess0:amd64 (0.16-1) ...
Setting up libicu67:amd64 (67.1-7) ...
Setting up xdg-user-dirs (0.17-2) ...
Setting up libmagic-mgc (1:5.39-3) ...
Setting up libglib2.0-0:amd64 (2.66.8-1) ...
No schema files found: doing nothing.
Setting up libmagic1:amd64 (1:5.39-3) ...
Setting up file (1:5.39-3) ...
Setting up libxnvctrl0:amd64 (460.91.03-1) ...
Setting up autotools-dev (20180224.1+nmu1) ...
Setting up libglib2.0-data (2.66.8-1) ...
Setting up libsigsegv2:amd64 (2.13-1) ...
Setting up libhwloc15:amd64 (2.4.1+dfsg-1) ...
Setting up libevent-core-2.1-7:amd64 (2.1.12-stable-1) ...
Setting up libevent-2.1-7:amd64 (2.1.12-stable-1) ...
Setting up pkg-config (0.29.2-1) ...
Setting up libltdl7:amd64 (2.4.6-15) ...
Setting up libgfortran5:amd64 (10.2.1-6) ...
Setting up zlib1g-dev:amd64 (1:1.2.11.dfsg-2) ...
Setting up libnuma1:amd64 (2.0.12-1+b1) ...
Setting up ocl-icd-libopencl1:amd64 (2.2.14-2) ...
Setting up libnl-3-200:amd64 (3.4.0-1+b1) ...
Setting up libpsm2-2 (11.2.185-1) ...
Setting up openmpi-common (4.1.0-10) ...
Setting up libgfortran-10-dev:amd64 (10.2.1-6) ...
Setting up libpsm-infinipath1 (3.3+20.604758e7-6.1) ...
update-alternatives: using /usr/lib/libpsm1/libpsm_infinipath.so.1.16 to provide /usr/lib/x86_64-linux-gnu/libpsm_infinipath.so.1 (libpsm_infinipath.so.1) in auto mode
Setting up libjs-jquery (3.5.1+dfsg+~3.5.5-7) ...
Setting up libxml2:amd64 (2.9.10+dfsg-6.7) ...
Setting up libevent-pthreads-2.1-7:amd64 (2.1.12-stable-1) ...
Setting up libevent-extra-2.1-7:amd64 (2.1.12-stable-1) ...
Setting up libtool (2.4.6-15) ...
Setting up libevent-openssl-2.1-7:amd64 (2.1.12-stable-1) ...
Setting up m4 (1.4.18-5) ...
Setting up libhwloc-plugins:amd64 (2.4.1+dfsg-1) ...
Setting up libnuma-dev:amd64 (2.0.12-1+b1) ...
Setting up libnl-route-3-200:amd64 (3.4.0-1+b1) ...
Setting up libjs-jquery-ui (1.12.1+dfsg-8+deb11u1) ...
Setting up shared-mime-info (2.0-1) ...
Setting up libevent-dev (2.1.12-stable-1) ...
Setting up gfortran-10 (10.2.1-6) ...
Setting up autoconf (2.69-14) ...
Setting up libnl-3-dev:amd64 (3.4.0-1+b1) ...
Setting up automake (1:1.16.3-2) ...
update-alternatives: using /usr/bin/automake-1.16 to provide /usr/bin/automake (automake) in auto mode
Setting up libibverbs1:amd64 (33.2-1) ...
Setting up libpmix2:amd64 (4.0.0-4.1) ...
Setting up ibverbs-providers:amd64 (33.2-1) ...
Setting up gfortran (4:10.2.1-1) ...
update-alternatives: using /usr/bin/gfortran to provide /usr/bin/f95 (f95) in auto mode
update-alternatives: using /usr/bin/gfortran to provide /usr/bin/f77 (f77) in auto mode
Setting up libnl-route-3-dev:amd64 (3.4.0-1+b1) ...
Setting up libltdl-dev:amd64 (2.4.6-15) ...
Setting up libhwloc-dev:amd64 (2.4.1+dfsg-1) ...
Setting up libpmix-dev:amd64 (4.0.0-4.1) ...
Setting up librdmacm1:amd64 (33.2-1) ...
Setting up libucx0:amd64 (1.10.1~rc1+really.1.10.0-1) ...
Setting up libcoarrays-dev:amd64 (2.9.2-3) ...
Setting up libibverbs-dev:amd64 (33.2-1) ...
Setting up libfabric1 (1.11.0-2) ...
Setting up libopenmpi3:amd64 (4.1.0-10) ...
Setting up libcaf-openmpi-3:amd64 (2.9.2-3) ...
Setting up openmpi-bin (4.1.0-10) ...
update-alternatives: using /usr/bin/mpirun.openmpi to provide /usr/bin/mpirun (mpirun) in auto mode
update-alternatives: using /usr/bin/mpicc.openmpi to provide /usr/bin/mpicc (mpi) in auto mode
Setting up libcoarrays-openmpi-dev:amd64 (2.9.2-3) ...
update-alternatives: using /usr/lib/x86_64-linux-gnu/open-coarrays/openmpi/bin/caf to provide /usr/bin/caf.openmpi (caf-openmpi) in auto mode
update-alternatives: using /usr/bin/caf.openmpi to provide /usr/bin/caf (caf) in auto mode
Setting up libopenmpi-dev:amd64 (4.1.0-10) ...
update-alternatives: using /usr/lib/x86_64-linux-gnu/openmpi/include to provide /usr/include/x86_64-linux-gnu/mpi (mpi-x86_64-linux-gnu) in auto mode
Setting up mpi-default-dev (1.13) ...
Processing triggers for libc-bin (2.31-13+deb11u2) ...
# OS packages installation successful
# Now letting opam install the packages
[NOTE] Package ocamlfind is already installed (current version is 1.9.1).
The following actions will be performed:
  - install conf-pkg-config 2
  - install conf-mpi        1
  - install mpi             1.03
===== 3 to install =====

<><> Gathering sources ><><><><><><><><><><><><><><><><><><><><><><><><><><><><>
[mpi.1.03] found in cache
Processing  3/3:

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
Processing  1/6: [conf-pkg-config: pkg-config]
+ /usr/bin/pkg-config "--help" (CWD=/home/opam/.opam/4.13/.opam-switch/build/conf-pkg-config.2)
- Usage:
-   pkg-config [OPTION?]
- 
- Help Options:
-   -h, --help                              Show help options
- 
- Application Options:
-   --version                               output version of pkg-config
-   --modversion                            output version for package
-   --atleast-pkgconfig-version=VERSION     require given version of pkg-config
-   --libs                                  output all linker flags
-   --static                                output linker flags for static linking
-   --short-errors                          print short errors
-   --libs-only-l                           output -l flags
-   --libs-only-other                       output other libs (e.g. -pthread)
-   --libs-only-L                           output -L flags
-   --cflags                                output all pre-processor and compiler flags
-   --cflags-only-I                         output -I flags
-   --cflags-only-other                     output cflags not covered by the cflags-only-I option
-   --variable=NAME                         get the value of variable named NAME
-   --define-variable=NAME=VALUE            set variable NAME to VALUE
-   --exists                                return 0 if the module(s) exist
-   --print-variables                       output list of variables defined by the module
-   --uninstalled                           return 0 if the uninstalled version of one or more module(s) or their dependencies will be used
-   --atleast-version=VERSION               return 0 if the module is at least version VERSION
-   --exact-version=VERSION                 return 0 if the module is at exactly version VERSION
-   --max-version=VERSION                   return 0 if the module is at no newer than version VERSION
-   --list-all                              list all known packages
-   --debug                                 show verbose debug information
-   --print-errors                          show verbose information about missing or conflicting packages (default unless --exists or --atleast/exact/max-version given on the command line)
-   --silence-errors                        be silent about errors (default when --exists or --atleast/exact/max-version given on the command line)
-   --errors-to-stdout                      print errors from --print-errors to stdout not stderr
-   --print-provides                        print which packages the package provides
-   --print-requires                        print which packages the package requires
-   --print-requires-private                print which packages the package requires for static linking
-   --validate                              validate a package's .pc file
-   --define-prefix                         try to override the value of prefix for each .pc file found with a guesstimated value based on the location of the .pc file
-   --dont-define-prefix                    don't try to override the value of prefix for each .pc file found with a guesstimated value based on the location of the .pc file
-   --prefix-variable=PREFIX                set the name of the variable that pkg-config automatically sets
- 
-> compiled  conf-pkg-config.2
Processing  2/6: [conf-pkg-config: mkdir]
+ /bin/mkdir "-p" "/home/opam/.opam/4.13/lib/pkgconfig" (CWD=/home/opam/.opam/4.13/.opam-switch/build/conf-pkg-config.2)
-> installed conf-pkg-config.2
Processing  3/6: [conf-mpi: sh configure]
+ /bin/sh "configure" "linux" (CWD=/home/opam/.opam/4.13/.opam-switch/build/conf-mpi.1)
-> compiled  conf-mpi.1
-> installed conf-mpi.1
Processing  5/6: [mpi: patch]
Processing  5/6: [mpi: make all]
+ /usr/bin/make "all" "opt" "MPIINCDIR=/usr/lib/x86_64-linux-gnu/openmpi/include" "MPILIBDIR=/usr/lib/x86_64-linux-gnu/openmpi/lib/lib" "MPICC=/usr/lib/x86_64-linux-gnu/openmpi/lib/bin/mpicc" "MPIRUN=/usr/lib/x86_64-linux-gnu/openmpi/lib/bin/mpirun" (CWD=/home/opam/.opam/4.13/.opam-switch/build/mpi.1.03)
- cc -I`ocamlc -where` -I/usr/lib/x86_64-linux-gnu/openmpi/include -O2 -g -Wall   -c -o init.o init.c
- init.c: In function 'caml_mpi_error_handler':
- init.c:39:18: warning: assignment discards 'const' qualifier from pointer target type [-Wdiscarded-qualifiers]
-    39 |     caml_mpi_exn = caml_named_value("Mpi.Error");
-       |                  ^
- init.c: In function 'caml_mpi_init':
- init.c:56:38: warning: assignment discards 'const' qualifier from pointer target type [-Wdiscarded-qualifiers]
-    56 |   for (i = 0; i < argc; i++) argv[i] = String_val(Field(arguments, i));
-       |                                      ^
- init.c:62:5: error: 'MPI_Handler_function' undeclared (first use in this function); did you mean 'MPI_User_function'?
-    62 |    (MPI_Handler_function *)caml_mpi_error_handler, &hdlr);
-       |     ^~~~~~~~~~~~~~~~~~~~
-       |     MPI_User_function
- init.c:62:5: note: each undeclared identifier is reported only once for each function it appears in
- init.c:62:27: error: expected expression before ')' token
-    62 |    (MPI_Handler_function *)caml_mpi_error_handler, &hdlr);
-       |                           ^
- init.c:61:3: error: too few arguments to function 'MPI_Comm_create_errhandler'
-    61 |   MPI_Comm_create_errhandler(
-       |   ^~~~~~~~~~~~~~~~~~~~~~~~~~
- In file included from init.c:18:
- /usr/lib/x86_64-linux-gnu/openmpi/include/mpi.h:1377:20: note: declared here
-  1377 | OMPI_DECLSPEC  int MPI_Comm_create_errhandler(MPI_Comm_errhandler_function *function,
-       |                    ^~~~~~~~~~~~~~~~~~~~~~~~~~
- At top level:
- init.c:30:13: warning: 'caml_mpi_error_handler' defined but not used [-Wunused-function]
-    30 | static void caml_mpi_error_handler(MPI_Comm * comm, int * errcode, ...)
-       |             ^~~~~~~~~~~~~~~~~~~~~~
- make: *** [<builtin>: init.o] Error 1
[ERROR] The compilation of mpi failed at "/usr/bin/make all opt MPIINCDIR=/usr/lib/x86_64-linux-gnu/openmpi/include MPILIBDIR=/usr/lib/x86_64-linux-gnu/openmpi/lib/lib MPICC=/usr/lib/x86_64-linux-gnu/openmpi/lib/bin/mpicc MPIRUN=/usr/lib/x86_64-linux-gnu/openmpi/lib/bin/mpirun".

#=== ERROR while compiling mpi.1.03 ===========================================#
# context              2.0.10 | linux/x86_64 | ocaml-base-compiler.4.13.1 | file:///src
# path                 ~/.opam/4.13/.opam-switch/build/mpi.1.03
# command              /usr/bin/make all opt MPIINCDIR=/usr/lib/x86_64-linux-gnu/openmpi/include MPILIBDIR=/usr/lib/x86_64-linux-gnu/openmpi/lib/lib MPICC=/usr/lib/x86_64-linux-gnu/openmpi/lib/bin/mpicc MPIRUN=/usr/lib/x86_64-linux-gnu/openmpi/lib/bin/mpirun
# exit-code            2
# env-file             ~/.opam/log/mpi-261-60459a.env
# output-file          ~/.opam/log/mpi-261-60459a.out
### output ###
# cc -I`ocamlc -where` -I/usr/lib/x86_64-linux-gnu/openmpi/include -O2 -g -Wall   -c -o init.o init.c
# init.c: In function 'caml_mpi_error_handler':
# init.c:39:18: warning: assignment discards 'const' qualifier from pointer target type [-Wdiscarded-qualifiers]
#    39 |     caml_mpi_exn = caml_named_value("Mpi.Error");
#       |                  ^
# init.c: In function 'caml_mpi_init':
# init.c:56:38: warning: assignment discards 'const' qualifier from pointer target type [-Wdiscarded-qualifiers]
#    56 |   for (i = 0; i < argc; i++) argv[i] = String_val(Field(arguments, i));
#       |                                      ^
# init.c:62:5: error: 'MPI_Handler_function' undeclared (first use in this function); did you mean 'MPI_User_function'?
#    62 |    (MPI_Handler_function *)caml_mpi_error_handler, &hdlr);
#       |     ^~~~~~~~~~~~~~~~~~~~
#       |     MPI_User_function
# init.c:62:5: note: each undeclared identifier is reported only once for each function it appears in
# init.c:62:27: error: expected expression before ')' token
#    62 |    (MPI_Handler_function *)caml_mpi_error_handler, &hdlr);
#       |                           ^
# init.c:61:3: error: too few arguments to function 'MPI_Comm_create_errhandler'
#    61 |   MPI_Comm_create_errhandler(
#       |   ^~~~~~~~~~~~~~~~~~~~~~~~~~
# In file included from init.c:18:
# /usr/lib/x86_64-linux-gnu/openmpi/include/mpi.h:1377:20: note: declared here
#  1377 | OMPI_DECLSPEC  int MPI_Comm_create_errhandler(MPI_Comm_errhandler_function *function,
#       |                    ^~~~~~~~~~~~~~~~~~~~~~~~~~
# At top level:
# init.c:30:13: warning: 'caml_mpi_error_handler' defined but not used [-Wunused-function]
#    30 | static void caml_mpi_error_handler(MPI_Comm * comm, int * errcode, ...)
#       |             ^~~~~~~~~~~~~~~~~~~~~~
# make: *** [<builtin>: init.o] Error 1



<><> Error report <><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><>
+- The following actions failed
| - build mpi 1.03
+- 
+- The following changes have been performed
| - install conf-mpi        1
| - install conf-pkg-config 2
+- 
# Run eval $(opam env) to update the current shell environment

The former state can be restored with:
    opam switch import "/home/opam/.opam/4.13/.opam-switch/backup/state-20220212083253.export"
'opam install --verbose --yes mpi.1.03 conf-mpi.1 conf-pkg-config.2 ocamlfind.1.9.1' failed.