mirage-git

Virtual package to install the `git.mirage` libary
IN THIS PACKAGE
Empty package map

Error log

The package failed to build. The error log from opam follows.

# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
# The following system packages are needed:
autoconf
debianutils
time
The following command needs to be run through "sudo":
    apt-get install -qq -yy autoconf debianutils time
debconf: delaying package configuration, since apt-utils is not installed
Selecting previously unselected package libsigsegv2:amd64.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 18331 files and directories currently installed.)
Preparing to unpack .../0-libsigsegv2_2.13-1_amd64.deb ...
Unpacking libsigsegv2:amd64 (2.13-1) ...
Selecting previously unselected package m4.
Preparing to unpack .../1-m4_1.4.18-5_amd64.deb ...
Unpacking m4 (1.4.18-5) ...
Selecting previously unselected package autoconf.
Preparing to unpack .../2-autoconf_2.69-14_all.deb ...
Unpacking autoconf (2.69-14) ...
Selecting previously unselected package autotools-dev.
Preparing to unpack .../3-autotools-dev_20180224.1+nmu1_all.deb ...
Unpacking autotools-dev (20180224.1+nmu1) ...
Selecting previously unselected package automake.
Preparing to unpack .../4-automake_1%3a1.16.3-2_all.deb ...
Unpacking automake (1:1.16.3-2) ...
Selecting previously unselected package time.
Preparing to unpack .../5-time_1.9-0.1_amd64.deb ...
Unpacking time (1.9-0.1) ...
Setting up time (1.9-0.1) ...
Setting up autotools-dev (20180224.1+nmu1) ...
Setting up libsigsegv2:amd64 (2.13-1) ...
Setting up m4 (1.4.18-5) ...
Setting up autoconf (2.69-14) ...
Setting up automake (1:1.16.3-2) ...
update-alternatives: using /usr/bin/automake-1.16 to provide /usr/bin/automake (automake) in auto mode
Processing triggers for libc-bin (2.31-13+deb11u3) ...
# OS packages installation successful
# Now letting opam install the packages
[NOTE] Package ocamlfind is already installed (current version is 1.9.5).
[NOTE] Package dune is already installed (current version is 1.11.4).
The following actions will be performed:
  - install cppo                    1.6.9
  - install seq                     0.2.2
  - install stdlib-shims            0.3.0
  - install stringext               1.6.0
  - install base-num                base
  - install ppx_derivers            1.2.1
  - install ocamlgraph              1.8.8
  - install bigarray-compat         1.1.0
  - install base-bytes              base
  - install magic-mime              1.2.0
  - install ocamlbuild              0.14.1
  - install jbuilder                transition
  - install ppx_tools               5.0+4.05.0
  - install result                  1.5
  - install conf-which              1
  - install re                      1.9.0
  - install num                     0
  - install ocplib-endian           1.2
  - install base64                  2.3.0
  - install topkg                   1.0.5
  - install ocamlmod                0.0.9
  - install ocamlify                0.0.1
  - install cppo_ocamlbuild         1.6.9
  - install cmdliner                0.9.8
  - install ppx_traverse_builtins   v0.9.0
  - install ocaml-compiler-libs     v0.9.0
  - install ocaml-migrate-parsetree 1.8.0
  - install conf-time               1
  - install conf-autoconf           0.1
  - install sexplib                 v0.9.3
  - install mtime                   0.8.4
  - install astring                 0.8.5
  - install oasis                   0.4.11
  - install lwt                     2.7.1
  - install fmt                     0.8.9
  - install ppx_tools_versioned     5.4.0
  - install ppx_deriving            4.2.1
  - install ppx_ast                 v0.9.1
  - install hashcons                1.3
  - install base                    v0.9.4
  - install logs                    0.7.0
  - install cstruct                 2.4.1
  - install stdio                   v0.9.1
  - install ppx_cstruct             0
  - install mstruct                 1.4.0
  - install io-page                 1.6.1
  - install hex                     1.4.0
  - install cstruct-lwt             0
  - install crc                     1.0.0
  - install ppx_core                v0.9.3
  - install mirage-profile          0.7.0
  - install ppx_optcomp             v0.9.0
  - install shared-memory-ring      3.0.0
  - install ppx_driver              v0.9.2
  - install ppx_metaquot            v0.9.0
  - install fieldslib               v0.9.0
  - install ppx_type_conv           v0.9.1
  - install ppx_sexp_conv           v0.9.0
  - install ppx_fields_conv         v0.9.0
  - install uri                     1.9.2
  - install ipaddr                  2.7.2
  - install mirage-types            2.8.0
  - install mirage-types-lwt        2.8.0
  - install mirage-clock-unix       1.0.0
  - install dns                     0.18.1
  - install mirage-flow             1.1.0
  - install channel                 1.1.1
  - install mirage-unix             2.6.0
  - install mirage-console          2.1.2
  - install tcpip                   2.8.1
  - install mirage-dns              2.5.0
  - install conduit                 0.14.5
  - install mirage-conduit          2.2.0
  - install cohttp                  0.22.0
  - install mirage-http             2.5.3
  - install git                     1.8.0
  - install mirage-git              1.6.0
===== 77 to install =====

<><> Gathering sources ><><><><><><><><><><><><><><><><><><><><><><><><><><><><>
[astring.0.8.5] found in cache
Processing  1/77:
[base.v0.9.4] found in cache
Processing  2/77:
Processing  3/77:
Processing  4/77:
[base64.2.3.0] found in cache
Processing  5/77:
[bigarray-compat.1.1.0] found in cache
Processing  6/77:
[channel.1.1.1] found in cache
Processing  7/77:
[cmdliner.0.9.8] found in cache
Processing  8/77:
[cohttp.0.22.0] found in cache
Processing  9/77:
Processing 10/77: [conduit.0.14.5: http]
Processing 11/77: [conduit.0.14.5: http]
Processing 12/77: [conduit.0.14.5: http]
Processing 13/77: [conduit.0.14.5: http]
[cppo.1.6.9] found in cache
Processing 14/77: [conduit.0.14.5: http]
[cppo_ocamlbuild.1.6.9] found in cache
Processing 15/77: [conduit.0.14.5: http]
[crc.1.0.0] found in cache
Processing 16/77: [conduit.0.14.5: http]
[cstruct.2.4.1] found in cache
Processing 17/77: [conduit.0.14.5: http]
Processing 18/77: [conduit.0.14.5: http]
Processing 19/77: [conduit.0.14.5: http] [dns.0.18.1: http]
[fieldslib.v0.9.0] found in cache
Processing 20/77: [conduit.0.14.5: http] [dns.0.18.1: http]
[fmt.0.8.9] found in cache
Processing 21/77: [conduit.0.14.5: http] [dns.0.18.1: http]
Processing 22/77: [conduit.0.14.5: http] [dns.0.18.1: http] [git.1.8.0: http]
[conduit.0.14.5] downloaded from https://github.com/mirage/ocaml-conduit/archive/v0.14.5.tar.gz
Processing 22/77: [dns.0.18.1: http] [git.1.8.0: http]
[hashcons.1.3] found in cache
Processing 23/77: [dns.0.18.1: http] [git.1.8.0: http]
[hex.1.4.0] found in cache
Processing 24/77: [dns.0.18.1: http] [git.1.8.0: http]
[io-page.1.6.1] found in cache
Processing 25/77: [dns.0.18.1: http] [git.1.8.0: http]
[ipaddr.2.7.2] found in cache
Processing 26/77: [dns.0.18.1: http] [git.1.8.0: http]
Processing 27/77: [dns.0.18.1: http] [git.1.8.0: http]
[logs.0.7.0] found in cache
Processing 28/77: [dns.0.18.1: http] [git.1.8.0: http]
[lwt.2.7.1] found in cache
Processing 29/77: [dns.0.18.1: http] [git.1.8.0: http]
[dns.0.18.1] downloaded from https://github.com/mirage/ocaml-dns/archive/v0.18.1.tar.gz
Processing 29/77: [git.1.8.0: http]
[magic-mime.1.2.0] found in cache
Processing 30/77: [git.1.8.0: http]
[mirage-clock-unix.1.0.0] found in cache
Processing 31/77: [git.1.8.0: http]
[git.1.8.0] downloaded from https://github.com/mirage/ocaml-git/archive/1.8.0.tar.gz
Processing 31/77:
Processing 32/77:
[mirage-console.2.1.2] found in cache
Processing 33/77:
Processing 34/77:
[mirage-flow.1.1.0] found in cache
Processing 35/77:
Processing 36/77:
Processing 37/77: [mirage-http.2.5.3: http]
[mirage-profile.0.7.0] found in cache
Processing 38/77: [mirage-http.2.5.3: http]
[mirage-types.2.8.0] found in cache
Processing 39/77: [mirage-http.2.5.3: http]
Processing 40/77: [mirage-http.2.5.3: http]
[mirage-unix.2.6.0] found in cache
Processing 41/77: [mirage-http.2.5.3: http]
[mstruct.1.4.0] found in cache
Processing 42/77: [mirage-http.2.5.3: http]
[mtime.0.8.4] found in cache
Processing 43/77: [mirage-http.2.5.3: http]
Processing 44/77: [mirage-http.2.5.3: http]
[oasis.0.4.11] found in cache
Processing 45/77: [mirage-http.2.5.3: http]
[ocaml-compiler-libs.v0.9.0] found in cache
Processing 46/77: [mirage-http.2.5.3: http]
[ocaml-migrate-parsetree.1.8.0] found in cache
Processing 47/77: [mirage-http.2.5.3: http]
[ocamlbuild.0.14.1] found in cache
Processing 48/77: [mirage-http.2.5.3: http]
[mirage-http.2.5.3] downloaded from https://github.com/ocaml/opam-source-archives/raw/main/mirage-http-2.5.3.tbz
Processing 48/77:
[ocamlgraph.1.8.8] found in cache
Processing 49/77:
[ocamlify.0.0.1] found in cache
Processing 50/77:
[ocamlmod.0.0.9] found in cache
Processing 51/77:
[ocplib-endian.1.2] found in cache
Processing 52/77:
[ppx_ast.v0.9.1] found in cache
Processing 53/77:
[ppx_core.v0.9.3] found in cache
Processing 54/77:
Processing 55/77:
[ppx_derivers.1.2.1] found in cache
Processing 56/77:
[ppx_deriving.4.2.1] found in cache
Processing 57/77:
[ppx_driver.v0.9.2] found in cache
Processing 58/77:
[ppx_fields_conv.v0.9.0] found in cache
Processing 59/77:
[ppx_metaquot.v0.9.0] found in cache
Processing 60/77:
[ppx_optcomp.v0.9.0] found in cache
Processing 61/77:
[ppx_sexp_conv.v0.9.0] found in cache
Processing 62/77:
[ppx_tools.5.0+4.05.0] found in cache
Processing 63/77:
[ppx_tools_versioned.5.4.0] found in cache
Processing 64/77:
[ppx_traverse_builtins.v0.9.0] found in cache
Processing 65/77:
[ppx_type_conv.v0.9.1] found in cache
Processing 66/77:
[re.1.9.0] found in cache
Processing 67/77:
[result.1.5] found in cache
Processing 68/77:
[seq.0.2.2] found in cache
Processing 69/77:
[sexplib.v0.9.3] found in cache
Processing 70/77:
[shared-memory-ring.3.0.0] found in cache
Processing 71/77:
[stdio.v0.9.1] found in cache
Processing 72/77:
[stdlib-shims.0.3.0] found in cache
Processing 73/77:
[stringext.1.6.0] found in cache
Processing 74/77:
Processing 75/77: [tcpip.2.8.1: http]
[topkg.1.0.5] found in cache
Processing 76/77: [tcpip.2.8.1: http]
[uri.1.9.2] found in cache
Processing 77/77: [tcpip.2.8.1: http]
[ERROR] The sources of the following couldn't be obtained, aborting:
          - tcpip.2.8.1:
            https://github.com/mirage/mirage-tcpip/archive/v2.8.1.tar.gz (Bad checksum, expected md5=1704b769cc0debc071bd50fcd4e8379c)

'opam install --verbose --yes mirage-git.1.6.0 astring.0.8.5 base.v0.9.4 base-bytes.base base-num.base base64.2.3.0 bigarray-compat.1.1.0 channel.1.1.1 cmdliner.0.9.8 cohttp.0.22.0 conduit.0.14.5 conf-autoconf.0.1 conf-time.1 conf-which.1 cppo.1.6.9 cppo_ocamlbuild.1.6.9 crc.1.0.0 cstruct.2.4.1 cstruct-lwt.0 dns.0.18.1 dune.1.11.4 fieldslib.v0.9.0 fmt.0.8.9 git.1.8.0 hashcons.1.3 hex.1.4.0 io-page.1.6.1 ipaddr.2.7.2 jbuilder.transition logs.0.7.0 lwt.2.7.1 magic-mime.1.2.0 mirage-clock-unix.1.0.0 mirage-conduit.2.2.0 mirage-console.2.1.2 mirage-dns.2.5.0 mirage-flow.1.1.0 mirage-http.2.5.3 mirage-profile.0.7.0 mirage-types.2.8.0 mirage-types-lwt.2.8.0 mirage-unix.2.6.0 mstruct.1.4.0 mtime.0.8.4 num.0 oasis.0.4.11 ocaml-compiler-libs.v0.9.0 ocaml-migrate-parsetree.1.8.0 ocamlbuild.0.14.1 ocamlfind.1.9.5 ocamlgraph.1.8.8 ocamlify.0.0.1 ocamlmod.0.0.9 ocplib-endian.1.2 ppx_ast.v0.9.1 ppx_core.v0.9.3 ppx_cstruct.0 ppx_derivers.1.2.1 ppx_deriving.4.2.1 ppx_driver.v0.9.2 ppx_fields_conv.v0.9.0 ppx_metaquot.v0.9.0 ppx_optcomp.v0.9.0 ppx_sexp_conv.v0.9.0 ppx_tools.5.0+4.05.0 ppx_tools_versioned.5.4.0 ppx_traverse_builtins.v0.9.0 ppx_type_conv.v0.9.1 re.1.9.0 result.1.5 seq.0.2.2 sexplib.v0.9.3 shared-memory-ring.3.0.0 stdio.v0.9.1 stdlib-shims.0.3.0 stringext.1.6.0 tcpip.2.8.1 topkg.1.0.5 uri.1.9.2' failed.