package melange-recharts

  1. Overview
  2. Docs
On This Page
  1. Error log

melange-recharts 4.0.0

Error log

The package failed to build. The error log from opam follows.

Opam plugin "depext" may require upgrading/reinstalling. Reinstall the plugin on the current switch? [Y/n] y
The following actions will be performed:
  - recompile opam-depext 1.2.1-1

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved opam-depext.1.2.1-1  (cached)
-> removed   opam-depext.1.2.1-1
-> installed opam-depext.1.2.1-1
Done.

<><> opam-depext.1.2.1-1 installed successfully <><><><><><><><><><><><><><><><>
=> opam-depext is unnecessary when used with opam >= 2.1. Please use opam install directly instead
# Run eval $(opam env) to update the current shell environment

<><> Carrying on to "opam depext -viy melange-recharts.4.0.0 stdlib-shims.0.3.0 sexplib0.v0.16.0 reason-react-ppx.0.13.0 reason-react.0.13.0 reason.3.11.0 ppxlib.0.32.1~5.2preview ppx_derivers.1.2.1 ocamlfind.1.9.6 ocaml-compiler-libs.v0.12.4 merlin-extend.0.6.1 menhirSdk.20231231 menhirLib.20231231 menhirCST.20231231 menhir.20231231 melange.2.1.0 fix.20230505 dune-build-info.3.14.0 dune.3.14.0 cppo.1.6.9 cmdliner.1.2.0" 

You are using opam 2.1+, where external dependency handling has been integrated: consider calling opam directly, the 'depext' plugin interface is provided for backwards compatibility only
# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
[ERROR] No solution for melange-recharts.4.0.0 & stdlib-shims.0.3.0 & sexplib0.v0.16.0 & reason-react-ppx.0.13.0 & reason-react.0.13.0 & reason.3.11.0 & ppxlib.0.32.1~5.2preview & ppx_derivers.1.2.1 & ocamlfind.1.9.6 & ocaml-compiler-libs.v0.12.4 & merlin-extend.0.6.1 & menhirSdk.20231231 & menhirLib.20231231 & menhirCST.20231231 & menhir.20231231 & melange.2.1.0 & fix.20230505 & dune-build-info.3.14.0 & dune.3.14.0 & cppo.1.6.9 & cmdliner.1.2.0:   * No agreement on the version of ocaml:
            - (invariant) -> ocaml-base-compiler = 5.1.1 -> ocaml = 5.1.1
            - melange = 2.1.0 -> ocaml < 5.1.1
            You can temporarily relax the switch invariant with `--update-invariant'
          * Incompatible packages:
            - (invariant) -> ocaml-base-compiler = 5.1.1
            - melange = 2.1.0 -> ocaml < 5.1.1 -> ocaml-system >= 4.00.0
          * Missing dependency:
            - melange = 2.1.0 -> ocaml < 5.1.1 -> ocaml-base-compiler < 3.07+1 | ocaml-system < 3.07+1 | ocaml-variants < 3.8~
            not available because the package is pinned to version 5.1.1
            unmet availability conditions: 'sys-ocaml-version = "3.07"'
            no matching version
          * Missing dependency:
            - melange = 2.1.0 -> ocaml < 5.1.1 -> ocaml-base-compiler = 3.07+1 | ocaml-system = 3.07+1 | ocaml-variants < 3.8~
            not available because the package is pinned to version 5.1.1
            unmet availability conditions: 'sys-ocaml-version = "3.07+1"'
            no matching version
          * Missing dependency:
            - melange = 2.1.0 -> ocaml < 5.1.1 -> ocaml-base-compiler = 3.07+2 | ocaml-system = 3.07+2 | ocaml-variants < 3.8~
            not available because the package is pinned to version 5.1.1
            unmet availability conditions: 'sys-ocaml-version = "3.07+2"'
            no matching version
          * Missing dependency:
            - melange = 2.1.0 -> ocaml < 5.1.1 -> ocaml-base-compiler = 3.08.0 | ocaml-system < 3.08.1~ | ocaml-variants < 3.08.1~
            not available because the package is pinned to version 5.1.1
            unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.0"'
            no matching version
          * Missing dependency:
            - melange = 2.1.0 -> ocaml < 5.1.1 -> ocaml-base-compiler = 3.08.1 | ocaml-system < 3.08.2~ | ocaml-variants < 3.08.2~
            not available because the package is pinned to version 5.1.1
            unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.1"'
            no matching version
          * Missing dependency:
            - melange = 2.1.0 -> ocaml < 5.1.1 -> ocaml-base-compiler = 3.08.2 | ocaml-system < 3.08.3~ | ocaml-variants < 3.08.3~
            not available because the package is pinned to version 5.1.1
            unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.2"'
            no matching version
          * Missing dependency:
            - melange = 2.1.0 -> ocaml < 5.1.1 -> ocaml-base-compiler = 3.08.3 | ocaml-system < 3.08.4~ | ocaml-variants < 3.08.4~
            not available because the package is pinned to version 5.1.1
            unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.3"'
            no matching version
          * Missing dependency:
            - melange = 2.1.0 -> ocaml < 5.1.1 -> ocaml-base-compiler = 3.08.4 | ocaml-system < 3.08.5~ | ocaml-variants < 3.08.5~
            not available because the package is pinned to version 5.1.1
            unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.4"'
            no matching version
          * Missing dependency:
            - melange = 2.1.0 -> ocaml < 5.1.1 -> ocaml-base-compiler = 3.09.0 | ocaml-system < 3.09.1~ | ocaml-variants < 3.09.1~
            not available because the package is pinned to version 5.1.1
            unmet availability conditions, e.g. 'sys-ocaml-version = "3.09.0"'
            no matching version


Command failed: opam --cli=2.1 list --readonly --external '--resolve=melange-recharts.4.0.0,stdlib-shims.0.3.0,sexplib0.v0.16.0,reason-react-ppx.0.13.0,reason-react.0.13.0,reason.3.11.0,ppxlib.0.32.1~5.2preview,ppx_derivers.1.2.1,ocamlfind.1.9.6,ocaml-compiler-libs.v0.12.4,merlin-extend.0.6.1,menhirSdk.20231231,menhirLib.20231231,menhirCST.20231231,menhir.20231231,melange.2.1.0,fix.20230505,dune-build-info.3.14.0,dune.3.14.0,cppo.1.6.9,cmdliner.1.2.0' returned 20