package libvhd

  1. Overview
  2. Docs
On This Page
  1. Error log

libvhd 0.9.0

Error log

The package failed to build. The error log from opam follows.

Opam plugin "depext" may require upgrading/reinstalling. Reinstall the plugin on the current switch? [Y/n] y
The following actions will be performed:
  - recompile opam-depext 1.2.1-1

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved opam-depext.1.2.1-1  (cached)
-> removed   opam-depext.1.2.1-1
-> installed opam-depext.1.2.1-1

<><> opam-depext.1.2.1-1 installed successfully <><><><><><><><><><><><><><><><>
=> opam-depext is unnecessary when used with opam >= 2.1. Please use opam install directly instead
# Run eval $(opam env) to update the current shell environment

<><> Carrying on to "opam depext -viy libvhd.0.9.0 ocamlmod.0.0.9 ocamlify.0.0.1 ocamlfind.1.9.6 ocamlbuild.0.14.3 oasis.0.4.11" 

You are using opam 2.1+, where external dependency handling has been integrated: consider calling opam directly, the 'depext' plugin interface is provided for backwards compatibility only
# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
[ERROR] No solution for libvhd.0.9.0 & ocamlmod.0.0.9 & ocamlify.0.0.1 & ocamlfind.1.9.6 & ocamlbuild.0.14.3 & oasis.0.4.11:   * Missing dependency:
            - libvhd
            depends on the unavailable system package 'blktap-dev'. Use `--no-depexts' to attempt installation anyway, or it is possible that a depext package name in the opam file is incorrect.

Command failed: opam --cli=2.1 list --readonly --external '--resolve=libvhd.0.9.0,ocamlmod.0.0.9,ocamlify.0.0.1,ocamlfind.1.9.6,ocamlbuild.0.14.3,oasis.0.4.11' returned 20

Innovation. Community. Security.