horned_worm

A functional Web app server.
IN THIS PACKAGE
Empty package map

Error log

The package failed to build. The error log from opam follows.

# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
# No extra OS packages requirements found.
# All required OS packages found.
# Now letting opam install the packages
[NOTE] Package ocamlfind is already installed (current version is 1.9.5).
[NOTE] Package dune is already installed (current version is 1.11.4).
The following actions will be performed:
  - install cppo                    1.6.9
  - install seq                     0.2.2
  - install stdlib-shims            0.3.0
  - install stringext               1.6.0
  - install octavius                1.2.2
  - install base-num                base
  - install ppx_derivers            1.2.1
  - install base-bytes              base
  - install magic-mime              1.2.0
  - install ocamlbuild              0.14.1
  - install jbuilder                transition
  - install result                  1.5
  - install yojson                  2.0.0
  - install re                      1.9.0
  - install num                     0
  - install base64                  2.3.0
  - install uchar                   0.0.2
  - install topkg                   1.0.5
  - install spawn                   v0.9.0
  - install ppx_traverse_builtins   v0.9.0
  - install ocaml-compiler-libs     v0.9.0
  - install jane-street-headers     v0.9.0
  - install ocaml-migrate-parsetree 1.8.0
  - install sexplib                 v0.9.3
  - install uutf                    1.0.3
  - install fmt                     0.8.9
  - install astring                 0.8.5
  - install ppx_ast                 v0.9.1
  - install base                    v0.9.4
  - install jsonm                   1.0.1
  - install logs                    0.7.0
  - install typerep                 v0.9.0
  - install stdio                   v0.9.1
  - install ppx_core                v0.9.3
  - install ppx_optcomp             v0.9.0
  - install ppx_driver              v0.9.2
  - install variantslib             v0.9.0
  - install ppx_metaquot            v0.9.0
  - install ppx_let                 v0.9.0
  - install ppx_here                v0.9.1
  - install fieldslib               v0.9.0
  - install ppx_type_conv           v0.9.1
  - install ppx_pipebang            v0.9.0
  - install ppx_optional            v0.9.0
  - install ppx_js_style            v0.9.0
  - install ppx_inline_test         v0.9.2
  - install ppx_fail                v0.9.0
  - install ppx_variants_conv       v0.9.0
  - install ppx_typerep_conv        v0.9.0
  - install ppx_traverse            v0.9.0
  - install ppx_sexp_conv           v0.9.0
  - install ppx_fields_conv         v0.9.0
  - install ppx_enumerate           v0.9.0
  - install ppx_compare             v0.9.0
  - install ppx_bench               v0.9.1
  - install uri                     1.9.7
  - install ppx_sexp_value          v0.9.0
  - install ppx_sexp_message        v0.9.0
  - install ppx_custom_printf       v0.9.0
  - install ipaddr                  2.9.0
  - install ppx_hash                v0.9.0
  - install ppx_assert              v0.9.0
  - install cohttp                  0.99.0
  - install bin_prot                v0.9.2
  - install conduit                 1.0.3
  - install ppx_base                v0.9.0
  - install ppx_expect              v0.9.0
  - install ppx_bin_prot            v0.9.0
  - install configurator            v0.9.1
  - install ppx_jane                v0.9.0
  - install core_kernel             v0.9.1
  - install core                    v0.9.2
  - install async_kernel            v0.9.0
  - install async_unix              v0.9.1
  - install async_rpc_kernel        v0.9.0
  - install async_extra             v0.9.0
  - install async                   v0.9.0
  - install conduit-async           1.0.0
  - install cohttp-async            0.99.0
  - install horned_worm             0.3.1
===== 80 to install =====

<><> Gathering sources ><><><><><><><><><><><><><><><><><><><><><><><><><><><><>
[astring.0.8.5] found in cache
Processing  1/80:
Processing  2/80: [async.v0.9.0: http]
Processing  3/80: [async.v0.9.0: http] [async_extra.v0.9.0: http]
[async_kernel.v0.9.0] found in cache
Processing  4/80: [async.v0.9.0: http] [async_extra.v0.9.0: http]
Processing  5/80: [async.v0.9.0: http] [async_extra.v0.9.0: http] [async_rpc_kernel.v0.9.0: http]
[async.v0.9.0] downloaded from https://ocaml.janestreet.com/ocaml-core/v0.9/files/async-v0.9.0.tar.gz
Processing  5/80: [async_extra.v0.9.0: http] [async_rpc_kernel.v0.9.0: http]
Processing  6/80: [async_extra.v0.9.0: http] [async_rpc_kernel.v0.9.0: http] [async_unix.v0.9.1: http]
[async_extra.v0.9.0] downloaded from https://ocaml.janestreet.com/ocaml-core/v0.9/files/async_extra-v0.9.0.tar.gz
Processing  6/80: [async_rpc_kernel.v0.9.0: http] [async_unix.v0.9.1: http]
[async_rpc_kernel.v0.9.0] downloaded from https://ocaml.janestreet.com/ocaml-core/v0.9/files/async_rpc_kernel-v0.9.0.tar.gz
Processing  6/80: [async_unix.v0.9.1: http]
[base.v0.9.4] found in cache
Processing  7/80: [async_unix.v0.9.1: http]
[async_unix.v0.9.1] downloaded from https://github.com/janestreet/async_unix/archive/v0.9.1.tar.gz
Processing  7/80:
Processing  8/80:
Processing  9/80:
[base64.2.3.0] found in cache
Processing 10/80:
Processing 11/80: [bin_prot.v0.9.2: http]
[cohttp.0.99.0] found in cache
Processing 12/80: [bin_prot.v0.9.2: http]
[cohttp-async.0.99.0] found in cache
Processing 13/80: [bin_prot.v0.9.2: http]
[conduit.1.0.3] found in cache
Processing 14/80: [bin_prot.v0.9.2: http]
[bin_prot.v0.9.2] downloaded from https://github.com/janestreet/bin_prot/archive/v0.9.2.tar.gz
Processing 14/80:
[conduit-async.1.0.0] found in cache
Processing 15/80:
[configurator.v0.9.1] found in cache
Processing 16/80:
Processing 17/80: [core.v0.9.2: http]
Processing 18/80: [core.v0.9.2: http] [core_kernel.v0.9.1: http]
[cppo.1.6.9] found in cache
Processing 19/80: [core.v0.9.2: http] [core_kernel.v0.9.1: http]
[core.v0.9.2] downloaded from https://github.com/janestreet/core/archive/v0.9.2.tar.gz
Processing 19/80: [core_kernel.v0.9.1: http]
[fieldslib.v0.9.0] found in cache
Processing 20/80: [core_kernel.v0.9.1: http]
[core_kernel.v0.9.1] downloaded from https://github.com/janestreet/core_kernel/archive/v0.9.1.tar.gz
Processing 20/80:
[fmt.0.8.9] found in cache
Processing 21/80:
Processing 22/80: [horned_worm.0.3.1: http]
[ipaddr.2.9.0] found in cache
Processing 23/80: [horned_worm.0.3.1: http]
[jane-street-headers.v0.9.0] found in cache
Processing 24/80: [horned_worm.0.3.1: http]
[horned_worm.0.3.1] downloaded from https://github.com/kkazuo/horned_worm/archive/v0.3.1.tar.gz
Processing 24/80:
Processing 25/80:
[jsonm.1.0.1] found in cache
Processing 26/80:
[logs.0.7.0] found in cache
Processing 27/80:
[magic-mime.1.2.0] found in cache
Processing 28/80:
Processing 29/80:
[ocaml-compiler-libs.v0.9.0] found in cache
Processing 30/80:
[ocaml-migrate-parsetree.1.8.0] found in cache
Processing 31/80:
[ocamlbuild.0.14.1] found in cache
Processing 32/80:
[octavius.1.2.2] found in cache
Processing 33/80:
[ppx_assert.v0.9.0] found in cache
Processing 34/80:
[ppx_ast.v0.9.1] found in cache
Processing 35/80:
[ppx_base.v0.9.0] found in cache
Processing 36/80:
[ppx_bench.v0.9.1] found in cache
Processing 37/80:
[ppx_bin_prot.v0.9.0] found in cache
Processing 38/80:
[ppx_compare.v0.9.0] found in cache
Processing 39/80:
[ppx_core.v0.9.3] found in cache
Processing 40/80:
[ppx_custom_printf.v0.9.0] found in cache
Processing 41/80:
[ppx_derivers.1.2.1] found in cache
Processing 42/80:
[ppx_driver.v0.9.2] found in cache
Processing 43/80:
[ppx_enumerate.v0.9.0] found in cache
Processing 44/80:
[ppx_expect.v0.9.0] found in cache
Processing 45/80:
[ppx_fail.v0.9.0] found in cache
Processing 46/80:
[ppx_fields_conv.v0.9.0] found in cache
Processing 47/80:
[ppx_hash.v0.9.0] found in cache
Processing 48/80:
[ppx_here.v0.9.1] found in cache
Processing 49/80:
[ppx_inline_test.v0.9.2] found in cache
Processing 50/80:
[ppx_jane.v0.9.0] found in cache
Processing 51/80:
[ppx_js_style.v0.9.0] found in cache
Processing 52/80:
[ppx_let.v0.9.0] found in cache
Processing 53/80:
[ppx_metaquot.v0.9.0] found in cache
Processing 54/80:
[ppx_optcomp.v0.9.0] found in cache
Processing 55/80:
[ppx_optional.v0.9.0] found in cache
Processing 56/80:
[ppx_pipebang.v0.9.0] found in cache
Processing 57/80:
[ppx_sexp_conv.v0.9.0] found in cache
Processing 58/80:
[ppx_sexp_message.v0.9.0] found in cache
Processing 59/80:
[ppx_sexp_value.v0.9.0] found in cache
Processing 60/80:
[ppx_traverse.v0.9.0] found in cache
Processing 61/80:
[ppx_traverse_builtins.v0.9.0] found in cache
Processing 62/80:
[ppx_type_conv.v0.9.1] found in cache
Processing 63/80:
[ppx_typerep_conv.v0.9.0] found in cache
Processing 64/80:
[ppx_variants_conv.v0.9.0] found in cache
Processing 65/80:
[re.1.9.0] found in cache
Processing 66/80:
[result.1.5] found in cache
Processing 67/80:
[seq.0.2.2] found in cache
Processing 68/80:
[sexplib.v0.9.3] found in cache
Processing 69/80:
[spawn.v0.9.0] found in cache
Processing 70/80:
[stdio.v0.9.1] found in cache
Processing 71/80:
[stdlib-shims.0.3.0] found in cache
Processing 72/80:
[stringext.1.6.0] found in cache
Processing 73/80:
[topkg.1.0.5] found in cache
Processing 74/80:
[typerep.v0.9.0] found in cache
Processing 75/80:
[uchar.0.0.2] found in cache
Processing 76/80:
[uri.1.9.7] found in cache
Processing 77/80:
[uutf.1.0.3] found in cache
Processing 78/80:
[variantslib.v0.9.0] found in cache
Processing 79/80:
[yojson.2.0.0] found in cache
Processing 80/80:

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
Processing  3/160: [cppo: dune build]
Processing  4/160: [cppo: dune build]
Processing  5/160: [cppo: dune build] [magic-mime: dune build]
Processing  6/160: [cppo: dune build] [magic-mime: dune build] [ocamlbuild: make configure.make]
Processing  7/160: [cppo: dune build] [magic-mime: dune build] [ocamlbuild: make configure.make] [octavius: dune build]
Processing  8/160: [cppo: dune build] [magic-mime: dune build] [ocamlbuild: make configure.make] [octavius: dune build] [ppx_derivers: dune build]
Processing  9/160: [cppo: dune build] [magic-mime: dune build] [ocamlbuild: make configure.make] [octavius: dune build] [ppx_derivers: dune build] [result: dune build]
Processing 10/160: [cppo: dune build] [magic-mime: dune build] [ocamlbuild: make configure.make] [octavius: dune build] [ppx_derivers: dune build] [result: dune build] [seq: dune build]
Processing 11/160: [cppo: dune build] [magic-mime: dune build] [ocamlbuild: make configure.make] [octavius: dune build] [ppx_derivers: dune build] [result: dune build] [seq: dune build] [stdlib-shims: dune build]
Processing 12/160: [cppo: dune build] [magic-mime: dune build] [ocamlbuild: make configure.make] [octavius: dune build] [ppx_derivers: dune build] [result: dune build] [seq: dune build] [stdlib-shims: dune build] [stringext: dune build]
-> installed base-bytes.base
Processing 13/160: [cppo: dune build] [magic-mime: dune build] [ocamlbuild: make configure.make] [octavius: dune build] [ppx_derivers: dune build] [result: dune build] [seq: dune build] [stdlib-shims: dune build] [stringext: dune build]
Processing 14/160: [base64: dune subst] [cppo: dune build] [magic-mime: dune build] [ocamlbuild: make configure.make] [octavius: dune build] [ppx_derivers: dune build] [result: dune build] [seq: dune build] [stdlib-shims: dune build] [stringext: dune build]
-> installed base-num.base
Processing 15/160: [base64: dune subst] [cppo: dune build] [magic-mime: dune build] [ocamlbuild: make configure.make] [octavius: dune build] [ppx_derivers: dune build] [result: dune build] [seq: dune build] [stdlib-shims: dune build] [stringext: dune build]
Processing 16/160: [base64: dune subst] [cppo: dune build] [magic-mime: dune build] [ocamlbuild: make configure.make] [octavius: dune build] [ppx_derivers: dune build] [result: dune build] [seq: dune build] [stdlib-shims: dune build] [stringext: dune build]
-> installed jbuilder.transition
Processing 17/160: [base64: dune subst] [cppo: dune build] [magic-mime: dune build] [ocamlbuild: make configure.make] [octavius: dune build] [ppx_derivers: dune build] [result: dune build] [seq: dune build] [stdlib-shims: dune build] [stringext: dune build]
Processing 18/160: [base64: dune subst] [cppo: dune build] [jane-street-headers: jbuilder build] [magic-mime: dune build] [ocamlbuild: make configure.make] [octavius: dune build] [ppx_derivers: dune build] [result: dune build] [seq: dune build] [stdlib-shims: dune build] [stringext: dune build]
Processing 19/160: [base64: dune subst] [cppo: dune build] [jane-street-headers: jbuilder build] [magic-mime: dune build] [ocaml-compiler-libs: jbuilder build] [ocamlbuild: make configure.make] [octavius: dune build] [ppx_derivers: dune build] [result: dune build] [seq: dune build] [stdlib-shims: dune build] [stringext: dune build]
Processing 20/160: [base64: dune subst] [cppo: dune build] [jane-street-headers: jbuilder build] [magic-mime: dune build] [ocaml-compiler-libs: jbuilder build] [ocamlbuild: make configure.make] [octavius: dune build] [ppx_derivers: dune build] [ppx_traverse_builtins: jbuilder build] [result: dune build] [seq: dune build] [stdlib-shims: dune build] [stringext: dune build]
Processing 21/160: [base64: dune subst] [cppo: dune build] [jane-street-headers: jbuilder build] [magic-mime: dune build] [ocaml-compiler-libs: jbuilder build] [ocamlbuild: make configure.make] [octavius: dune build] [ppx_derivers: dune build] [ppx_traverse_builtins: jbuilder build] [result: dune build] [seq: dune build] [spawn: jbuilder build] [stdlib-shims: dune build] [stringext: dune build]
-> installed num.0
Processing 22/160: [base64: dune subst] [cppo: dune build] [jane-street-headers: jbuilder build] [magic-mime: dune build] [ocaml-compiler-libs: jbuilder build] [ocamlbuild: make configure.make] [octavius: dune build] [ppx_derivers: dune build] [ppx_traverse_builtins: jbuilder build] [result: dune build] [seq: dune build] [spawn: jbuilder build] [stdlib-shims: dune build] [stringext: dune build]
Processing 23/160: [base64: dune subst] [cppo: dune build] [jane-street-headers: jbuilder build] [magic-mime: dune build] [ocaml-compiler-libs: jbuilder build] [ocamlbuild: make configure.make] [octavius: dune build] [ppx_derivers: dune build] [ppx_traverse_builtins: jbuilder build] [result: dune build] [seq: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [stdlib-shims: dune build] [stringext: dune build]
+ /home/opam/.opam/4.05/bin/dune "build" "-p" "cppo" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/cppo.1.6.9)
-> compiled  cppo.1.6.9
Processing 23/160: [base64: dune subst] [jane-street-headers: jbuilder build] [magic-mime: dune build] [ocaml-compiler-libs: jbuilder build] [ocamlbuild: make configure.make] [octavius: dune build] [ppx_derivers: dune build] [ppx_traverse_builtins: jbuilder build] [result: dune build] [seq: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [stdlib-shims: dune build] [stringext: dune build]
-> installed cppo.1.6.9
Processing 24/160: [base64: dune subst] [jane-street-headers: jbuilder build] [magic-mime: dune build] [ocaml-compiler-libs: jbuilder build] [ocamlbuild: make configure.make] [octavius: dune build] [ppx_derivers: dune build] [ppx_traverse_builtins: jbuilder build] [result: dune build] [seq: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [stdlib-shims: dune build] [stringext: dune build]
+ /home/opam/.opam/4.05/bin/dune "build" "-p" "magic-mime" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/magic-mime.1.2.0)
-> compiled  magic-mime.1.2.0
Processing 24/160: [base64: dune subst] [jane-street-headers: jbuilder build] [ocaml-compiler-libs: jbuilder build] [ocamlbuild: make configure.make] [octavius: dune build] [ppx_derivers: dune build] [ppx_traverse_builtins: jbuilder build] [result: dune build] [seq: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [stdlib-shims: dune build] [stringext: dune build]
-> installed magic-mime.1.2.0
Processing 25/160: [base64: dune subst] [jane-street-headers: jbuilder build] [ocaml-compiler-libs: jbuilder build] [ocamlbuild: make configure.make] [octavius: dune build] [ppx_derivers: dune build] [ppx_traverse_builtins: jbuilder build] [result: dune build] [seq: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [stdlib-shims: dune build] [stringext: dune build]
+ /usr/bin/make "-f" "configure.make" "all" "OCAMLBUILD_PREFIX=/home/opam/.opam/4.05" "OCAMLBUILD_BINDIR=/home/opam/.opam/4.05/bin" "OCAMLBUILD_LIBDIR=/home/opam/.opam/4.05/lib" "OCAMLBUILD_MANDIR=/home/opam/.opam/4.05/man" "OCAML_NATIVE=true" "OCAML_NATIVE_TOOLS=true" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1)
- (echo "# This file was generated from configure.make"; \
- echo ;\
- echo "OCAML_PREFIX=/home/opam/.opam/4.05"; \
- echo "OCAML_BINDIR=/home/opam/.opam/4.05/bin"; \
- echo "OCAML_LIBDIR=/home/opam/.opam/4.05/lib/ocaml"; \
- echo "OCAML_MANDIR=/home/opam/.opam/4.05/man"; \
- echo ;\
- echo "EXT_OBJ=.o"; \
- echo "EXT_ASM=.s"; \
- echo "EXT_LIB=.a"; \
- echo "EXT_DLL=.so"; \
- echo "EXE="; \
- echo ;\
- echo "OCAML_NATIVE=true"; \
- echo "OCAML_NATIVE_TOOLS=true"; \
- echo "NATDYNLINK=true"; \
- echo "SUPPORT_SHARED_LIBRARIES=true"; \
- echo ;\
- echo "PREFIX=/home/opam/.opam/4.05"; \
- echo "BINDIR=/home/opam/.opam/4.05/bin"; \
- echo "LIBDIR=/home/opam/.opam/4.05/lib"; \
- echo "MANDIR=/home/opam/.opam/4.05/man"; \
- ) > Makefile.config
- (echo "(* This file was generated from ../configure.make *)"; \
- echo ;\
- echo 'let bindir = "/home/opam/.opam/4.05/bin"'; \
- echo 'let libdir = "/home/opam/.opam/4.05/lib"'; \
- echo 'let ocaml_libdir = "/home/opam/.opam/4.05/lib/ocaml"'; \
- echo 'let libdir_abs = "/home/opam/.opam/4.05/lib"'; \
- echo 'let ocaml_native = true'; \
- echo 'let ocaml_native_tools = true'; \
- echo 'let supports_shared_libraries = true';\
- echo 'let a = "a"'; \
- echo 'let o = "o"'; \
- echo 'let so = "so"'; \
- echo 'let ext_dll = ".so"'; \
- echo 'let exe = ""'; \
- echo 'let version = "0.14.1"'; \
- ) > src/ocamlbuild_config.ml
- (echo "# This file was generated from configure.make"; \
- echo ;\
- echo "OCAML_PREFIX=/home/opam/.opam/4.05"; \
- echo "OCAML_BINDIR=/home/opam/.opam/4.05/bin"; \
- echo "OCAML_LIBDIR=/home/opam/.opam/4.05/lib/ocaml"; \
- echo "OCAML_MANDIR=/home/opam/.opam/4.05/man"; \
- echo ;\
- echo "EXT_OBJ=.o"; \
- echo "EXT_ASM=.s"; \
- echo "EXT_LIB=.a"; \
- echo "EXT_DLL=.so"; \
- echo "EXE="; \
- echo ;\
- echo "OCAML_NATIVE=true"; \
- echo "OCAML_NATIVE_TOOLS=true"; \
- echo "NATDYNLINK=true"; \
- echo "SUPPORT_SHARED_LIBRARIES=true"; \
- echo ;\
- echo "PREFIX=/home/opam/.opam/4.05"; \
- echo "BINDIR=/home/opam/.opam/4.05/bin"; \
- echo "LIBDIR=/home/opam/.opam/4.05/lib"; \
- echo "MANDIR=/home/opam/.opam/4.05/man"; \
- ) > Makefile.config
- (echo "(* This file was generated from ../configure.make *)"; \
- echo ;\
- echo 'let bindir = "/home/opam/.opam/4.05/bin"'; \
- echo 'let libdir = "/home/opam/.opam/4.05/lib"'; \
- echo 'let ocaml_libdir = "/home/opam/.opam/4.05/lib/ocaml"'; \
- echo 'let libdir_abs = "/home/opam/.opam/4.05/lib"'; \
- echo 'let ocaml_native = true'; \
- echo 'let ocaml_native_tools = true'; \
- echo 'let supports_shared_libraries = true';\
- echo 'let a = "a"'; \
- echo 'let o = "o"'; \
- echo 'let so = "so"'; \
- echo 'let ext_dll = ".so"'; \
- echo 'let exe = ""'; \
- echo 'let version = "0.14.1"'; \
- ) > src/ocamlbuild_config.ml
Processing 25/160: [base64: dune subst] [jane-street-headers: jbuilder build] [ocaml-compiler-libs: jbuilder build] [ocamlbuild: make check-if-preinstalled] [octavius: dune build] [ppx_derivers: dune build] [ppx_traverse_builtins: jbuilder build] [result: dune build] [seq: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [stdlib-shims: dune build] [stringext: dune build]
+ /home/opam/.opam/4.05/bin/dune "build" "-p" "octavius" "-j" "31" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/octavius.1.2.2)
-> compiled  octavius.1.2.2
Processing 25/160: [base64: dune subst] [jane-street-headers: jbuilder build] [ocaml-compiler-libs: jbuilder build] [ocamlbuild: make check-if-preinstalled] [ppx_derivers: dune build] [ppx_traverse_builtins: jbuilder build] [result: dune build] [seq: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [stdlib-shims: dune build] [stringext: dune build]
-> installed octavius.1.2.2
Processing 26/160: [base64: dune subst] [jane-street-headers: jbuilder build] [ocaml-compiler-libs: jbuilder build] [ocamlbuild: make check-if-preinstalled] [ppx_derivers: dune build] [ppx_traverse_builtins: jbuilder build] [result: dune build] [seq: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [stdlib-shims: dune build] [stringext: dune build]
+ /home/opam/.opam/4.05/bin/dune "build" "-p" "ppx_derivers" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_derivers.1.2.1)
-> compiled  ppx_derivers.1.2.1
Processing 26/160: [base64: dune subst] [jane-street-headers: jbuilder build] [ocaml-compiler-libs: jbuilder build] [ocamlbuild: make check-if-preinstalled] [ppx_traverse_builtins: jbuilder build] [result: dune build] [seq: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [stdlib-shims: dune build] [stringext: dune build]
-> installed ppx_derivers.1.2.1
Processing 27/160: [base64: dune subst] [jane-street-headers: jbuilder build] [ocaml-compiler-libs: jbuilder build] [ocamlbuild: make check-if-preinstalled] [ppx_traverse_builtins: jbuilder build] [result: dune build] [seq: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [stdlib-shims: dune build] [stringext: dune build]
+ /home/opam/.opam/4.05/bin/dune "build" "-p" "result" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/result.1.5)
-> compiled  result.1.5
Processing 27/160: [base64: dune subst] [jane-street-headers: jbuilder build] [ocaml-compiler-libs: jbuilder build] [ocamlbuild: make check-if-preinstalled] [ppx_traverse_builtins: jbuilder build] [seq: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [stdlib-shims: dune build] [stringext: dune build]
-> installed result.1.5
Processing 28/160: [base64: dune subst] [jane-street-headers: jbuilder build] [ocaml-compiler-libs: jbuilder build] [ocamlbuild: make check-if-preinstalled] [ppx_traverse_builtins: jbuilder build] [seq: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [stdlib-shims: dune build] [stringext: dune build]
Processing 29/160: [base64: dune subst] [jane-street-headers: jbuilder build] [ocaml-compiler-libs: jbuilder build] [ocaml-migrate-parsetree: dune build] [ocamlbuild: make check-if-preinstalled] [ppx_traverse_builtins: jbuilder build] [seq: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [stdlib-shims: dune build] [stringext: dune build]
+ /home/opam/.opam/4.05/bin/dune "build" "-p" "seq" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/seq.0.2.2)
-> compiled  seq.0.2.2
Processing 29/160: [base64: dune subst] [jane-street-headers: jbuilder build] [ocaml-compiler-libs: jbuilder build] [ocaml-migrate-parsetree: dune build] [ocamlbuild: make check-if-preinstalled] [ppx_traverse_builtins: jbuilder build] [sexplib: jbuilder build] [spawn: jbuilder build] [stdlib-shims: dune build] [stringext: dune build]
-> installed seq.0.2.2
Processing 30/160: [base64: dune subst] [jane-street-headers: jbuilder build] [ocaml-compiler-libs: jbuilder build] [ocaml-migrate-parsetree: dune build] [ocamlbuild: make check-if-preinstalled] [ppx_traverse_builtins: jbuilder build] [sexplib: jbuilder build] [spawn: jbuilder build] [stdlib-shims: dune build] [stringext: dune build]
Processing 31/160: [base64: dune subst] [jane-street-headers: jbuilder build] [ocaml-compiler-libs: jbuilder build] [ocaml-migrate-parsetree: dune build] [ocamlbuild: make check-if-preinstalled] [ppx_traverse_builtins: jbuilder build] [re: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [stdlib-shims: dune build] [stringext: dune build]
Processing 32/160: [base64: dune subst] [jane-street-headers: jbuilder build] [ocaml-compiler-libs: jbuilder build] [ocaml-migrate-parsetree: dune build] [ocamlbuild: make check-if-preinstalled] [ppx_traverse_builtins: jbuilder build] [re: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [stdlib-shims: dune build] [stringext: dune build] [yojson: dune build]
+ /home/opam/.opam/4.05/bin/dune "build" "-p" "stdlib-shims" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/stdlib-shims.0.3.0)
-> compiled  stdlib-shims.0.3.0
Processing 32/160: [base64: dune subst] [jane-street-headers: jbuilder build] [ocaml-compiler-libs: jbuilder build] [ocaml-migrate-parsetree: dune build] [ocamlbuild: make check-if-preinstalled] [ppx_traverse_builtins: jbuilder build] [re: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [stringext: dune build] [yojson: dune build]
-> installed stdlib-shims.0.3.0
Processing 33/160: [base64: dune subst] [jane-street-headers: jbuilder build] [ocaml-compiler-libs: jbuilder build] [ocaml-migrate-parsetree: dune build] [ocamlbuild: make check-if-preinstalled] [ppx_traverse_builtins: jbuilder build] [re: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [stringext: dune build] [yojson: dune build]
+ /home/opam/.opam/4.05/bin/dune "build" "-p" "stringext" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/stringext.1.6.0)
-> compiled  stringext.1.6.0
Processing 33/160: [base64: dune subst] [jane-street-headers: jbuilder build] [ocaml-compiler-libs: jbuilder build] [ocaml-migrate-parsetree: dune build] [ocamlbuild: make check-if-preinstalled] [ppx_traverse_builtins: jbuilder build] [re: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [yojson: dune build]
-> installed stringext.1.6.0
Processing 34/160: [base64: dune subst] [jane-street-headers: jbuilder build] [ocaml-compiler-libs: jbuilder build] [ocaml-migrate-parsetree: dune build] [ocamlbuild: make check-if-preinstalled] [ppx_traverse_builtins: jbuilder build] [re: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [yojson: dune build]
+ /home/opam/.opam/4.05/bin/dune "subst" (CWD=/home/opam/.opam/4.05/.opam-switch/build/base64.2.3.0)
Processing 34/160: [base64: dune build] [jane-street-headers: jbuilder build] [ocaml-compiler-libs: jbuilder build] [ocaml-migrate-parsetree: dune build] [ocamlbuild: make check-if-preinstalled] [ppx_traverse_builtins: jbuilder build] [re: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [yojson: dune build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "-p" "jane-street-headers" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/jane-street-headers.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "include/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "include/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  jane-street-headers.v0.9.0
Processing 34/160: [base64: dune build] [ocaml-compiler-libs: jbuilder build] [ocaml-migrate-parsetree: dune build] [ocamlbuild: make check-if-preinstalled] [ppx_traverse_builtins: jbuilder build] [re: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [yojson: dune build]
-> installed jane-street-headers.v0.9.0
Processing 35/160: [base64: dune build] [ocaml-compiler-libs: jbuilder build] [ocaml-migrate-parsetree: dune build] [ocamlbuild: make check-if-preinstalled] [ppx_traverse_builtins: jbuilder build] [re: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [yojson: dune build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ocaml-compiler-libs" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ocaml-compiler-libs.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "src/gen/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/ocaml_bytecomp/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/ocaml_common/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/ocaml_toplevel/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/read_cma/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/shadow/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/shadow/gen/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/shadow/gen/gen.ml", line 19, characters 30-47:
- Warning 3: deprecated: StdLabels.String.capitalize
- Use String.capitalize_ascii instead.
- File "src/shadow/gen/gen.ml", line 29, characters 10-27:
- Warning 3: deprecated: StdLabels.String.capitalize
- Use String.capitalize_ascii instead.
- File "src/shadow/gen/gen.ml", line 19, characters 30-47:
- Warning 3: deprecated: StdLabels.String.capitalize
- Use String.capitalize_ascii instead.
- File "src/shadow/gen/gen.ml", line 29, characters 10-27:
- Warning 3: deprecated: StdLabels.String.capitalize
- Use String.capitalize_ascii instead.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "src/gen/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/ocaml_bytecomp/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/ocaml_common/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/ocaml_toplevel/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/read_cma/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/shadow/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/shadow/gen/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/shadow/gen/gen.ml", line 19, characters 30-47:
- Warning 3: deprecated: StdLabels.String.capitalize
- Use String.capitalize_ascii instead.
- File "src/shadow/gen/gen.ml", line 29, characters 10-27:
- Warning 3: deprecated: StdLabels.String.capitalize
- Use String.capitalize_ascii instead.
- File "src/shadow/gen/gen.ml", line 19, characters 30-47:
- Warning 3: deprecated: StdLabels.String.capitalize
- Use String.capitalize_ascii instead.
- File "src/shadow/gen/gen.ml", line 29, characters 10-27:
- Warning 3: deprecated: StdLabels.String.capitalize
- Use String.capitalize_ascii instead.
-> compiled  ocaml-compiler-libs.v0.9.0
Processing 35/160: [base64: dune build] [ocaml-migrate-parsetree: dune build] [ocamlbuild: make check-if-preinstalled] [ppx_traverse_builtins: jbuilder build] [re: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [yojson: dune build]
-> installed ocaml-compiler-libs.v0.9.0
Processing 36/160: [base64: dune build] [ocaml-migrate-parsetree: dune build] [ocamlbuild: make check-if-preinstalled] [ppx_traverse_builtins: jbuilder build] [re: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [yojson: dune build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_traverse_builtins" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_traverse_builtins.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_traverse_builtins.v0.9.0
Processing 36/160: [base64: dune build] [ocaml-migrate-parsetree: dune build] [ocamlbuild: make check-if-preinstalled] [re: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [yojson: dune build]
-> installed ppx_traverse_builtins.v0.9.0
Processing 37/160: [base64: dune build] [ocaml-migrate-parsetree: dune build] [ocamlbuild: make check-if-preinstalled] [re: dune build] [sexplib: jbuilder build] [spawn: jbuilder build] [yojson: dune build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "-p" "spawn" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/spawn.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "bench/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "bench/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  spawn.v0.9.0
Processing 37/160: [base64: dune build] [ocaml-migrate-parsetree: dune build] [ocamlbuild: make check-if-preinstalled] [re: dune build] [sexplib: jbuilder build] [yojson: dune build]
-> installed spawn.v0.9.0
Processing 38/160: [base64: dune build] [ocaml-migrate-parsetree: dune build] [ocamlbuild: make check-if-preinstalled] [re: dune build] [sexplib: jbuilder build] [yojson: dune build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "-p" "sexplib" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/sexplib.v0.9.3)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "num/lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src0/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "unix/lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-       ocamlc src/.sexplib.objs/byte/sexplib__Pre_sexp.{cmi,cmo,cmt}
- File "src/pre_sexp.ml", line 1082, characters 44-57:
- Warning 3: deprecated: String.create
- Use Bytes.create instead.
- File "src/pre_sexp.ml", line 1096, characters 28-41:
- Warning 3: deprecated: String.create
- Use Bytes.create instead.
- File "src/pre_sexp.ml", line 1108, characters 32-45:
- Warning 3: deprecated: String.create
- Use Bytes.create instead.
-     ocamlopt src/.sexplib.objs/native/sexplib__Pre_sexp.{cmx,o}
- File "src/pre_sexp.ml", line 1082, characters 44-57:
- Warning 3: deprecated: String.create
- Use Bytes.create instead.
- File "src/pre_sexp.ml", line 1096, characters 28-41:
- Warning 3: deprecated: String.create
- Use Bytes.create instead.
- File "src/pre_sexp.ml", line 1108, characters 32-45:
- Warning 3: deprecated: String.create
- Use Bytes.create instead.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "num/lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src0/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "unix/lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-       ocamlc src/.sexplib.objs/byte/sexplib__Pre_sexp.{cmi,cmo,cmt}
- File "src/pre_sexp.ml", line 1082, characters 44-57:
- Warning 3: deprecated: String.create
- Use Bytes.create instead.
- File "src/pre_sexp.ml", line 1096, characters 28-41:
- Warning 3: deprecated: String.create
- Use Bytes.create instead.
- File "src/pre_sexp.ml", line 1108, characters 32-45:
- Warning 3: deprecated: String.create
- Use Bytes.create instead.
-     ocamlopt src/.sexplib.objs/native/sexplib__Pre_sexp.{cmx,o}
- File "src/pre_sexp.ml", line 1082, characters 44-57:
- Warning 3: deprecated: String.create
- Use Bytes.create instead.
- File "src/pre_sexp.ml", line 1096, characters 28-41:
- Warning 3: deprecated: String.create
- Use Bytes.create instead.
- File "src/pre_sexp.ml", line 1108, characters 32-45:
- Warning 3: deprecated: String.create
- Use Bytes.create instead.
-> compiled  sexplib.v0.9.3
Processing 38/160: [base64: dune build] [ocaml-migrate-parsetree: dune build] [ocamlbuild: make check-if-preinstalled] [re: dune build] [yojson: dune build]
-> installed sexplib.v0.9.3
Processing 39/160: [base64: dune build] [ocaml-migrate-parsetree: dune build] [ocamlbuild: make check-if-preinstalled] [re: dune build] [yojson: dune build]
Processing 40/160: [base: jbuilder build] [base64: dune build] [ocaml-migrate-parsetree: dune build] [ocamlbuild: make check-if-preinstalled] [re: dune build] [yojson: dune build]
+ /usr/bin/make "check-if-preinstalled" "all" "opam-install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1)
- if test -d /home/opam/.opam/4.05/lib/ocaml/ocamlbuild; then\
-   >&2 echo "ERROR: Preinstalled ocamlbuild detected at"\
-        "/home/opam/.opam/4.05/lib/ocaml/ocamlbuild";\
-   >&2 echo "Installation aborted; if you want to bypass this"\
-         "safety check, pass CHECK_IF_PREINSTALLED=false to make";\
-   exit 2;\
- fi
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/const.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/loc.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/loc.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/discard_printf.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/discard_printf.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/signatures.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/my_std.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/my_std.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/my_unix.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/my_unix.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/tags.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/tags.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/display.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/display.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/log.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/log.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/shell.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/shell.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/bool.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/bool.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_ast.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_ast.ml
- ocamllex.opt src/glob_lexer.mll
- 55 states, 419 transitions, table size 2006 bytes
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_lexer.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_lexer.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob.ml
- ocamllex.opt src/lexers.mll
- 251 states, 1051 transitions, table size 5710 bytes
- 4334 additional bytes used for bindings
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/lexers.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/lexers.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/param_tags.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/param_tags.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/command.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/command.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_config.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_where.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_where.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/slurp.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/slurp.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/options.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/options.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/pathname.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/pathname.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/configuration.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/configuration.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/flags.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/flags.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/hygiene.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/hygiene.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/digest_cache.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/digest_cache.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/resource.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/resource.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/rule.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/rule.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/solver.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/solver.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/report.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/report.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/tools.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/tools.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/fda.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/fda.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/findlib.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/findlib.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_arch.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_arch.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_utils.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_utils.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_dependencies.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_dependencies.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_compiler.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_compiler.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_tools.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_tools.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_specific.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_specific.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/exit_codes.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/exit_codes.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/plugin.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/plugin.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/hooks.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/hooks.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/main.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/main.ml
- mkdir -p tmp
- ocamlc.opt -pack src/const.cmo src/loc.cmo src/discard_printf.cmo src/signatures.cmi src/my_std.cmo src/my_unix.cmo src/tags.cmo src/display.cmo src/log.cmo src/shell.cmo src/bool.cmo src/glob_ast.cmo src/glob_lexer.cmo src/glob.cmo src/lexers.cmo src/param_tags.cmo src/command.cmo src/ocamlbuild_config.cmo src/ocamlbuild_where.cmo src/slurp.cmo src/options.cmo src/pathname.cmo src/configuration.cmo src/flags.cmo src/hygiene.cmo src/digest_cache.cmo src/resource.cmo src/rule.cmo src/solver.cmo src/report.cmo src/tools.cmo src/fda.cmo src/findlib.cmo src/ocaml_arch.cmo src/ocaml_utils.cmo src/ocaml_dependencies.cmo src/ocaml_compiler.cmo src/ocaml_tools.cmo src/ocaml_specific.cmo src/exit_codes.cmo src/plugin.cmo src/hooks.cmo src/main.cmo -o tmp/ocamlbuild_pack.cmo
- mv tmp/ocamlbuild_pack.cmi src/ocamlbuild_pack.cmi
- mv tmp/ocamlbuild_pack.cmo src/ocamlbuild_pack.cmo
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_plugin.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_plugin.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_executor.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_executor.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_unix_plugin.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_unix_plugin.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild.ml
- ocamlc.opt -I +unix -I src -o ocamlbuild.byte unix.cma src/ocamlbuild_pack.cmo src/ocamlbuild_plugin.cmo src/ocamlbuild_executor.cmo src/ocamlbuild_unix_plugin.cmo src/ocamlbuild.cmo
- ocamlc.opt -a -o src/ocamlbuildlib.cma src/ocamlbuild_pack.cmo src/ocamlbuild_plugin.cmo src/ocamlbuild_executor.cmo src/ocamlbuild_unix_plugin.cmo
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/const.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/loc.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/discard_printf.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/my_std.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/my_unix.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/tags.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/display.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/log.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/shell.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/bool.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_ast.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_lexer.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/lexers.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/param_tags.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/command.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_config.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_where.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/slurp.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/options.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/pathname.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/configuration.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/flags.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/hygiene.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/digest_cache.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/resource.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/rule.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/solver.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/report.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/tools.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/fda.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/findlib.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_arch.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_utils.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_dependencies.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_compiler.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_tools.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_specific.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/exit_codes.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/plugin.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/hooks.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/main.ml
- mkdir -p tmp
- ocamlopt.opt -pack src/const.cmx src/loc.cmx src/discard_printf.cmx src/signatures.cmi src/my_std.cmx src/my_unix.cmx src/tags.cmx src/display.cmx src/log.cmx src/shell.cmx src/bool.cmx src/glob_ast.cmx src/glob_lexer.cmx src/glob.cmx src/lexers.cmx src/param_tags.cmx src/command.cmx src/ocamlbuild_config.cmx src/ocamlbuild_where.cmx src/slurp.cmx src/options.cmx src/pathname.cmx src/configuration.cmx src/flags.cmx src/hygiene.cmx src/digest_cache.cmx src/resource.cmx src/rule.cmx src/solver.cmx src/report.cmx src/tools.cmx src/fda.cmx src/findlib.cmx src/ocaml_arch.cmx src/ocaml_utils.cmx src/ocaml_dependencies.cmx src/ocaml_compiler.cmx src/ocaml_tools.cmx src/ocaml_specific.cmx src/exit_codes.cmx src/plugin.cmx src/hooks.cmx src/main.cmx -o tmp/ocamlbuild_pack.cmx
- mv tmp/ocamlbuild_pack.cmx src/ocamlbuild_pack.cmx
- mv tmp/ocamlbuild_pack.o src/ocamlbuild_pack.o
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_plugin.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_executor.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_unix_plugin.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild.ml
- ocamlopt.opt -I +unix -I src -o ocamlbuild.native unix.cmxa src/ocamlbuild_pack.cmx src/ocamlbuild_plugin.cmx src/ocamlbuild_executor.cmx src/ocamlbuild_unix_plugin.cmx src/ocamlbuild.cmx
- ocamlopt.opt -a -o src/ocamlbuildlib.cmxa src/ocamlbuild_pack.cmx src/ocamlbuild_plugin.cmx src/ocamlbuild_executor.cmx src/ocamlbuild_unix_plugin.cmx
- ocamlc.opt src/ocamlbuild_pack.cmo -I src man/options_man.ml -o man/options_man.byte
- ./man/options_man.byte > man/ocamlbuild.options.1
- cat man/ocamlbuild.header.1 man/ocamlbuild.options.1 man/ocamlbuild.footer.1 > man/ocamlbuild.1
- /usr/bin/make ocamlbuild.install
- make[1]: Entering directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- rm -f ocamlbuild.install
- touch ocamlbuild.install
- /usr/bin/make install-bin-opam
- make[2]: Entering directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- echo 'bin: [' >> ocamlbuild.install
- echo '  "ocamlbuild.byte" {"ocamlbuild.byte"}' >> ocamlbuild.install
- echo '  "ocamlbuild.native" {"ocamlbuild.native"}' >> ocamlbuild.install
- echo '  "ocamlbuild.native" {"ocamlbuild"}' >> ocamlbuild.install
- echo ']' >> ocamlbuild.install
- echo >> ocamlbuild.install
- make[2]: Leaving directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- /usr/bin/make install-lib-opam
- make[2]: Entering directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- echo 'lib: [' >> ocamlbuild.install
- /usr/bin/make install-lib-basics-opam
- make[3]: Entering directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- echo '  "ocamlbuild.opam" {"opam"}' >> ocamlbuild.install
- echo '  "META"' >> ocamlbuild.install
- for lib in src/signatures.mli src/signatures.cmi src/signatures.cmti; do \
-   echo "  \"$lib\" {\"$(basename $lib)\"}" >> ocamlbuild.install; \
- done
- make[3]: Leaving directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- /usr/bin/make install-lib-byte-opam
- make[3]: Entering directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- for lib in src/ocamlbuildlib.cma src/ocamlbuild.cmo src/ocamlbuild_pack.cmi src/ocamlbuild_plugin.cmi src/ocamlbuild_executor.cmi src/ocamlbuild_unix_plugin.cmi; do \
-   echo "  \"$lib\" {\"$(basename $lib)\"}" >> ocamlbuild.install; \
- done
- make[3]: Leaving directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- /usr/bin/make install-lib-native-opam
- make[3]: Entering directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- for lib in src/ocamlbuildlib.cmxa src/ocamlbuildlib.a src/ocamlbuild.cmx src/ocamlbuild.o src/ocamlbuild_pack.cmx src/ocamlbuild_plugin.cmx src/ocamlbuild_executor.cmx src/ocamlbuild_unix_plugin.cmx src/ocamlbuild_plugin.o src/ocamlbuild_executor.o src/ocamlbuild_unix_plugin.o; do \
-   echo "  \"$lib\" {\"$(basename $lib)\"}" >> ocamlbuild.install; \
- done
- make[3]: Leaving directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- echo ']' >> ocamlbuild.install
- echo >> ocamlbuild.install
- make[2]: Leaving directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- /usr/bin/make install-man-opam
- make[2]: Entering directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- echo 'man: [' >> ocamlbuild.install
- echo '  "man/ocamlbuild.1" {"man1/ocamlbuild.1"}' >> ocamlbuild.install
- echo ']' >> ocamlbuild.install
- echo >> ocamlbuild.install
- make[2]: Leaving directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- /usr/bin/make install-doc-opam
- make[2]: Entering directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- echo 'doc: [' >> ocamlbuild.install
- echo '  "LICENSE"' >> ocamlbuild.install
- echo '  "Changes"' >> ocamlbuild.install
- echo '  "Readme.md"' >> ocamlbuild.install
- echo ']' >> ocamlbuild.install
- make[2]: Leaving directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- make[1]: Leaving directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- if test -d /home/opam/.opam/4.05/lib/ocaml/ocamlbuild; then\
-   >&2 echo "ERROR: Preinstalled ocamlbuild detected at"\
-        "/home/opam/.opam/4.05/lib/ocaml/ocamlbuild";\
-   >&2 echo "Installation aborted; if you want to bypass this"\
-         "safety check, pass CHECK_IF_PREINSTALLED=false to make";\
-   exit 2;\
- fi
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/const.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/loc.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/loc.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/discard_printf.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/discard_printf.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/signatures.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/my_std.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/my_std.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/my_unix.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/my_unix.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/tags.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/tags.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/display.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/display.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/log.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/log.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/shell.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/shell.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/bool.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/bool.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_ast.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_ast.ml
- ocamllex.opt src/glob_lexer.mll
- 55 states, 419 transitions, table size 2006 bytes
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_lexer.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_lexer.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob.ml
- ocamllex.opt src/lexers.mll
- 251 states, 1051 transitions, table size 5710 bytes
- 4334 additional bytes used for bindings
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/lexers.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/lexers.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/param_tags.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/param_tags.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/command.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/command.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_config.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_where.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_where.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/slurp.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/slurp.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/options.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/options.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/pathname.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/pathname.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/configuration.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/configuration.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/flags.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/flags.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/hygiene.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/hygiene.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/digest_cache.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/digest_cache.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/resource.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/resource.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/rule.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/rule.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/solver.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/solver.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/report.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/report.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/tools.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/tools.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/fda.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/fda.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/findlib.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/findlib.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_arch.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_arch.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_utils.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_utils.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_dependencies.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_dependencies.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_compiler.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_compiler.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_tools.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_tools.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_specific.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_specific.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/exit_codes.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/exit_codes.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/plugin.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/plugin.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/hooks.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/hooks.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/main.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/main.ml
- mkdir -p tmp
- ocamlc.opt -pack src/const.cmo src/loc.cmo src/discard_printf.cmo src/signatures.cmi src/my_std.cmo src/my_unix.cmo src/tags.cmo src/display.cmo src/log.cmo src/shell.cmo src/bool.cmo src/glob_ast.cmo src/glob_lexer.cmo src/glob.cmo src/lexers.cmo src/param_tags.cmo src/command.cmo src/ocamlbuild_config.cmo src/ocamlbuild_where.cmo src/slurp.cmo src/options.cmo src/pathname.cmo src/configuration.cmo src/flags.cmo src/hygiene.cmo src/digest_cache.cmo src/resource.cmo src/rule.cmo src/solver.cmo src/report.cmo src/tools.cmo src/fda.cmo src/findlib.cmo src/ocaml_arch.cmo src/ocaml_utils.cmo src/ocaml_dependencies.cmo src/ocaml_compiler.cmo src/ocaml_tools.cmo src/ocaml_specific.cmo src/exit_codes.cmo src/plugin.cmo src/hooks.cmo src/main.cmo -o tmp/ocamlbuild_pack.cmo
- mv tmp/ocamlbuild_pack.cmi src/ocamlbuild_pack.cmi
- mv tmp/ocamlbuild_pack.cmo src/ocamlbuild_pack.cmo
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_plugin.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_plugin.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_executor.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_executor.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_unix_plugin.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_unix_plugin.ml
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild.mli
- ocamlc.opt -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild.ml
- ocamlc.opt -I +unix -I src -o ocamlbuild.byte unix.cma src/ocamlbuild_pack.cmo src/ocamlbuild_plugin.cmo src/ocamlbuild_executor.cmo src/ocamlbuild_unix_plugin.cmo src/ocamlbuild.cmo
- ocamlc.opt -a -o src/ocamlbuildlib.cma src/ocamlbuild_pack.cmo src/ocamlbuild_plugin.cmo src/ocamlbuild_executor.cmo src/ocamlbuild_unix_plugin.cmo
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/const.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/loc.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/discard_printf.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/my_std.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/my_unix.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/tags.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/display.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/log.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/shell.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/bool.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_ast.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_lexer.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/lexers.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/param_tags.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/command.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_config.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_where.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/slurp.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/options.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/pathname.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/configuration.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/flags.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/hygiene.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/digest_cache.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/resource.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/rule.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/solver.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/report.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/tools.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/fda.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/findlib.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_arch.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_utils.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_dependencies.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_compiler.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_tools.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_specific.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/exit_codes.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/plugin.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/hooks.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/main.ml
- mkdir -p tmp
- ocamlopt.opt -pack src/const.cmx src/loc.cmx src/discard_printf.cmx src/signatures.cmi src/my_std.cmx src/my_unix.cmx src/tags.cmx src/display.cmx src/log.cmx src/shell.cmx src/bool.cmx src/glob_ast.cmx src/glob_lexer.cmx src/glob.cmx src/lexers.cmx src/param_tags.cmx src/command.cmx src/ocamlbuild_config.cmx src/ocamlbuild_where.cmx src/slurp.cmx src/options.cmx src/pathname.cmx src/configuration.cmx src/flags.cmx src/hygiene.cmx src/digest_cache.cmx src/resource.cmx src/rule.cmx src/solver.cmx src/report.cmx src/tools.cmx src/fda.cmx src/findlib.cmx src/ocaml_arch.cmx src/ocaml_utils.cmx src/ocaml_dependencies.cmx src/ocaml_compiler.cmx src/ocaml_tools.cmx src/ocaml_specific.cmx src/exit_codes.cmx src/plugin.cmx src/hooks.cmx src/main.cmx -o tmp/ocamlbuild_pack.cmx
- mv tmp/ocamlbuild_pack.cmx src/ocamlbuild_pack.cmx
- mv tmp/ocamlbuild_pack.o src/ocamlbuild_pack.o
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_plugin.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_executor.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_unix_plugin.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w +L -w +R -w +Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild.ml
- ocamlopt.opt -I +unix -I src -o ocamlbuild.native unix.cmxa src/ocamlbuild_pack.cmx src/ocamlbuild_plugin.cmx src/ocamlbuild_executor.cmx src/ocamlbuild_unix_plugin.cmx src/ocamlbuild.cmx
- ocamlopt.opt -a -o src/ocamlbuildlib.cmxa src/ocamlbuild_pack.cmx src/ocamlbuild_plugin.cmx src/ocamlbuild_executor.cmx src/ocamlbuild_unix_plugin.cmx
- ocamlc.opt src/ocamlbuild_pack.cmo -I src man/options_man.ml -o man/options_man.byte
- ./man/options_man.byte > man/ocamlbuild.options.1
- cat man/ocamlbuild.header.1 man/ocamlbuild.options.1 man/ocamlbuild.footer.1 > man/ocamlbuild.1
- /usr/bin/make ocamlbuild.install
- make[1]: Entering directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- rm -f ocamlbuild.install
- touch ocamlbuild.install
- /usr/bin/make install-bin-opam
- make[2]: Entering directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- echo 'bin: [' >> ocamlbuild.install
- echo '  "ocamlbuild.byte" {"ocamlbuild.byte"}' >> ocamlbuild.install
- echo '  "ocamlbuild.native" {"ocamlbuild.native"}' >> ocamlbuild.install
- echo '  "ocamlbuild.native" {"ocamlbuild"}' >> ocamlbuild.install
- echo ']' >> ocamlbuild.install
- echo >> ocamlbuild.install
- make[2]: Leaving directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- /usr/bin/make install-lib-opam
- make[2]: Entering directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- echo 'lib: [' >> ocamlbuild.install
- /usr/bin/make install-lib-basics-opam
- make[3]: Entering directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- echo '  "ocamlbuild.opam" {"opam"}' >> ocamlbuild.install
- echo '  "META"' >> ocamlbuild.install
- for lib in src/signatures.mli src/signatures.cmi src/signatures.cmti; do \
-   echo "  \"$lib\" {\"$(basename $lib)\"}" >> ocamlbuild.install; \
- done
- make[3]: Leaving directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- /usr/bin/make install-lib-byte-opam
- make[3]: Entering directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- for lib in src/ocamlbuildlib.cma src/ocamlbuild.cmo src/ocamlbuild_pack.cmi src/ocamlbuild_plugin.cmi src/ocamlbuild_executor.cmi src/ocamlbuild_unix_plugin.cmi; do \
-   echo "  \"$lib\" {\"$(basename $lib)\"}" >> ocamlbuild.install; \
- done
- make[3]: Leaving directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- /usr/bin/make install-lib-native-opam
- make[3]: Entering directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- for lib in src/ocamlbuildlib.cmxa src/ocamlbuildlib.a src/ocamlbuild.cmx src/ocamlbuild.o src/ocamlbuild_pack.cmx src/ocamlbuild_plugin.cmx src/ocamlbuild_executor.cmx src/ocamlbuild_unix_plugin.cmx src/ocamlbuild_plugin.o src/ocamlbuild_executor.o src/ocamlbuild_unix_plugin.o; do \
-   echo "  \"$lib\" {\"$(basename $lib)\"}" >> ocamlbuild.install; \
- done
- make[3]: Leaving directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- echo ']' >> ocamlbuild.install
- echo >> ocamlbuild.install
- make[2]: Leaving directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- /usr/bin/make install-man-opam
- make[2]: Entering directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- echo 'man: [' >> ocamlbuild.install
- echo '  "man/ocamlbuild.1" {"man1/ocamlbuild.1"}' >> ocamlbuild.install
- echo ']' >> ocamlbuild.install
- echo >> ocamlbuild.install
- make[2]: Leaving directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- /usr/bin/make install-doc-opam
- make[2]: Entering directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- echo 'doc: [' >> ocamlbuild.install
- echo '  "LICENSE"' >> ocamlbuild.install
- echo '  "Changes"' >> ocamlbuild.install
- echo '  "Readme.md"' >> ocamlbuild.install
- echo ']' >> ocamlbuild.install
- make[2]: Leaving directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
- make[1]: Leaving directory '/home/opam/.opam/4.05/.opam-switch/build/ocamlbuild.0.14.1'
-> compiled  ocamlbuild.0.14.1
Processing 40/160: [base: jbuilder build] [base64: dune build] [ocaml-migrate-parsetree: dune build] [re: dune build] [yojson: dune build]
-> installed ocamlbuild.0.14.1
Processing 41/160: [base: jbuilder build] [base64: dune build] [ocaml-migrate-parsetree: dune build] [re: dune build] [yojson: dune build]
Processing 42/160: [base: jbuilder build] [base64: dune build] [ocaml-migrate-parsetree: dune build] [re: dune build] [topkg: ocaml build] [yojson: dune build]
Processing 43/160: [base: jbuilder build] [base64: dune build] [ocaml-migrate-parsetree: dune build] [re: dune build] [topkg: ocaml build] [uchar: ocaml] [yojson: dune build]
+ /home/opam/.opam/4.05/bin/dune "build" "-p" "ocaml-migrate-parsetree" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ocaml-migrate-parsetree.1.8.0)
-> compiled  ocaml-migrate-parsetree.1.8.0
Processing 43/160: [base: jbuilder build] [base64: dune build] [re: dune build] [topkg: ocaml build] [uchar: ocaml] [yojson: dune build]
-> installed ocaml-migrate-parsetree.1.8.0
Processing 44/160: [base: jbuilder build] [base64: dune build] [re: dune build] [topkg: ocaml build] [uchar: ocaml] [yojson: dune build]
Processing 45/160: [base: jbuilder build] [base64: dune build] [ppx_ast: jbuilder build] [re: dune build] [topkg: ocaml build] [uchar: ocaml] [yojson: dune build]
+ /home/opam/.opam/4.05/bin/dune "build" "-p" "re" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/re.1.9.0)
-> compiled  re.1.9.0
Processing 45/160: [base: jbuilder build] [base64: dune build] [ppx_ast: jbuilder build] [topkg: ocaml build] [uchar: ocaml] [yojson: dune build]
-> installed re.1.9.0
Processing 46/160: [base: jbuilder build] [base64: dune build] [ppx_ast: jbuilder build] [topkg: ocaml build] [uchar: ocaml] [yojson: dune build]
+ /home/opam/.opam/4.05/bin/dune "build" "-p" "yojson" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/yojson.2.0.0)
-> compiled  yojson.2.0.0
Processing 46/160: [base: jbuilder build] [base64: dune build] [ppx_ast: jbuilder build] [topkg: ocaml build] [uchar: ocaml]
-> installed yojson.2.0.0
Processing 47/160: [base: jbuilder build] [base64: dune build] [ppx_ast: jbuilder build] [topkg: ocaml build] [uchar: ocaml]
+ /home/opam/.opam/4.05/bin/dune "build" "-p" "base64" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/base64.2.3.0)
-> compiled  base64.2.3.0
Processing 47/160: [base: jbuilder build] [ppx_ast: jbuilder build] [topkg: ocaml build] [uchar: ocaml]
-> installed base64.2.3.0
Processing 48/160: [base: jbuilder build] [ppx_ast: jbuilder build] [topkg: ocaml build] [uchar: ocaml]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "-p" "base" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/base.v0.9.4)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "compiler-stdlib/gen/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "compiler-stdlib/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "generate/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "lint/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "shadow-stdlib/gen/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "shadow-stdlib/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 18, characters 0-142:
- 18 | (rule
- 19 |  ((targets (pow_overflow_bounds.ml))
- 20 |   (deps    (../generate/generate_pow_overflow_bounds.exe))
- 21 |   (action  (run ${<} -atomic -o ${@}))))
- Warning: The following files are both generated by a rule and are present in
- the source tree:
- - src/pow_overflow_bounds.ml
- Because you are using the jbuilder binary, I am closing my eyes on this and I
- am acting as if the rule didn't exist. However, you should really delete
- these files from your source tree. I will no longer accept this once you
- upgrade your project to dune >= 1.10.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "compiler-stdlib/gen/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "compiler-stdlib/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "generate/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "lint/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "shadow-stdlib/gen/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "shadow-stdlib/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 18, characters 0-142:
- 18 | (rule
- 19 |  ((targets (pow_overflow_bounds.ml))
- 20 |   (deps    (../generate/generate_pow_overflow_bounds.exe))
- 21 |   (action  (run ${<} -atomic -o ${@}))))
- Warning: The following files are both generated by a rule and are present in
- the source tree:
- - src/pow_overflow_bounds.ml
- Because you are using the jbuilder binary, I am closing my eyes on this and I
- am acting as if the rule didn't exist. However, you should really delete
- these files from your source tree. I will no longer accept this once you
- upgrade your project to dune >= 1.10.
-> compiled  base.v0.9.4
Processing 48/160: [ppx_ast: jbuilder build] [topkg: ocaml build] [uchar: ocaml]
-> installed base.v0.9.4
Processing 49/160: [ppx_ast: jbuilder build] [topkg: ocaml build] [uchar: ocaml]
Processing 50/160: [ppx_ast: jbuilder build] [stdio: jbuilder build] [topkg: ocaml build] [uchar: ocaml]
Processing 51/160: [ppx_ast: jbuilder build] [stdio: jbuilder build] [topkg: ocaml build] [typerep: jbuilder build] [uchar: ocaml]
+ /home/opam/.opam/4.05/bin/ocaml "pkg/pkg.ml" "build" "--pkg-name" "topkg" "--dev-pkg" "false" (CWD=/home/opam/.opam/4.05/.opam-switch/build/topkg.1.0.5)
- ocamlfind ocamldep -modules src/topkg.ml > src/topkg.ml.depends
- ocamlfind ocamldep -modules src/topkg.mli > src/topkg.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg.cmi src/topkg.mli
- ocamlfind ocamldep -modules src/topkg_build.ml > src/topkg_build.ml.depends
- ocamlfind ocamldep -modules src/topkg_build.mli > src/topkg_build.mli.depends
- ocamlfind ocamldep -modules src/topkg_cmd.mli > src/topkg_cmd.mli.depends
- ocamlfind ocamldep -modules src/topkg_fpath.mli > src/topkg_fpath.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_fpath.cmi src/topkg_fpath.mli
- ocamlfind ocamldep -modules src/topkg_codec.mli > src/topkg_codec.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_cmd.cmi src/topkg_cmd.mli
- ocamlfind ocamldep -modules src/topkg_result.mli > src/topkg_result.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_result.cmi src/topkg_result.mli
- ocamlfind ocamldep -modules src/topkg_conf.mli > src/topkg_conf.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_codec.cmi src/topkg_codec.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_conf.cmi src/topkg_conf.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_build.cmi src/topkg_build.mli
- ocamlfind ocamldep -modules src/topkg_cmd.ml > src/topkg_cmd.ml.depends
- ocamlfind ocamldep -modules src/topkg_fpath.ml > src/topkg_fpath.ml.depends
- ocamlfind ocamldep -modules src/topkg_string.ml > src/topkg_string.ml.depends
- ocamlfind ocamldep -modules src/topkg_string.mli > src/topkg_string.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_string.cmi src/topkg_string.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_string.cmx src/topkg_string.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_fpath.cmx src/topkg_fpath.ml
- ocamlfind ocamldep -modules src/topkg_codec.ml > src/topkg_codec.ml.depends
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_cmd.cmx src/topkg_cmd.ml
- ocamlfind ocamldep -modules src/topkg_os.ml > src/topkg_os.ml.depends
- ocamlfind ocamldep -modules src/topkg_os.mli > src/topkg_os.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_os.cmi src/topkg_os.mli
- ocamlfind ocamldep -modules src/topkg_log.ml > src/topkg_log.ml.depends
- ocamlfind ocamldep -modules src/topkg_log.mli > src/topkg_log.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_log.cmi src/topkg_log.mli
- ocamlfind ocamldep -modules src/topkg_result.ml > src/topkg_result.ml.depends
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_result.cmx src/topkg_result.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_log.cmx src/topkg_log.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_os.cmx src/topkg_os.ml
- ocamlfind ocamldep -modules src/topkg_conf.ml > src/topkg_conf.ml.depends
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_codec.cmx src/topkg_codec.ml
- ocamlfind ocamldep -modules src/topkg_vcs.ml > src/topkg_vcs.ml.depends
- ocamlfind ocamldep -modules src/topkg_vcs.mli > src/topkg_vcs.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_vcs.cmi src/topkg_vcs.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_vcs.cmx src/topkg_vcs.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_conf.cmx src/topkg_conf.ml
- ocamlfind ocamldep -modules src/topkg_distrib.ml > src/topkg_distrib.ml.depends
- ocamlfind ocamldep -modules src/topkg_distrib.mli > src/topkg_distrib.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_distrib.cmi src/topkg_distrib.mli
- ocamlfind ocamldep -modules src/topkg_opam.ml > src/topkg_opam.ml.depends
- ocamlfind ocamldep -modules src/topkg_opam.mli > src/topkg_opam.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_opam.cmi src/topkg_opam.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_opam.cmx src/topkg_opam.ml
- ocamlfind ocamldep -modules src/topkg_fexts.ml > src/topkg_fexts.ml.depends
- ocamlfind ocamldep -modules src/topkg_fexts.mli > src/topkg_fexts.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_fexts.cmi src/topkg_fexts.mli
- ocamlfind ocamldep -modules src/topkg_install.ml > src/topkg_install.ml.depends
- ocamlfind ocamldep -modules src/topkg_install.mli > src/topkg_install.mli.depends
- ocamlfind ocamldep -modules src/topkg_test.mli > src/topkg_test.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_test.cmi src/topkg_test.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_install.cmi src/topkg_install.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_fexts.cmx src/topkg_fexts.ml
- ocamlfind ocamldep -modules src/topkg_test.ml > src/topkg_test.ml.depends
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_test.cmx src/topkg_test.ml
- ocamlfind ocamldep -modules src/topkg_ipc.ml > src/topkg_ipc.ml.depends
- ocamlfind ocamldep -modules src/topkg_ipc.mli > src/topkg_ipc.mli.depends
- ocamlfind ocamldep -modules src/topkg_pkg.mli > src/topkg_pkg.mli.depends
- ocamlfind ocamldep -modules src/topkg_publish.mli > src/topkg_publish.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_publish.cmi src/topkg_publish.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_pkg.cmi src/topkg_pkg.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_ipc.cmi src/topkg_ipc.mli
- ocamlfind ocamldep -modules src/topkg_pkg.ml > src/topkg_pkg.ml.depends
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_build.cmx src/topkg_build.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_distrib.cmx src/topkg_distrib.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_install.cmx src/topkg_install.ml
- ocamlfind ocamldep -modules src/topkg_publish.ml > src/topkg_publish.ml.depends
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_publish.cmx src/topkg_publish.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_pkg.cmx src/topkg_pkg.ml
- ocamlfind ocamldep -modules src/topkg_main.ml > src/topkg_main.ml.depends
- ocamlfind ocamldep -modules src/topkg_main.mli > src/topkg_main.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_main.cmi src/topkg_main.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_ipc.cmx src/topkg_ipc.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_main.cmx src/topkg_main.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg.cmx src/topkg.ml
- ocamlfind ocamlopt -a -I src src/topkg_string.cmx src/topkg_fpath.cmx src/topkg_cmd.cmx src/topkg_result.cmx src/topkg_log.cmx src/topkg_os.cmx src/topkg_codec.cmx src/topkg_vcs.cmx src/topkg_conf.cmx src/topkg_build.cmx src/topkg_opam.cmx src/topkg_distrib.cmx src/topkg_fexts.cmx src/topkg_test.cmx src/topkg_install.cmx src/topkg_publish.cmx src/topkg_pkg.cmx src/topkg_ipc.cmx src/topkg_main.cmx src/topkg.cmx -o src/topkg.cmxa
- ocamlfind ocamlopt -shared -linkall -I src src/topkg.cmxa -o src/topkg.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg.cmo src/topkg.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_build.cmo src/topkg_build.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_cmd.cmo src/topkg_cmd.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_codec.cmo src/topkg_codec.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_conf.cmo src/topkg_conf.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_distrib.cmo src/topkg_distrib.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_fexts.cmo src/topkg_fexts.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_fpath.cmo src/topkg_fpath.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_install.cmo src/topkg_install.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_ipc.cmo src/topkg_ipc.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_log.cmo src/topkg_log.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_main.cmo src/topkg_main.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_opam.cmo src/topkg_opam.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_os.cmo src/topkg_os.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_pkg.cmo src/topkg_pkg.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_publish.cmo src/topkg_publish.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_result.cmo src/topkg_result.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_string.cmo src/topkg_string.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_test.cmo src/topkg_test.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_vcs.cmo src/topkg_vcs.ml
- ocamlfind ocamlc -a -I src src/topkg_string.cmo src/topkg_fpath.cmo src/topkg_cmd.cmo src/topkg_result.cmo src/topkg_log.cmo src/topkg_os.cmo src/topkg_codec.cmo src/topkg_vcs.cmo src/topkg_conf.cmo src/topkg_build.cmo src/topkg_opam.cmo src/topkg_distrib.cmo src/topkg_fexts.cmo src/topkg_test.cmo src/topkg_install.cmo src/topkg_publish.cmo src/topkg_pkg.cmo src/topkg_ipc.cmo src/topkg_main.cmo src/topkg.cmo -o src/topkg.cma
- # Parallel statistics: { count(total): 2(84), max: 20, min: 2, average(total): 11.000(1.238) }
- ocamlfind ocamldep -modules src/topkg.ml > src/topkg.ml.depends
- ocamlfind ocamldep -modules src/topkg.mli > src/topkg.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg.cmi src/topkg.mli
- ocamlfind ocamldep -modules src/topkg_build.ml > src/topkg_build.ml.depends
- ocamlfind ocamldep -modules src/topkg_build.mli > src/topkg_build.mli.depends
- ocamlfind ocamldep -modules src/topkg_cmd.mli > src/topkg_cmd.mli.depends
- ocamlfind ocamldep -modules src/topkg_fpath.mli > src/topkg_fpath.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_fpath.cmi src/topkg_fpath.mli
- ocamlfind ocamldep -modules src/topkg_codec.mli > src/topkg_codec.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_cmd.cmi src/topkg_cmd.mli
- ocamlfind ocamldep -modules src/topkg_result.mli > src/topkg_result.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_result.cmi src/topkg_result.mli
- ocamlfind ocamldep -modules src/topkg_conf.mli > src/topkg_conf.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_codec.cmi src/topkg_codec.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_conf.cmi src/topkg_conf.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_build.cmi src/topkg_build.mli
- ocamlfind ocamldep -modules src/topkg_cmd.ml > src/topkg_cmd.ml.depends
- ocamlfind ocamldep -modules src/topkg_fpath.ml > src/topkg_fpath.ml.depends
- ocamlfind ocamldep -modules src/topkg_string.ml > src/topkg_string.ml.depends
- ocamlfind ocamldep -modules src/topkg_string.mli > src/topkg_string.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_string.cmi src/topkg_string.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_string.cmx src/topkg_string.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_fpath.cmx src/topkg_fpath.ml
- ocamlfind ocamldep -modules src/topkg_codec.ml > src/topkg_codec.ml.depends
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_cmd.cmx src/topkg_cmd.ml
- ocamlfind ocamldep -modules src/topkg_os.ml > src/topkg_os.ml.depends
- ocamlfind ocamldep -modules src/topkg_os.mli > src/topkg_os.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_os.cmi src/topkg_os.mli
- ocamlfind ocamldep -modules src/topkg_log.ml > src/topkg_log.ml.depends
- ocamlfind ocamldep -modules src/topkg_log.mli > src/topkg_log.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_log.cmi src/topkg_log.mli
- ocamlfind ocamldep -modules src/topkg_result.ml > src/topkg_result.ml.depends
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_result.cmx src/topkg_result.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_log.cmx src/topkg_log.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_os.cmx src/topkg_os.ml
- ocamlfind ocamldep -modules src/topkg_conf.ml > src/topkg_conf.ml.depends
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_codec.cmx src/topkg_codec.ml
- ocamlfind ocamldep -modules src/topkg_vcs.ml > src/topkg_vcs.ml.depends
- ocamlfind ocamldep -modules src/topkg_vcs.mli > src/topkg_vcs.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_vcs.cmi src/topkg_vcs.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_vcs.cmx src/topkg_vcs.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_conf.cmx src/topkg_conf.ml
- ocamlfind ocamldep -modules src/topkg_distrib.ml > src/topkg_distrib.ml.depends
- ocamlfind ocamldep -modules src/topkg_distrib.mli > src/topkg_distrib.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_distrib.cmi src/topkg_distrib.mli
- ocamlfind ocamldep -modules src/topkg_opam.ml > src/topkg_opam.ml.depends
- ocamlfind ocamldep -modules src/topkg_opam.mli > src/topkg_opam.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_opam.cmi src/topkg_opam.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_opam.cmx src/topkg_opam.ml
- ocamlfind ocamldep -modules src/topkg_fexts.ml > src/topkg_fexts.ml.depends
- ocamlfind ocamldep -modules src/topkg_fexts.mli > src/topkg_fexts.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_fexts.cmi src/topkg_fexts.mli
- ocamlfind ocamldep -modules src/topkg_install.ml > src/topkg_install.ml.depends
- ocamlfind ocamldep -modules src/topkg_install.mli > src/topkg_install.mli.depends
- ocamlfind ocamldep -modules src/topkg_test.mli > src/topkg_test.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_test.cmi src/topkg_test.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_install.cmi src/topkg_install.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_fexts.cmx src/topkg_fexts.ml
- ocamlfind ocamldep -modules src/topkg_test.ml > src/topkg_test.ml.depends
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_test.cmx src/topkg_test.ml
- ocamlfind ocamldep -modules src/topkg_ipc.ml > src/topkg_ipc.ml.depends
- ocamlfind ocamldep -modules src/topkg_ipc.mli > src/topkg_ipc.mli.depends
- ocamlfind ocamldep -modules src/topkg_pkg.mli > src/topkg_pkg.mli.depends
- ocamlfind ocamldep -modules src/topkg_publish.mli > src/topkg_publish.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_publish.cmi src/topkg_publish.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_pkg.cmi src/topkg_pkg.mli
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_ipc.cmi src/topkg_ipc.mli
- ocamlfind ocamldep -modules src/topkg_pkg.ml > src/topkg_pkg.ml.depends
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_build.cmx src/topkg_build.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_distrib.cmx src/topkg_distrib.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_install.cmx src/topkg_install.ml
- ocamlfind ocamldep -modules src/topkg_publish.ml > src/topkg_publish.ml.depends
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_publish.cmx src/topkg_publish.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_pkg.cmx src/topkg_pkg.ml
- ocamlfind ocamldep -modules src/topkg_main.ml > src/topkg_main.ml.depends
- ocamlfind ocamldep -modules src/topkg_main.mli > src/topkg_main.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_main.cmi src/topkg_main.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_ipc.cmx src/topkg_ipc.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_main.cmx src/topkg_main.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg.cmx src/topkg.ml
- ocamlfind ocamlopt -a -I src src/topkg_string.cmx src/topkg_fpath.cmx src/topkg_cmd.cmx src/topkg_result.cmx src/topkg_log.cmx src/topkg_os.cmx src/topkg_codec.cmx src/topkg_vcs.cmx src/topkg_conf.cmx src/topkg_build.cmx src/topkg_opam.cmx src/topkg_distrib.cmx src/topkg_fexts.cmx src/topkg_test.cmx src/topkg_install.cmx src/topkg_publish.cmx src/topkg_pkg.cmx src/topkg_ipc.cmx src/topkg_main.cmx src/topkg.cmx -o src/topkg.cmxa
- ocamlfind ocamlopt -shared -linkall -I src src/topkg.cmxa -o src/topkg.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg.cmo src/topkg.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_build.cmo src/topkg_build.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_cmd.cmo src/topkg_cmd.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_codec.cmo src/topkg_codec.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_conf.cmo src/topkg_conf.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_distrib.cmo src/topkg_distrib.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_fexts.cmo src/topkg_fexts.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_fpath.cmo src/topkg_fpath.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_install.cmo src/topkg_install.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_ipc.cmo src/topkg_ipc.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_log.cmo src/topkg_log.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_main.cmo src/topkg_main.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_opam.cmo src/topkg_opam.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_os.cmo src/topkg_os.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_pkg.cmo src/topkg_pkg.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_publish.cmo src/topkg_publish.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_result.cmo src/topkg_result.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_string.cmo src/topkg_string.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_test.cmo src/topkg_test.ml
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -I src-care -I src-bin -o src/topkg_vcs.cmo src/topkg_vcs.ml
- ocamlfind ocamlc -a -I src src/topkg_string.cmo src/topkg_fpath.cmo src/topkg_cmd.cmo src/topkg_result.cmo src/topkg_log.cmo src/topkg_os.cmo src/topkg_codec.cmo src/topkg_vcs.cmo src/topkg_conf.cmo src/topkg_build.cmo src/topkg_opam.cmo src/topkg_distrib.cmo src/topkg_fexts.cmo src/topkg_test.cmo src/topkg_install.cmo src/topkg_publish.cmo src/topkg_pkg.cmo src/topkg_ipc.cmo src/topkg_main.cmo src/topkg.cmo -o src/topkg.cma
- # Parallel statistics: { count(total): 2(84), max: 20, min: 2, average(total): 11.000(1.238) }
-> compiled  topkg.1.0.5
Processing 51/160: [ppx_ast: jbuilder build] [stdio: jbuilder build] [typerep: jbuilder build] [uchar: ocaml]
-> installed topkg.1.0.5
Processing 52/160: [ppx_ast: jbuilder build] [stdio: jbuilder build] [typerep: jbuilder build] [uchar: ocaml]
Processing 53/160: [astring: ocaml build] [ppx_ast: jbuilder build] [stdio: jbuilder build] [typerep: jbuilder build] [uchar: ocaml]
Processing 54/160: [astring: ocaml build] [fmt: ocaml build] [ppx_ast: jbuilder build] [stdio: jbuilder build] [typerep: jbuilder build] [uchar: ocaml]
Processing 55/160: [astring: ocaml build] [fmt: ocaml build] [ppx_ast: jbuilder build] [stdio: jbuilder build] [typerep: jbuilder build] [uchar: ocaml] [uutf: ocaml build]
+ /home/opam/.opam/4.05/bin/ocaml "pkg/git.ml" (CWD=/home/opam/.opam/4.05/.opam-switch/build/uchar.0.0.2)
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_ast" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_ast.v0.9.1)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_ast.v0.9.1
Processing 55/160: [astring: ocaml build] [fmt: ocaml build] [stdio: jbuilder build] [typerep: jbuilder build] [uchar: ocaml] [uutf: ocaml build]
-> installed ppx_ast.v0.9.1
Processing 56/160: [astring: ocaml build] [fmt: ocaml build] [stdio: jbuilder build] [typerep: jbuilder build] [uchar: ocaml] [uutf: ocaml build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "stdio" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/stdio.v0.9.1)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  stdio.v0.9.1
Processing 56/160: [astring: ocaml build] [fmt: ocaml build] [typerep: jbuilder build] [uchar: ocaml] [uutf: ocaml build]
-> installed stdio.v0.9.1
Processing 57/160: [astring: ocaml build] [fmt: ocaml build] [typerep: jbuilder build] [uchar: ocaml] [uutf: ocaml build]
Processing 58/160: [astring: ocaml build] [fmt: ocaml build] [ppx_core: jbuilder build] [typerep: jbuilder build] [uchar: ocaml] [uutf: ocaml build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "typerep" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/typerep.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  typerep.v0.9.0
Processing 58/160: [astring: ocaml build] [fmt: ocaml build] [ppx_core: jbuilder build] [uchar: ocaml] [uutf: ocaml build]
-> installed typerep.v0.9.0
Processing 59/160: [astring: ocaml build] [fmt: ocaml build] [ppx_core: jbuilder build] [uchar: ocaml] [uutf: ocaml build]
+ /home/opam/.opam/4.05/bin/ocaml "pkg/pkg.ml" "build" "--pinned" "false" (CWD=/home/opam/.opam/4.05/.opam-switch/build/astring.0.8.5)
- ocamlfind ocamldep -modules src/astring_unsafe.ml > src/astring_unsafe.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/astring_unsafe.cmo src/astring_unsafe.ml
- ocamlfind ocamldep -modules src/astring_base.ml > src/astring_base.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/astring_base.cmo src/astring_base.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -o src/astring_unsafe.cmx src/astring_unsafe.ml
- ocamlfind ocamldep -modules src/astring_escape.ml > src/astring_escape.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/astring_escape.cmo src/astring_escape.ml
- ocamlfind ocamldep -modules src/astring_char.ml > src/astring_char.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/astring_char.cmo src/astring_char.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -o src/astring_escape.cmx src/astring_escape.ml
- ocamlfind ocamldep -modules src/astring_sub.ml > src/astring_sub.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/astring_sub.cmo src/astring_sub.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -o src/astring_base.cmx src/astring_base.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -o src/astring_char.cmx src/astring_char.ml
- ocamlfind ocamldep -modules src/astring_string.ml > src/astring_string.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/astring_string.cmo src/astring_string.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -o src/astring_sub.cmx src/astring_sub.ml
- ocamlfind ocamldep -modules src/astring.ml > src/astring.ml.depends
- ocamlfind ocamldep -modules src/astring.mli > src/astring.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/astring.cmi src/astring.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -o src/astring_string.cmx src/astring_string.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -o src/astring.cmx src/astring.ml
- ocamlfind ocamlopt -a -I src src/astring_unsafe.cmx src/astring_base.cmx src/astring_escape.cmx src/astring_char.cmx src/astring_sub.cmx src/astring_string.cmx src/astring.cmx -o src/astring.cmxa
- ocamlfind ocamlopt -shared -linkall -I src src/astring.cmxa -o src/astring.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/astring.cmo src/astring.ml
- ocamlfind ocamlc -a -I src src/astring_unsafe.cmo src/astring_base.cmo src/astring_escape.cmo src/astring_char.cmo src/astring_sub.cmo src/astring_string.cmo src/astring.cmo -o src/astring.cma
- ocamlfind ocamldep -package compiler-libs.toplevel -modules src/astring_top.ml > src/astring_top.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package compiler-libs.toplevel -I src -I test -o src/astring_top.cmo src/astring_top.ml
- + ocamlfind ocamlc -c -g -bin-annot -safe-string -package compiler-libs.toplevel -I src -I test -o src/astring_top.cmo src/astring_top.ml
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package compiler-libs.toplevel -I src -I test -o src/astring_top.cmx src/astring_top.ml
- + ocamlfind ocamlopt -c -g -bin-annot -safe-string -package compiler-libs.toplevel -I src -I test -o src/astring_top.cmx src/astring_top.ml
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- File "_none_", line 1:
- Warning 58: no cmx file was found in path for module Toploop, and its interface was not compiled with -opaque
- ocamlfind ocamlopt -a -package compiler-libs.toplevel -I src src/astring_top.cmx -o src/astring_top.cmxa
- + ocamlfind ocamlopt -a -package compiler-libs.toplevel -I src src/astring_top.cmx -o src/astring_top.cmxa
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- ocamlfind ocamlopt -shared -linkall -package compiler-libs.toplevel -I src src/astring_top.cmxa -o src/astring_top.cmxs
- + ocamlfind ocamlopt -shared -linkall -package compiler-libs.toplevel -I src src/astring_top.cmxa -o src/astring_top.cmxs
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- ocamlfind ocamlc -a -package compiler-libs.toplevel -I src src/astring_top.cmo -o src/astring_top.cma
- + ocamlfind ocamlc -a -package compiler-libs.toplevel -I src src/astring_top.cmo -o src/astring_top.cma
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- # No parallelism done
- ocamlfind ocamldep -modules src/astring_unsafe.ml > src/astring_unsafe.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/astring_unsafe.cmo src/astring_unsafe.ml
- ocamlfind ocamldep -modules src/astring_base.ml > src/astring_base.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/astring_base.cmo src/astring_base.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -o src/astring_unsafe.cmx src/astring_unsafe.ml
- ocamlfind ocamldep -modules src/astring_escape.ml > src/astring_escape.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/astring_escape.cmo src/astring_escape.ml
- ocamlfind ocamldep -modules src/astring_char.ml > src/astring_char.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/astring_char.cmo src/astring_char.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -o src/astring_escape.cmx src/astring_escape.ml
- ocamlfind ocamldep -modules src/astring_sub.ml > src/astring_sub.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/astring_sub.cmo src/astring_sub.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -o src/astring_base.cmx src/astring_base.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -o src/astring_char.cmx src/astring_char.ml
- ocamlfind ocamldep -modules src/astring_string.ml > src/astring_string.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/astring_string.cmo src/astring_string.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -o src/astring_sub.cmx src/astring_sub.ml
- ocamlfind ocamldep -modules src/astring.ml > src/astring.ml.depends
- ocamlfind ocamldep -modules src/astring.mli > src/astring.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/astring.cmi src/astring.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -o src/astring_string.cmx src/astring_string.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -o src/astring.cmx src/astring.ml
- ocamlfind ocamlopt -a -I src src/astring_unsafe.cmx src/astring_base.cmx src/astring_escape.cmx src/astring_char.cmx src/astring_sub.cmx src/astring_string.cmx src/astring.cmx -o src/astring.cmxa
- ocamlfind ocamlopt -shared -linkall -I src src/astring.cmxa -o src/astring.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/astring.cmo src/astring.ml
- ocamlfind ocamlc -a -I src src/astring_unsafe.cmo src/astring_base.cmo src/astring_escape.cmo src/astring_char.cmo src/astring_sub.cmo src/astring_string.cmo src/astring.cmo -o src/astring.cma
- ocamlfind ocamldep -package compiler-libs.toplevel -modules src/astring_top.ml > src/astring_top.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package compiler-libs.toplevel -I src -I test -o src/astring_top.cmo src/astring_top.ml
- + ocamlfind ocamlc -c -g -bin-annot -safe-string -package compiler-libs.toplevel -I src -I test -o src/astring_top.cmo src/astring_top.ml
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package compiler-libs.toplevel -I src -I test -o src/astring_top.cmx src/astring_top.ml
- + ocamlfind ocamlopt -c -g -bin-annot -safe-string -package compiler-libs.toplevel -I src -I test -o src/astring_top.cmx src/astring_top.ml
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- File "_none_", line 1:
- Warning 58: no cmx file was found in path for module Toploop, and its interface was not compiled with -opaque
- ocamlfind ocamlopt -a -package compiler-libs.toplevel -I src src/astring_top.cmx -o src/astring_top.cmxa
- + ocamlfind ocamlopt -a -package compiler-libs.toplevel -I src src/astring_top.cmx -o src/astring_top.cmxa
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- ocamlfind ocamlopt -shared -linkall -package compiler-libs.toplevel -I src src/astring_top.cmxa -o src/astring_top.cmxs
- + ocamlfind ocamlopt -shared -linkall -package compiler-libs.toplevel -I src src/astring_top.cmxa -o src/astring_top.cmxs
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- ocamlfind ocamlc -a -package compiler-libs.toplevel -I src src/astring_top.cmo -o src/astring_top.cma
- + ocamlfind ocamlc -a -package compiler-libs.toplevel -I src src/astring_top.cmo -o src/astring_top.cma
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- # No parallelism done
-> compiled  astring.0.8.5
Processing 59/160: [fmt: ocaml build] [ppx_core: jbuilder build] [uchar: ocaml] [uutf: ocaml build]
-> installed astring.0.8.5
Processing 60/160: [fmt: ocaml build] [ppx_core: jbuilder build] [uchar: ocaml] [uutf: ocaml build]
+ /home/opam/.opam/4.05/bin/ocaml "pkg/pkg.ml" "build" "--dev-pkg" "false" "--with-base-unix" "true" "--with-cmdliner" "false" (CWD=/home/opam/.opam/4.05/.opam-switch/build/fmt.0.8.9)
- ocamlfind ocamldep -package seq -package stdlib-shims -modules src/fmt.ml > src/fmt.ml.depends
- ocamlfind ocamldep -package seq -package stdlib-shims -modules src/fmt.mli > src/fmt.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package seq -package stdlib-shims -I src -I test -o src/fmt.cmi src/fmt.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package seq -package stdlib-shims -I src -I test -o src/fmt.cmx src/fmt.ml
- ocamlfind ocamlopt -a -package seq -package stdlib-shims -I src src/fmt.cmx -o src/fmt.cmxa
- ocamlfind ocamlopt -shared -linkall -package seq -package stdlib-shims -I src src/fmt.cmxa -o src/fmt.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package seq -package stdlib-shims -I src -I test -o src/fmt.cmo src/fmt.ml
- ocamlfind ocamlc -a -package seq -package stdlib-shims -I src src/fmt.cmo -o src/fmt.cma
- ocamlfind ocamldep -package unix -package seq -package stdlib-shims -modules src/fmt_tty.ml > src/fmt_tty.ml.depends
- ocamlfind ocamldep -package unix -package seq -package stdlib-shims -modules src/fmt_tty.mli > src/fmt_tty.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package unix -package seq -package stdlib-shims -I src -I test -o src/fmt_tty.cmi src/fmt_tty.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package unix -package seq -package stdlib-shims -I src -I test -o src/fmt_tty.cmx src/fmt_tty.ml
- ocamlfind ocamlopt -a -package unix -package seq -package stdlib-shims -I src src/fmt_tty.cmx -o src/fmt_tty.cmxa
- ocamlfind ocamlopt -shared -linkall -package unix -package seq -package stdlib-shims -I src src/fmt_tty.cmxa -o src/fmt_tty.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package unix -package seq -package stdlib-shims -I src -I test -o src/fmt_tty.cmo src/fmt_tty.ml
- ocamlfind ocamlc -a -package unix -package seq -package stdlib-shims -I src src/fmt_tty.cmo -o src/fmt_tty.cma
- ocamlfind ocamldep -package compiler-libs.toplevel -package seq -package stdlib-shims -modules src/fmt_top.ml > src/fmt_top.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package compiler-libs.toplevel -package seq -package stdlib-shims -I src -I test -o src/fmt_top.cmo src/fmt_top.ml
- + ocamlfind ocamlc -c -g -bin-annot -safe-string -package compiler-libs.toplevel -package seq -package stdlib-shims -I src -I test -o src/fmt_top.cmo src/fmt_top.ml
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package compiler-libs.toplevel -package seq -package stdlib-shims -I src -I test -o src/fmt_top.cmx src/fmt_top.ml
- + ocamlfind ocamlopt -c -g -bin-annot -safe-string -package compiler-libs.toplevel -package seq -package stdlib-shims -I src -I test -o src/fmt_top.cmx src/fmt_top.ml
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- File "_none_", line 1:
- Warning 58: no cmx file was found in path for module Toploop, and its interface was not compiled with -opaque
- ocamlfind ocamlopt -a -package compiler-libs.toplevel -package seq -package stdlib-shims -I src src/fmt_top.cmx -o src/fmt_top.cmxa
- + ocamlfind ocamlopt -a -package compiler-libs.toplevel -package seq -package stdlib-shims -I src src/fmt_top.cmx -o src/fmt_top.cmxa
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- ocamlfind ocamlopt -shared -linkall -package compiler-libs.toplevel -package seq -package stdlib-shims -I src src/fmt_top.cmxa -o src/fmt_top.cmxs
- + ocamlfind ocamlopt -shared -linkall -package compiler-libs.toplevel -package seq -package stdlib-shims -I src src/fmt_top.cmxa -o src/fmt_top.cmxs
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- ocamlfind ocamlc -a -package compiler-libs.toplevel -package seq -package stdlib-shims -I src src/fmt_top.cmo -o src/fmt_top.cma
- + ocamlfind ocamlc -a -package compiler-libs.toplevel -package seq -package stdlib-shims -I src src/fmt_top.cmo -o src/fmt_top.cma
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- # No parallelism done
- ocamlfind ocamldep -package seq -package stdlib-shims -modules src/fmt.ml > src/fmt.ml.depends
- ocamlfind ocamldep -package seq -package stdlib-shims -modules src/fmt.mli > src/fmt.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package seq -package stdlib-shims -I src -I test -o src/fmt.cmi src/fmt.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package seq -package stdlib-shims -I src -I test -o src/fmt.cmx src/fmt.ml
- ocamlfind ocamlopt -a -package seq -package stdlib-shims -I src src/fmt.cmx -o src/fmt.cmxa
- ocamlfind ocamlopt -shared -linkall -package seq -package stdlib-shims -I src src/fmt.cmxa -o src/fmt.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package seq -package stdlib-shims -I src -I test -o src/fmt.cmo src/fmt.ml
- ocamlfind ocamlc -a -package seq -package stdlib-shims -I src src/fmt.cmo -o src/fmt.cma
- ocamlfind ocamldep -package unix -package seq -package stdlib-shims -modules src/fmt_tty.ml > src/fmt_tty.ml.depends
- ocamlfind ocamldep -package unix -package seq -package stdlib-shims -modules src/fmt_tty.mli > src/fmt_tty.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package unix -package seq -package stdlib-shims -I src -I test -o src/fmt_tty.cmi src/fmt_tty.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package unix -package seq -package stdlib-shims -I src -I test -o src/fmt_tty.cmx src/fmt_tty.ml
- ocamlfind ocamlopt -a -package unix -package seq -package stdlib-shims -I src src/fmt_tty.cmx -o src/fmt_tty.cmxa
- ocamlfind ocamlopt -shared -linkall -package unix -package seq -package stdlib-shims -I src src/fmt_tty.cmxa -o src/fmt_tty.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package unix -package seq -package stdlib-shims -I src -I test -o src/fmt_tty.cmo src/fmt_tty.ml
- ocamlfind ocamlc -a -package unix -package seq -package stdlib-shims -I src src/fmt_tty.cmo -o src/fmt_tty.cma
- ocamlfind ocamldep -package compiler-libs.toplevel -package seq -package stdlib-shims -modules src/fmt_top.ml > src/fmt_top.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package compiler-libs.toplevel -package seq -package stdlib-shims -I src -I test -o src/fmt_top.cmo src/fmt_top.ml
- + ocamlfind ocamlc -c -g -bin-annot -safe-string -package compiler-libs.toplevel -package seq -package stdlib-shims -I src -I test -o src/fmt_top.cmo src/fmt_top.ml
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package compiler-libs.toplevel -package seq -package stdlib-shims -I src -I test -o src/fmt_top.cmx src/fmt_top.ml
- + ocamlfind ocamlopt -c -g -bin-annot -safe-string -package compiler-libs.toplevel -package seq -package stdlib-shims -I src -I test -o src/fmt_top.cmx src/fmt_top.ml
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- File "_none_", line 1:
- Warning 58: no cmx file was found in path for module Toploop, and its interface was not compiled with -opaque
- ocamlfind ocamlopt -a -package compiler-libs.toplevel -package seq -package stdlib-shims -I src src/fmt_top.cmx -o src/fmt_top.cmxa
- + ocamlfind ocamlopt -a -package compiler-libs.toplevel -package seq -package stdlib-shims -I src src/fmt_top.cmx -o src/fmt_top.cmxa
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- ocamlfind ocamlopt -shared -linkall -package compiler-libs.toplevel -package seq -package stdlib-shims -I src src/fmt_top.cmxa -o src/fmt_top.cmxs
- + ocamlfind ocamlopt -shared -linkall -package compiler-libs.toplevel -package seq -package stdlib-shims -I src src/fmt_top.cmxa -o src/fmt_top.cmxs
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- ocamlfind ocamlc -a -package compiler-libs.toplevel -package seq -package stdlib-shims -I src src/fmt_top.cmo -o src/fmt_top.cma
- + ocamlfind ocamlc -a -package compiler-libs.toplevel -package seq -package stdlib-shims -I src src/fmt_top.cmo -o src/fmt_top.cma
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- # No parallelism done
-> compiled  fmt.0.8.9
Processing 60/160: [ppx_core: jbuilder build] [uchar: ocaml] [uutf: ocaml build]
-> installed fmt.0.8.9
Processing 61/160: [ppx_core: jbuilder build] [uchar: ocaml] [uutf: ocaml build]
Processing 62/160: [logs: ocaml build] [ppx_core: jbuilder build] [uchar: ocaml] [uutf: ocaml build]
+ /home/opam/.opam/4.05/bin/ocaml "pkg/pkg.ml" "build" "--dev-pkg" "false" "--with-cmdliner" "false" (CWD=/home/opam/.opam/4.05/.opam-switch/build/uutf.1.0.3)
- ocamlfind ocamldep -modules src/uutf.ml > src/uutf.ml.depends
- ocamlfind ocamldep -modules src/uutf.mli > src/uutf.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/uutf.cmi src/uutf.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -o src/uutf.cmx src/uutf.ml
- ocamlfind ocamlopt -a -I src src/uutf.cmx -o src/uutf.cmxa
- ocamlfind ocamlopt -shared -linkall -I src src/uutf.cmxa -o src/uutf.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/uutf.cmo src/uutf.ml
- ocamlfind ocamlc -a -I src src/uutf.cmo -o src/uutf.cma
- # No parallelism done
- ocamlfind ocamldep -modules src/uutf.ml > src/uutf.ml.depends
- ocamlfind ocamldep -modules src/uutf.mli > src/uutf.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/uutf.cmi src/uutf.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -o src/uutf.cmx src/uutf.ml
- ocamlfind ocamlopt -a -I src src/uutf.cmx -o src/uutf.cmxa
- ocamlfind ocamlopt -shared -linkall -I src src/uutf.cmxa -o src/uutf.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/uutf.cmo src/uutf.ml
- ocamlfind ocamlc -a -I src src/uutf.cmo -o src/uutf.cma
- # No parallelism done
-> compiled  uutf.1.0.3
Processing 62/160: [logs: ocaml build] [ppx_core: jbuilder build] [uchar: ocaml]
-> installed uutf.1.0.3
Processing 63/160: [logs: ocaml build] [ppx_core: jbuilder build] [uchar: ocaml]
+ /home/opam/.opam/4.05/bin/ocaml "pkg/build.ml" "native=true" "native-dynlink=true" (CWD=/home/opam/.opam/4.05/.opam-switch/build/uchar.0.0.2)
-> compiled  uchar.0.0.2
Processing 63/160: [logs: ocaml build] [ppx_core: jbuilder build]
-> installed uchar.0.0.2
Processing 64/160: [logs: ocaml build] [ppx_core: jbuilder build]
Processing 65/160: [jsonm: ocaml build] [logs: ocaml build] [ppx_core: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "-p" "ppx_core" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_core.v0.9.3)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/gen/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-       ocamlc src/gen/.gen_ast_pattern.eobjs/byte/import.{cmi,cmo,cmt}
- File "src/gen/import.ml", line 93, characters 9-25:
- Warning 3: deprecated: String.lowercase
- Use String.lowercase_ascii instead.
-     ocamlopt src/gen/.gen_ast_pattern.eobjs/native/import.{cmx,o}
- File "src/gen/import.ml", line 93, characters 9-25:
- Warning 3: deprecated: String.lowercase
- Use String.lowercase_ascii instead.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/gen/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-       ocamlc src/gen/.gen_ast_pattern.eobjs/byte/import.{cmi,cmo,cmt}
- File "src/gen/import.ml", line 93, characters 9-25:
- Warning 3: deprecated: String.lowercase
- Use String.lowercase_ascii instead.
-     ocamlopt src/gen/.gen_ast_pattern.eobjs/native/import.{cmx,o}
- File "src/gen/import.ml", line 93, characters 9-25:
- Warning 3: deprecated: String.lowercase
- Use String.lowercase_ascii instead.
-> compiled  ppx_core.v0.9.3
Processing 65/160: [jsonm: ocaml build] [logs: ocaml build]
-> installed ppx_core.v0.9.3
Processing 66/160: [jsonm: ocaml build] [logs: ocaml build]
Processing 67/160: [jsonm: ocaml build] [logs: ocaml build] [ppx_optcomp: jbuilder build]
+ /home/opam/.opam/4.05/bin/ocaml "pkg/pkg.ml" "build" "--pinned" "false" "--with-js_of_ocaml" "false" "--with-fmt" "true" "--with-cmdliner" "false" "--with-lwt" "false" "--with-base-threads" "true" (CWD=/home/opam/.opam/4.05/.opam-switch/build/logs.0.7.0)
- ocamlfind ocamldep -modules src/logs.ml > src/logs.ml.depends
- ocamlfind ocamldep -modules src/logs.mli > src/logs.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/logs.cmi src/logs.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -o src/logs.cmx src/logs.ml
- ocamlfind ocamlopt -a -I src src/logs.cmx -o src/logs.cmxa
- ocamlfind ocamlopt -shared -linkall -I src src/logs.cmxa -o src/logs.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/logs.cmo src/logs.ml
- ocamlfind ocamlc -a -I src src/logs.cmo -o src/logs.cma
- ocamlfind ocamldep -package fmt -modules src/logs_fmt.ml > src/logs_fmt.ml.depends
- ocamlfind ocamldep -package fmt -modules src/logs_fmt.mli > src/logs_fmt.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package fmt -I src -I test -o src/logs_fmt.cmi src/logs_fmt.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package fmt -I src -I test -o src/logs_fmt.cmx src/logs_fmt.ml
- ocamlfind ocamlopt -a -package fmt -I src src/logs_fmt.cmx -o src/logs_fmt.cmxa
- ocamlfind ocamlopt -shared -linkall -package fmt -I src src/logs_fmt.cmxa -o src/logs_fmt.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package fmt -I src -I test -o src/logs_fmt.cmo src/logs_fmt.ml
- ocamlfind ocamlc -a -package fmt -I src src/logs_fmt.cmo -o src/logs_fmt.cma
- ocamlfind ocamldep -package compiler-libs.toplevel -modules src/logs_top.ml > src/logs_top.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package compiler-libs.toplevel -I src -I test -o src/logs_top.cmo src/logs_top.ml
- + ocamlfind ocamlc -c -g -bin-annot -safe-string -package compiler-libs.toplevel -I src -I test -o src/logs_top.cmo src/logs_top.ml
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package compiler-libs.toplevel -I src -I test -o src/logs_top.cmx src/logs_top.ml
- + ocamlfind ocamlopt -c -g -bin-annot -safe-string -package compiler-libs.toplevel -I src -I test -o src/logs_top.cmx src/logs_top.ml
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- File "_none_", line 1:
- Warning 58: no cmx file was found in path for module Toploop, and its interface was not compiled with -opaque
- ocamlfind ocamlopt -a -package compiler-libs.toplevel -I src src/logs_top.cmx -o src/logs_top.cmxa
- + ocamlfind ocamlopt -a -package compiler-libs.toplevel -I src src/logs_top.cmx -o src/logs_top.cmxa
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- ocamlfind ocamlopt -shared -linkall -package compiler-libs.toplevel -I src src/logs_top.cmxa -o src/logs_top.cmxs
- + ocamlfind ocamlopt -shared -linkall -package compiler-libs.toplevel -I src src/logs_top.cmxa -o src/logs_top.cmxs
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- ocamlfind ocamlc -a -package compiler-libs.toplevel -I src src/logs_top.cmo -o src/logs_top.cma
- + ocamlfind ocamlc -a -package compiler-libs.toplevel -I src src/logs_top.cmo -o src/logs_top.cma
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- ocamlfind ocamldep -package threads -modules src/logs_threaded.ml > src/logs_threaded.ml.depends
- ocamlfind ocamldep -package threads -modules src/logs_threaded.mli > src/logs_threaded.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -thread -package threads -I src -I test -o src/logs_threaded.cmi src/logs_threaded.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -thread -package threads -I src -I test -o src/logs_threaded.cmx src/logs_threaded.ml
- ocamlfind ocamlopt -a -thread -package threads -I src src/logs_threaded.cmx -o src/logs_threaded.cmxa
- ocamlfind ocamlopt -shared -linkall -thread -package threads -I src src/logs_threaded.cmxa -o src/logs_threaded.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -thread -package threads -I src -I test -o src/logs_threaded.cmo src/logs_threaded.ml
- ocamlfind ocamlc -a -thread -package threads -I src src/logs_threaded.cmo -o src/logs_threaded.cma
- # No parallelism done
- ocamlfind ocamldep -modules src/logs.ml > src/logs.ml.depends
- ocamlfind ocamldep -modules src/logs.mli > src/logs.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/logs.cmi src/logs.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -I src -I test -o src/logs.cmx src/logs.ml
- ocamlfind ocamlopt -a -I src src/logs.cmx -o src/logs.cmxa
- ocamlfind ocamlopt -shared -linkall -I src src/logs.cmxa -o src/logs.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -I src -I test -o src/logs.cmo src/logs.ml
- ocamlfind ocamlc -a -I src src/logs.cmo -o src/logs.cma
- ocamlfind ocamldep -package fmt -modules src/logs_fmt.ml > src/logs_fmt.ml.depends
- ocamlfind ocamldep -package fmt -modules src/logs_fmt.mli > src/logs_fmt.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package fmt -I src -I test -o src/logs_fmt.cmi src/logs_fmt.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package fmt -I src -I test -o src/logs_fmt.cmx src/logs_fmt.ml
- ocamlfind ocamlopt -a -package fmt -I src src/logs_fmt.cmx -o src/logs_fmt.cmxa
- ocamlfind ocamlopt -shared -linkall -package fmt -I src src/logs_fmt.cmxa -o src/logs_fmt.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package fmt -I src -I test -o src/logs_fmt.cmo src/logs_fmt.ml
- ocamlfind ocamlc -a -package fmt -I src src/logs_fmt.cmo -o src/logs_fmt.cma
- ocamlfind ocamldep -package compiler-libs.toplevel -modules src/logs_top.ml > src/logs_top.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package compiler-libs.toplevel -I src -I test -o src/logs_top.cmo src/logs_top.ml
- + ocamlfind ocamlc -c -g -bin-annot -safe-string -package compiler-libs.toplevel -I src -I test -o src/logs_top.cmo src/logs_top.ml
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package compiler-libs.toplevel -I src -I test -o src/logs_top.cmx src/logs_top.ml
- + ocamlfind ocamlopt -c -g -bin-annot -safe-string -package compiler-libs.toplevel -I src -I test -o src/logs_top.cmx src/logs_top.ml
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- File "_none_", line 1:
- Warning 58: no cmx file was found in path for module Toploop, and its interface was not compiled with -opaque
- ocamlfind ocamlopt -a -package compiler-libs.toplevel -I src src/logs_top.cmx -o src/logs_top.cmxa
- + ocamlfind ocamlopt -a -package compiler-libs.toplevel -I src src/logs_top.cmx -o src/logs_top.cmxa
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- ocamlfind ocamlopt -shared -linkall -package compiler-libs.toplevel -I src src/logs_top.cmxa -o src/logs_top.cmxs
- + ocamlfind ocamlopt -shared -linkall -package compiler-libs.toplevel -I src src/logs_top.cmxa -o src/logs_top.cmxs
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- ocamlfind ocamlc -a -package compiler-libs.toplevel -I src src/logs_top.cmo -o src/logs_top.cma
- + ocamlfind ocamlc -a -package compiler-libs.toplevel -I src src/logs_top.cmo -o src/logs_top.cma
- findlib: [WARNING] Interface topdirs.cmi occurs in several directories: /home/opam/.opam/4.05/lib/ocaml, /home/opam/.opam/4.05/lib/ocaml/compiler-libs
- ocamlfind ocamldep -package threads -modules src/logs_threaded.ml > src/logs_threaded.ml.depends
- ocamlfind ocamldep -package threads -modules src/logs_threaded.mli > src/logs_threaded.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -thread -package threads -I src -I test -o src/logs_threaded.cmi src/logs_threaded.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -thread -package threads -I src -I test -o src/logs_threaded.cmx src/logs_threaded.ml
- ocamlfind ocamlopt -a -thread -package threads -I src src/logs_threaded.cmx -o src/logs_threaded.cmxa
- ocamlfind ocamlopt -shared -linkall -thread -package threads -I src src/logs_threaded.cmxa -o src/logs_threaded.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -thread -package threads -I src -I test -o src/logs_threaded.cmo src/logs_threaded.ml
- ocamlfind ocamlc -a -thread -package threads -I src src/logs_threaded.cmo -o src/logs_threaded.cma
- # No parallelism done
-> compiled  logs.0.7.0
Processing 67/160: [jsonm: ocaml build] [ppx_optcomp: jbuilder build]
-> installed logs.0.7.0
Processing 68/160: [jsonm: ocaml build] [ppx_optcomp: jbuilder build]
+ /home/opam/.opam/4.05/bin/ocaml "pkg/pkg.ml" "build" "--pinned" "false" (CWD=/home/opam/.opam/4.05/.opam-switch/build/jsonm.1.0.1)
- ocamlfind ocamldep -package bytes -package uchar -package uutf -modules src/jsonm.ml > src/jsonm.ml.depends
- ocamlfind ocamldep -package bytes -package uchar -package uutf -modules src/jsonm.mli > src/jsonm.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package bytes -package uchar -package uutf -I src -I test -o src/jsonm.cmi src/jsonm.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package bytes -package uchar -package uutf -I src -I test -o src/jsonm.cmx src/jsonm.ml
- ocamlfind ocamlopt -a -package bytes -package uchar -package uutf -I src src/jsonm.cmx -o src/jsonm.cmxa
- ocamlfind ocamlopt -shared -linkall -package bytes -package uchar -package uutf -I src src/jsonm.cmxa -o src/jsonm.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package bytes -package uchar -package uutf -I src -I test -o src/jsonm.cmo src/jsonm.ml
- ocamlfind ocamlc -a -package bytes -package uchar -package uutf -I src src/jsonm.cmo -o src/jsonm.cma
- ocamlfind ocamldep -package unix -package bytes -package uchar -package uutf -modules test/jsontrip.ml > test/jsontrip.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package unix -package bytes -package uchar -package uutf -I test -I src -o test/jsontrip.cmo test/jsontrip.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package unix -package bytes -package uchar -package uutf -I test -I src -o test/jsontrip.cmx test/jsontrip.ml
- ocamlfind ocamlopt -linkpkg -g -package unix -package bytes -package uchar -package uutf -I src -I test src/jsonm.cmx test/jsontrip.cmx -o test/jsontrip.native
- # No parallelism done
- ocamlfind ocamldep -package bytes -package uchar -package uutf -modules src/jsonm.ml > src/jsonm.ml.depends
- ocamlfind ocamldep -package bytes -package uchar -package uutf -modules src/jsonm.mli > src/jsonm.mli.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package bytes -package uchar -package uutf -I src -I test -o src/jsonm.cmi src/jsonm.mli
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package bytes -package uchar -package uutf -I src -I test -o src/jsonm.cmx src/jsonm.ml
- ocamlfind ocamlopt -a -package bytes -package uchar -package uutf -I src src/jsonm.cmx -o src/jsonm.cmxa
- ocamlfind ocamlopt -shared -linkall -package bytes -package uchar -package uutf -I src src/jsonm.cmxa -o src/jsonm.cmxs
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package bytes -package uchar -package uutf -I src -I test -o src/jsonm.cmo src/jsonm.ml
- ocamlfind ocamlc -a -package bytes -package uchar -package uutf -I src src/jsonm.cmo -o src/jsonm.cma
- ocamlfind ocamldep -package unix -package bytes -package uchar -package uutf -modules test/jsontrip.ml > test/jsontrip.ml.depends
- ocamlfind ocamlc -c -g -bin-annot -safe-string -package unix -package bytes -package uchar -package uutf -I test -I src -o test/jsontrip.cmo test/jsontrip.ml
- ocamlfind ocamlopt -c -g -bin-annot -safe-string -package unix -package bytes -package uchar -package uutf -I test -I src -o test/jsontrip.cmx test/jsontrip.ml
- ocamlfind ocamlopt -linkpkg -g -package unix -package bytes -package uchar -package uutf -I src -I test src/jsonm.cmx test/jsontrip.cmx -o test/jsontrip.native
- # No parallelism done
-> compiled  jsonm.1.0.1
Processing 68/160: [ppx_optcomp: jbuilder build]
-> installed jsonm.1.0.1
Processing 69/160: [ppx_optcomp: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_optcomp" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_optcomp.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "bin/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_optcomp.v0.9.0
-> installed ppx_optcomp.v0.9.0
Processing 71/160: [ppx_driver: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "-p" "ppx_driver" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_driver.v0.9.2)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "bench/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "ocamlbuild_plugin/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "print-diff/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "runner/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "runner_as_ppx/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/omp-integration/omp-ppx/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/omp-integration/test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_driver.v0.9.2
-> installed ppx_driver.v0.9.2
Processing 73/160: [fieldslib: jbuilder build]
Processing 74/160: [fieldslib: jbuilder build] [ppx_here: jbuilder build]
Processing 75/160: [fieldslib: jbuilder build] [ppx_here: jbuilder build] [ppx_let: jbuilder build]
Processing 76/160: [fieldslib: jbuilder build] [ppx_here: jbuilder build] [ppx_let: jbuilder build] [ppx_metaquot: jbuilder build]
Processing 77/160: [fieldslib: jbuilder build] [ppx_here: jbuilder build] [ppx_let: jbuilder build] [ppx_metaquot: jbuilder build] [variantslib: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "fieldslib" "--no-config" "--root" "." "-j" "31" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/fieldslib.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  fieldslib.v0.9.0
Processing 77/160: [ppx_here: jbuilder build] [ppx_let: jbuilder build] [ppx_metaquot: jbuilder build] [variantslib: jbuilder build]
-> installed fieldslib.v0.9.0
Processing 78/160: [ppx_here: jbuilder build] [ppx_let: jbuilder build] [ppx_metaquot: jbuilder build] [variantslib: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "-p" "ppx_here" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_here.v0.9.1)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "expander/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "expander/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_here.v0.9.1
Processing 78/160: [ppx_let: jbuilder build] [ppx_metaquot: jbuilder build] [variantslib: jbuilder build]
-> installed ppx_here.v0.9.1
Processing 79/160: [ppx_let: jbuilder build] [ppx_metaquot: jbuilder build] [variantslib: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_let" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_let.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_let.v0.9.0
Processing 79/160: [ppx_metaquot: jbuilder build] [variantslib: jbuilder build]
-> installed ppx_let.v0.9.0
Processing 80/160: [ppx_metaquot: jbuilder build] [variantslib: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_metaquot" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_metaquot.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "lifters/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "lifters/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_metaquot.v0.9.0
Processing 80/160: [variantslib: jbuilder build]
-> installed ppx_metaquot.v0.9.0
Processing 81/160: [variantslib: jbuilder build]
Processing 82/160: [ppx_fail: jbuilder build] [variantslib: jbuilder build]
Processing 83/160: [ppx_fail: jbuilder build] [ppx_inline_test: jbuilder build] [variantslib: jbuilder build]
Processing 84/160: [ppx_fail: jbuilder build] [ppx_inline_test: jbuilder build] [ppx_js_style: jbuilder build] [variantslib: jbuilder build]
Processing 85/160: [ppx_fail: jbuilder build] [ppx_inline_test: jbuilder build] [ppx_js_style: jbuilder build] [ppx_optional: jbuilder build] [variantslib: jbuilder build]
Processing 86/160: [ppx_fail: jbuilder build] [ppx_inline_test: jbuilder build] [ppx_js_style: jbuilder build] [ppx_optional: jbuilder build] [ppx_pipebang: jbuilder build] [variantslib: jbuilder build]
Processing 87/160: [ppx_fail: jbuilder build] [ppx_inline_test: jbuilder build] [ppx_js_style: jbuilder build] [ppx_optional: jbuilder build] [ppx_pipebang: jbuilder build] [ppx_type_conv: jbuilder build] [variantslib: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "variantslib" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/variantslib.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  variantslib.v0.9.0
Processing 87/160: [ppx_fail: jbuilder build] [ppx_inline_test: jbuilder build] [ppx_js_style: jbuilder build] [ppx_optional: jbuilder build] [ppx_pipebang: jbuilder build] [ppx_type_conv: jbuilder build]
-> installed variantslib.v0.9.0
Processing 88/160: [ppx_fail: jbuilder build] [ppx_inline_test: jbuilder build] [ppx_js_style: jbuilder build] [ppx_optional: jbuilder build] [ppx_pipebang: jbuilder build] [ppx_type_conv: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_optional" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_optional.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_optional.v0.9.0
Processing 88/160: [ppx_fail: jbuilder build] [ppx_inline_test: jbuilder build] [ppx_js_style: jbuilder build] [ppx_pipebang: jbuilder build] [ppx_type_conv: jbuilder build]
-> installed ppx_optional.v0.9.0
Processing 89/160: [ppx_fail: jbuilder build] [ppx_inline_test: jbuilder build] [ppx_js_style: jbuilder build] [ppx_pipebang: jbuilder build] [ppx_type_conv: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "-p" "ppx_inline_test" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_inline_test.v0.9.2)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "config/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "drop/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "example/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "libname/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "runner/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "runner/lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "runtime-lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 10, characters 0-626:
- 10 | (rule
- 11 |  ((targets (test.output test-partitions.output diff-with-without-partitions))
- 12 |   (deps (./inline_tests_runner ./inline_tests_runner.exe))
- ....
- 28 | diff -u  --label test.output --label test-partitions.output \
- 29 |   test.output test-partitions.output > diff-with-without-partitions || true
- 30 | "))))
- Warning: The following files are both generated by a rule and are present in
- the source tree:
- - test/diff-with-without-partitions
- Because you are using the jbuilder binary, I am closing my eyes on this and I
- am overwriting the source files with the generated one. However, you should
- really delete these files from your source tree. I will no longer accept this
- once you upgrade your project to dune >= 1.10.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "config/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "drop/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "example/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "libname/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "runner/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "runner/lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "runtime-lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 10, characters 0-626:
- 10 | (rule
- 11 |  ((targets (test.output test-partitions.output diff-with-without-partitions))
- 12 |   (deps (./inline_tests_runner ./inline_tests_runner.exe))
- ....
- 28 | diff -u  --label test.output --label test-partitions.output \
- 29 |   test.output test-partitions.output > diff-with-without-partitions || true
- 30 | "))))
- Warning: The following files are both generated by a rule and are present in
- the source tree:
- - test/diff-with-without-partitions
- Because you are using the jbuilder binary, I am closing my eyes on this and I
- am overwriting the source files with the generated one. However, you should
- really delete these files from your source tree. I will no longer accept this
- once you upgrade your project to dune >= 1.10.
-> compiled  ppx_inline_test.v0.9.2
Processing 89/160: [ppx_fail: jbuilder build] [ppx_js_style: jbuilder build] [ppx_pipebang: jbuilder build] [ppx_type_conv: jbuilder build]
-> installed ppx_inline_test.v0.9.2
Processing 90/160: [ppx_fail: jbuilder build] [ppx_js_style: jbuilder build] [ppx_pipebang: jbuilder build] [ppx_type_conv: jbuilder build]
Processing 91/160: [ppx_bench: jbuilder build] [ppx_fail: jbuilder build] [ppx_js_style: jbuilder build] [ppx_pipebang: jbuilder build] [ppx_type_conv: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_fail" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_fail.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_fail.v0.9.0
Processing 91/160: [ppx_bench: jbuilder build] [ppx_js_style: jbuilder build] [ppx_pipebang: jbuilder build] [ppx_type_conv: jbuilder build]
-> installed ppx_fail.v0.9.0
Processing 92/160: [ppx_bench: jbuilder build] [ppx_js_style: jbuilder build] [ppx_pipebang: jbuilder build] [ppx_type_conv: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_js_style" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_js_style.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_js_style.v0.9.0
Processing 92/160: [ppx_bench: jbuilder build] [ppx_pipebang: jbuilder build] [ppx_type_conv: jbuilder build]
-> installed ppx_js_style.v0.9.0
Processing 93/160: [ppx_bench: jbuilder build] [ppx_pipebang: jbuilder build] [ppx_type_conv: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_pipebang" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_pipebang.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "example/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "example/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_pipebang.v0.9.0
Processing 93/160: [ppx_bench: jbuilder build] [ppx_type_conv: jbuilder build]
-> installed ppx_pipebang.v0.9.0
Processing 94/160: [ppx_bench: jbuilder build] [ppx_type_conv: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "-p" "ppx_type_conv" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_type_conv.v0.9.1)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_type_conv.v0.9.1
Processing 94/160: [ppx_bench: jbuilder build]
-> installed ppx_type_conv.v0.9.1
Processing 95/160: [ppx_bench: jbuilder build]
Processing 96/160: [ppx_bench: jbuilder build] [ppx_compare: jbuilder build]
Processing 97/160: [ppx_bench: jbuilder build] [ppx_compare: jbuilder build] [ppx_enumerate: jbuilder build]
Processing 98/160: [ppx_bench: jbuilder build] [ppx_compare: jbuilder build] [ppx_enumerate: jbuilder build] [ppx_fields_conv: jbuilder build]
Processing 99/160: [ppx_bench: jbuilder build] [ppx_compare: jbuilder build] [ppx_enumerate: jbuilder build] [ppx_fields_conv: jbuilder build] [ppx_sexp_conv: jbuilder build]
Processing 100/160: [ppx_bench: jbuilder build] [ppx_compare: jbuilder build] [ppx_enumerate: jbuilder build] [ppx_fields_conv: jbuilder build] [ppx_sexp_conv: jbuilder build] [ppx_traverse: jbuilder build]
Processing 101/160: [ppx_bench: jbuilder build] [ppx_compare: jbuilder build] [ppx_enumerate: jbuilder build] [ppx_fields_conv: jbuilder build] [ppx_sexp_conv: jbuilder build] [ppx_traverse: jbuilder build] [ppx_typerep_conv: jbuilder build]
Processing 102/160: [ppx_bench: jbuilder build] [ppx_compare: jbuilder build] [ppx_enumerate: jbuilder build] [ppx_fields_conv: jbuilder build] [ppx_sexp_conv: jbuilder build] [ppx_traverse: jbuilder build] [ppx_typerep_conv: jbuilder build] [ppx_variants_conv: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "-p" "ppx_bench" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_bench.v0.9.1)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "example/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "runtime-lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "example/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "runtime-lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_bench.v0.9.1
Processing 102/160: [ppx_compare: jbuilder build] [ppx_enumerate: jbuilder build] [ppx_fields_conv: jbuilder build] [ppx_sexp_conv: jbuilder build] [ppx_traverse: jbuilder build] [ppx_typerep_conv: jbuilder build] [ppx_variants_conv: jbuilder build]
-> installed ppx_bench.v0.9.1
Processing 103/160: [ppx_compare: jbuilder build] [ppx_enumerate: jbuilder build] [ppx_fields_conv: jbuilder build] [ppx_sexp_conv: jbuilder build] [ppx_traverse: jbuilder build] [ppx_typerep_conv: jbuilder build] [ppx_variants_conv: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_typerep_conv" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_typerep_conv.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_typerep_conv.v0.9.0
Processing 103/160: [ppx_compare: jbuilder build] [ppx_enumerate: jbuilder build] [ppx_fields_conv: jbuilder build] [ppx_sexp_conv: jbuilder build] [ppx_traverse: jbuilder build] [ppx_variants_conv: jbuilder build]
-> installed ppx_typerep_conv.v0.9.0
Processing 104/160: [ppx_compare: jbuilder build] [ppx_enumerate: jbuilder build] [ppx_fields_conv: jbuilder build] [ppx_sexp_conv: jbuilder build] [ppx_traverse: jbuilder build] [ppx_variants_conv: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_compare" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_compare.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "expander/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "runtime-lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "expander/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "runtime-lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_compare.v0.9.0
Processing 104/160: [ppx_enumerate: jbuilder build] [ppx_fields_conv: jbuilder build] [ppx_sexp_conv: jbuilder build] [ppx_traverse: jbuilder build] [ppx_variants_conv: jbuilder build]
-> installed ppx_compare.v0.9.0
Processing 105/160: [ppx_enumerate: jbuilder build] [ppx_fields_conv: jbuilder build] [ppx_sexp_conv: jbuilder build] [ppx_traverse: jbuilder build] [ppx_variants_conv: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_enumerate" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_enumerate.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "example/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "example/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_enumerate.v0.9.0
Processing 105/160: [ppx_fields_conv: jbuilder build] [ppx_sexp_conv: jbuilder build] [ppx_traverse: jbuilder build] [ppx_variants_conv: jbuilder build]
-> installed ppx_enumerate.v0.9.0
Processing 106/160: [ppx_fields_conv: jbuilder build] [ppx_sexp_conv: jbuilder build] [ppx_traverse: jbuilder build] [ppx_variants_conv: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_fields_conv" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_fields_conv.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "example/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "example/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_fields_conv.v0.9.0
Processing 106/160: [ppx_sexp_conv: jbuilder build] [ppx_traverse: jbuilder build] [ppx_variants_conv: jbuilder build]
-> installed ppx_fields_conv.v0.9.0
Processing 107/160: [ppx_sexp_conv: jbuilder build] [ppx_traverse: jbuilder build] [ppx_variants_conv: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_sexp_conv" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_sexp_conv.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "expander/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "expander/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_sexp_conv.v0.9.0
Processing 107/160: [ppx_traverse: jbuilder build] [ppx_variants_conv: jbuilder build]
-> installed ppx_sexp_conv.v0.9.0
Processing 108/160: [ppx_traverse: jbuilder build] [ppx_variants_conv: jbuilder build]
Processing 109/160: [ipaddr: dune build] [ppx_traverse: jbuilder build] [ppx_variants_conv: jbuilder build]
Processing 110/160: [ipaddr: dune build] [ppx_assert: jbuilder build] [ppx_traverse: jbuilder build] [ppx_variants_conv: jbuilder build]
Processing 111/160: [ipaddr: dune build] [ppx_assert: jbuilder build] [ppx_hash: jbuilder build] [ppx_traverse: jbuilder build] [ppx_variants_conv: jbuilder build]
Processing 112/160: [ipaddr: dune build] [ppx_assert: jbuilder build] [ppx_hash: jbuilder build] [ppx_sexp_message: jbuilder build] [ppx_traverse: jbuilder build] [ppx_variants_conv: jbuilder build]
Processing 113/160: [ipaddr: dune build] [ppx_assert: jbuilder build] [ppx_hash: jbuilder build] [ppx_sexp_message: jbuilder build] [ppx_sexp_value: jbuilder build] [ppx_traverse: jbuilder build] [ppx_variants_conv: jbuilder build]
Processing 114/160: [ipaddr: dune build] [ppx_assert: jbuilder build] [ppx_hash: jbuilder build] [ppx_sexp_message: jbuilder build] [ppx_sexp_value: jbuilder build] [ppx_traverse: jbuilder build] [ppx_variants_conv: jbuilder build] [uri: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_traverse" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_traverse.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_traverse.v0.9.0
Processing 114/160: [ipaddr: dune build] [ppx_assert: jbuilder build] [ppx_hash: jbuilder build] [ppx_sexp_message: jbuilder build] [ppx_sexp_value: jbuilder build] [ppx_variants_conv: jbuilder build] [uri: jbuilder build]
-> installed ppx_traverse.v0.9.0
Processing 115/160: [ipaddr: dune build] [ppx_assert: jbuilder build] [ppx_hash: jbuilder build] [ppx_sexp_message: jbuilder build] [ppx_sexp_value: jbuilder build] [ppx_variants_conv: jbuilder build] [uri: jbuilder build]
Processing 116/160: [ipaddr: dune build] [ppx_assert: jbuilder build] [ppx_custom_printf: jbuilder build] [ppx_hash: jbuilder build] [ppx_sexp_message: jbuilder build] [ppx_sexp_value: jbuilder build] [ppx_variants_conv: jbuilder build] [uri: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_variants_conv" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_variants_conv.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "example/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "example/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_variants_conv.v0.9.0
Processing 116/160: [ipaddr: dune build] [ppx_assert: jbuilder build] [ppx_custom_printf: jbuilder build] [ppx_hash: jbuilder build] [ppx_sexp_message: jbuilder build] [ppx_sexp_value: jbuilder build] [uri: jbuilder build]
-> installed ppx_variants_conv.v0.9.0
Processing 117/160: [ipaddr: dune build] [ppx_assert: jbuilder build] [ppx_custom_printf: jbuilder build] [ppx_hash: jbuilder build] [ppx_sexp_message: jbuilder build] [ppx_sexp_value: jbuilder build] [uri: jbuilder build]
+ /home/opam/.opam/4.05/bin/dune "build" "-p" "ipaddr" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ipaddr.2.9.0)
-     ocamlopt lib/.ipaddr_top.objs/native/ipaddr_top.{cmx,o}
- File "_none_", line 1:
- Warning 58: no cmx file was found in path for module Toploop, and its interface was not compiled with -opaque
-     ocamlopt lib/.ipaddr_top.objs/native/ipaddr_top.{cmx,o}
- File "_none_", line 1:
- Warning 58: no cmx file was found in path for module Toploop, and its interface was not compiled with -opaque
-> compiled  ipaddr.2.9.0
Processing 117/160: [ppx_assert: jbuilder build] [ppx_custom_printf: jbuilder build] [ppx_hash: jbuilder build] [ppx_sexp_message: jbuilder build] [ppx_sexp_value: jbuilder build] [uri: jbuilder build]
-> installed ipaddr.2.9.0
Processing 118/160: [ppx_assert: jbuilder build] [ppx_custom_printf: jbuilder build] [ppx_hash: jbuilder build] [ppx_sexp_message: jbuilder build] [ppx_sexp_value: jbuilder build] [uri: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_assert" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_assert.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "bench/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "runtime-lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "bench/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "runtime-lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_assert.v0.9.0
Processing 118/160: [ppx_custom_printf: jbuilder build] [ppx_hash: jbuilder build] [ppx_sexp_message: jbuilder build] [ppx_sexp_value: jbuilder build] [uri: jbuilder build]
-> installed ppx_assert.v0.9.0
Processing 119/160: [ppx_custom_printf: jbuilder build] [ppx_hash: jbuilder build] [ppx_sexp_message: jbuilder build] [ppx_sexp_value: jbuilder build] [uri: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_hash" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_hash.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "expander/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "runtime-lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "runtime-lib/bench/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "runtime-lib/siphash/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "runtime-lib/test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "expander/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "runtime-lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "runtime-lib/bench/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "runtime-lib/siphash/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "runtime-lib/test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_hash.v0.9.0
Processing 119/160: [ppx_custom_printf: jbuilder build] [ppx_sexp_message: jbuilder build] [ppx_sexp_value: jbuilder build] [uri: jbuilder build]
-> installed ppx_hash.v0.9.0
Processing 120/160: [ppx_custom_printf: jbuilder build] [ppx_sexp_message: jbuilder build] [ppx_sexp_value: jbuilder build] [uri: jbuilder build]
Processing 121/160: [ppx_base: jbuilder build] [ppx_custom_printf: jbuilder build] [ppx_sexp_message: jbuilder build] [ppx_sexp_value: jbuilder build] [uri: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_sexp_message" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_sexp_message.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_sexp_message.v0.9.0
Processing 121/160: [ppx_base: jbuilder build] [ppx_custom_printf: jbuilder build] [ppx_sexp_value: jbuilder build] [uri: jbuilder build]
-> installed ppx_sexp_message.v0.9.0
Processing 122/160: [ppx_base: jbuilder build] [ppx_custom_printf: jbuilder build] [ppx_sexp_value: jbuilder build] [uri: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_sexp_value" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_sexp_value.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "example/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "example/deprecated/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/deprecated/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "example/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "example/deprecated/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/deprecated/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_sexp_value.v0.9.0
Processing 122/160: [ppx_base: jbuilder build] [ppx_custom_printf: jbuilder build] [uri: jbuilder build]
-> installed ppx_sexp_value.v0.9.0
Processing 123/160: [ppx_base: jbuilder build] [ppx_custom_printf: jbuilder build] [uri: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "-p" "uri" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/uri.1.9.7)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "config/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "etc/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "lib_test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-       ocamlc lib/.uri.objs/byte/uri.{cmo,cmt}
- File "lib/uri.ml", line 608, characters 32-38:
- Warning 3: deprecated: Re.get
- Use Group.get
- File "lib/uri.ml", line 613, characters 34-40:
- Warning 3: deprecated: Re.get
- Use Group.get
-     ocamlopt lib/.uri.objs/native/uri.{cmx,o}
- File "lib/uri.ml", line 608, characters 32-38:
- Warning 3: deprecated: Re.get
- Use Group.get
- File "lib/uri.ml", line 613, characters 34-40:
- Warning 3: deprecated: Re.get
- Use Group.get
-     ocamlopt lib/.uri_top.objs/native/uri_top.{cmx,o}
- File "_none_", line 1:
- Warning 58: no cmx file was found in path for module Toploop, and its interface was not compiled with -opaque
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "config/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "etc/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "lib_test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-       ocamlc lib/.uri.objs/byte/uri.{cmo,cmt}
- File "lib/uri.ml", line 608, characters 32-38:
- Warning 3: deprecated: Re.get
- Use Group.get
- File "lib/uri.ml", line 613, characters 34-40:
- Warning 3: deprecated: Re.get
- Use Group.get
-     ocamlopt lib/.uri.objs/native/uri.{cmx,o}
- File "lib/uri.ml", line 608, characters 32-38:
- Warning 3: deprecated: Re.get
- Use Group.get
- File "lib/uri.ml", line 613, characters 34-40:
- Warning 3: deprecated: Re.get
- Use Group.get
-     ocamlopt lib/.uri_top.objs/native/uri_top.{cmx,o}
- File "_none_", line 1:
- Warning 58: no cmx file was found in path for module Toploop, and its interface was not compiled with -opaque
-> compiled  uri.1.9.7
Processing 123/160: [ppx_base: jbuilder build] [ppx_custom_printf: jbuilder build]
-> installed uri.1.9.7
Processing 124/160: [ppx_base: jbuilder build] [ppx_custom_printf: jbuilder build]
Processing 125/160: [cohttp: jbuilder build] [ppx_base: jbuilder build] [ppx_custom_printf: jbuilder build]
Processing 126/160: [cohttp: jbuilder build] [conduit: jbuilder build] [ppx_base: jbuilder build] [ppx_custom_printf: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_custom_printf" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_custom_printf.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/gen/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/gen/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_custom_printf.v0.9.0
Processing 126/160: [cohttp: jbuilder build] [conduit: jbuilder build] [ppx_base: jbuilder build]
-> installed ppx_custom_printf.v0.9.0
Processing 127/160: [cohttp: jbuilder build] [conduit: jbuilder build] [ppx_base: jbuilder build]
Processing 128/160: [bin_prot: jbuilder build] [cohttp: jbuilder build] [conduit: jbuilder build] [ppx_base: jbuilder build]
Processing 129/160: [bin_prot: jbuilder build] [cohttp: jbuilder build] [conduit: jbuilder build] [ppx_base: jbuilder build] [ppx_expect: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_base" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_base.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "bin/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "bin/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_base.v0.9.0
Processing 129/160: [bin_prot: jbuilder build] [cohttp: jbuilder build] [conduit: jbuilder build] [ppx_expect: jbuilder build]
-> installed ppx_base.v0.9.0
Processing 130/160: [bin_prot: jbuilder build] [cohttp: jbuilder build] [conduit: jbuilder build] [ppx_expect: jbuilder build]
Processing 131/160: [bin_prot: jbuilder build] [cohttp: jbuilder build] [conduit: jbuilder build] [configurator: jbuilder build] [ppx_expect: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "-p" "conduit" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/conduit.1.0.3)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "async/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "lwt/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "lwt-unix/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "mirage/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "tests/mirage/simple/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "async/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "lwt/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "lwt-unix/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "mirage/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "tests/mirage/simple/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  conduit.1.0.3
Processing 131/160: [bin_prot: jbuilder build] [cohttp: jbuilder build] [configurator: jbuilder build] [ppx_expect: jbuilder build]
-> installed conduit.1.0.3
Processing 132/160: [bin_prot: jbuilder build] [cohttp: jbuilder build] [configurator: jbuilder build] [ppx_expect: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "-p" "cohttp" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/cohttp.0.99.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "cohttp/scripts/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp/test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-async/bin/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-async/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-async/test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-lwt/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-lwt-jsoo/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-lwt-unix/bin/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-lwt-unix/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-lwt-unix/test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-top/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp_async_test/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp_lwt_unix_test/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp_server/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp_test/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "examples/async/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "mirage-http/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-       ocamlc cohttp/src/.cohttp.objs/byte/cohttp__Header.{cmo,cmt}
- File "cohttp/src/header.ml", line 168, characters 11-22:
- Warning 3: deprecated: module Re_emacs
- Use Re.Emacs
- File "cohttp/src/header.ml", line 174, characters 24-34:
- Warning 3: deprecated: Re.get_ofs
- Use Group.offset
-     ocamlopt cohttp/src/.cohttp.objs/native/cohttp__Header.{cmx,o}
- File "cohttp/src/header.ml", line 168, characters 11-22:
- Warning 3: deprecated: module Re_emacs
- Use Re.Emacs
- File "cohttp/src/header.ml", line 174, characters 24-34:
- Warning 3: deprecated: Re.get_ofs
- Use Group.offset
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "cohttp/scripts/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp/test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-async/bin/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-async/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-async/test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-lwt/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-lwt-jsoo/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-lwt-unix/bin/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-lwt-unix/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-lwt-unix/test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-top/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp_async_test/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp_lwt_unix_test/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp_server/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp_test/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "examples/async/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "mirage-http/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-       ocamlc cohttp/src/.cohttp.objs/byte/cohttp__Header.{cmo,cmt}
- File "cohttp/src/header.ml", line 168, characters 11-22:
- Warning 3: deprecated: module Re_emacs
- Use Re.Emacs
- File "cohttp/src/header.ml", line 174, characters 24-34:
- Warning 3: deprecated: Re.get_ofs
- Use Group.offset
-     ocamlopt cohttp/src/.cohttp.objs/native/cohttp__Header.{cmx,o}
- File "cohttp/src/header.ml", line 168, characters 11-22:
- Warning 3: deprecated: module Re_emacs
- Use Re.Emacs
- File "cohttp/src/header.ml", line 174, characters 24-34:
- Warning 3: deprecated: Re.get_ofs
- Use Group.offset
-> compiled  cohttp.0.99.0
Processing 132/160: [bin_prot: jbuilder build] [configurator: jbuilder build] [ppx_expect: jbuilder build]
-> installed cohttp.0.99.0
Processing 133/160: [bin_prot: jbuilder build] [configurator: jbuilder build] [ppx_expect: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "-p" "bin_prot" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/bin_prot.v0.9.2)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "bench/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "shape/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "xen/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "bench/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "shape/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "xen/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  bin_prot.v0.9.2
Processing 133/160: [configurator: jbuilder build] [ppx_expect: jbuilder build]
-> installed bin_prot.v0.9.2
Processing 134/160: [configurator: jbuilder build] [ppx_expect: jbuilder build]
Processing 135/160: [configurator: jbuilder build] [ppx_bin_prot: jbuilder build] [ppx_expect: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_expect" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_expect.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "collector/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "common/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "config/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "evaluator/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "example/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "expect_payload/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "matcher/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "negative-tests/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "negative-tests/disabling/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "negative-tests/disabling/lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "matcher/reconcile.ml", line 29, characters 11-23:
- Warning 3: deprecated: module Re_glob
- Use Re.Glob
- File "matcher/reconcile.ml", line 38, characters 25-36:
- Warning 3: deprecated: module Re_emacs
- Use Re.Emacs
- File "matcher/reconcile.ml", line 29, characters 11-23:
- Warning 3: deprecated: module Re_glob
- Use Re.Glob
- File "matcher/reconcile.ml", line 38, characters 25-36:
- Warning 3: deprecated: module Re_emacs
- Use Re.Emacs
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "collector/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "common/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "config/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "evaluator/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "example/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "expect_payload/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "matcher/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "negative-tests/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "negative-tests/disabling/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "negative-tests/disabling/lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "matcher/reconcile.ml", line 29, characters 11-23:
- Warning 3: deprecated: module Re_glob
- Use Re.Glob
- File "matcher/reconcile.ml", line 38, characters 25-36:
- Warning 3: deprecated: module Re_emacs
- Use Re.Emacs
- File "matcher/reconcile.ml", line 29, characters 11-23:
- Warning 3: deprecated: module Re_glob
- Use Re.Glob
- File "matcher/reconcile.ml", line 38, characters 25-36:
- Warning 3: deprecated: module Re_emacs
- Use Re.Emacs
-> compiled  ppx_expect.v0.9.0
Processing 135/160: [configurator: jbuilder build] [ppx_bin_prot: jbuilder build]
-> installed ppx_expect.v0.9.0
Processing 136/160: [configurator: jbuilder build] [ppx_bin_prot: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "-p" "configurator" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/configurator.v0.9.1)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  configurator.v0.9.1
Processing 136/160: [ppx_bin_prot: jbuilder build]
-> installed configurator.v0.9.1
Processing 137/160: [ppx_bin_prot: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_bin_prot" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_bin_prot.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "shape/example0/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "shape/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "shape/test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_bin_prot.v0.9.0
-> installed ppx_bin_prot.v0.9.0
Processing 139/160: [ppx_jane: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "--only-packages" "ppx_jane" "--root" "." "-j" "31" "--no-config" "@install" (CWD=/home/opam/.opam/4.05/.opam-switch/build/ppx_jane.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "bin/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "kernel/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  ppx_jane.v0.9.0
-> installed ppx_jane.v0.9.0
Processing 141/160: [core_kernel: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "-p" "core_kernel" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/core_kernel.v0.9.1)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "base_for_tests/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "bench-bin/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "example/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "replace_caml_modify_for_testing/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/config/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/bin/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test-build-info/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test-build-info/bin/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  core_kernel.v0.9.1
-> installed core_kernel.v0.9.1
Processing 143/160: [async_kernel: jbuilder build]
Processing 144/160: [async_kernel: jbuilder build] [core: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "-p" "async_kernel" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/async_kernel.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  async_kernel.v0.9.0
Processing 144/160: [core: jbuilder build]
-> installed async_kernel.v0.9.0
Processing 145/160: [core: jbuilder build]
Processing 146/160: [async_rpc_kernel: jbuilder build] [core: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "-p" "async_rpc_kernel" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/async_rpc_kernel.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "bench/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "bench/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  async_rpc_kernel.v0.9.0
Processing 146/160: [core: jbuilder build]
-> installed async_rpc_kernel.v0.9.0
Processing 147/160: [core: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "-p" "core" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/core.v0.9.2)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "bench/bin/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "example/command/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "example/quickcheck/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "example/unix/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/config/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/bin/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/bin/manual/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "test/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "top/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-       ocamlc src/unix_stubs.o
- unix_stubs.c: In function 'unix_mknod_stub':
- unix_stubs.c:554:13: warning: implicit declaration of function 'makedev' [-Wimplicit-function-declaration]
-   554 |       dev = makedev(Int_val(v_major), Int_val(v_minor));
-       |             ^~~~~~~
-     ocamlopt src/.core.objs/native/core__Iobuf.{cmx,o}
- File "src/iobuf.ml", line 937, characters 4-62:
- Warning 55: Cannot inline: Function information unavailable
-       ocamlc src/.core.objs/byte/core__Command.{cmo,cmt}
- File "src/command.ml", line 1497, characters 15-906:
- Warning 8: this pattern-matching is not exhaustive.
- Here is an example of a case that is not matched:
- Expand _
-     ocamlopt src/.core.objs/native/core__Command.{cmx,o}
- File "src/command.ml", line 1497, characters 15-906:
- Warning 8: this pattern-matching is not exhaustive.
- Here is an example of a case that is not matched:
- Expand _
-> compiled  core.v0.9.2
-> installed core.v0.9.2
Processing 149/160: [async_unix: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "-p" "async_unix" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/async_unix.v0.9.1)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  async_unix.v0.9.1
-> installed async_unix.v0.9.1
Processing 151/160: [async_extra: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "-p" "async_extra" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/async_extra.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  async_extra.v0.9.0
-> installed async_extra.v0.9.0
Processing 153/160: [async: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "-p" "async" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/async.v0.9.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "bench/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "example/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  async.v0.9.0
-> installed async.v0.9.0
Processing 155/160: [conduit-async: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "-p" "conduit-async" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/conduit-async.1.0.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "async/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "lib/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "lwt/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "lwt-unix/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "mirage/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-> compiled  conduit-async.1.0.0
-> installed conduit-async.1.0.0
Processing 157/160: [cohttp-async: jbuilder build]
+ /home/opam/.opam/4.05/bin/jbuilder "build" "-p" "cohttp-async" "-j" "31" (CWD=/home/opam/.opam/4.05/.opam-switch/build/cohttp-async.0.99.0)
- The jbuilder binary is deprecated and will cease to be maintained in July 2019.
- Please switch to dune instead.
- File "cohttp/scripts/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp/test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-async/bin/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-async/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-async/test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-lwt/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-lwt-jsoo/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-lwt-unix/bin/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-lwt-unix/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-lwt-unix/test/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp-top/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp_async_test/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp_lwt_unix_test/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp_server/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "cohttp_test/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "examples/async/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
- File "mirage-http/src/jbuild", line 1, characters 0-0:
- Warning: jbuild files are deprecated, please convert this file to a dune file
- instead.
- Note: You can use "dune upgrade" to convert your project to dune.
-     ocamlopt cohttp-async/bin/cohttp_server_async.exe (exit 2)
- (cd _build/default && /home/opam/.opam/4.05/bin/ocamlopt.opt -w -40 -g -o cohttp-async/bin/cohttp_server_async.exe -I /home/opam/.opam/4.05/lib/astring -I /home/opam/.opam/4.05/lib/async -I /home/opam/.opam/4.05/lib/async_extra -I /home/opam/.opam/4.05/lib/async_kernel -I /home/opam/.opam/4.05/lib/async_rpc_kernel -I /home/opam/.opam/4.05/lib/async_unix -I /home/opam/.opam/4.05/lib/base -I /home/opam/.opam/4.05/lib/base/caml -I /home/opam/.opam/4.05/lib/base/shadow_stdlib -I /home/opam/.opam/4.05/lib/base64 -I /home/opam/.opam/4.05/lib/bin_prot -I /home/opam/.opam/4.05/lib/bin_prot/shape -I /home/opam/.opam/4.05/lib/bytes -I /home/opam/.opam/4.05/lib/cohttp -I /home/opam/.opam/4.05/lib/conduit -I /home/opam/.opam/4.05/lib/conduit-async -I /home/opam/.opam/4.05/lib/core -I /home/opam/.opam/4.05/lib/core_kernel -I /home/opam/.opam/4.05/lib/core_kernel/base_for_tests -I /home/opam/.opam/4.05/lib/fieldslib -I /home/opam/.opam/4.05/lib/fmt -I /home/opam/.opam/4.05/lib/ipaddr -I /home/opam/.opam/4.05/lib/ipaddr/unix -I /home/opam/.opam/4.05/lib/jane-street-headers -I /home/opam/.opam/4.05/lib/logs -I /home/opam/.opam/4.05/lib/magic-mime -I /home/opam/.opam/4.05/lib/num -I /home/opam/.opam/4.05/lib/ocaml/threads -I /home/opam/.opam/4.05/lib/ppx_assert/runtime-lib -I /home/opam/.opam/4.05/lib/ppx_bench/runtime-lib -I /home/opam/.opam/4.05/lib/ppx_compare/runtime-lib -I /home/opam/.opam/4.05/lib/ppx_expect/collector -I /home/opam/.opam/4.05/lib/ppx_expect/common -I /home/opam/.opam/4.05/lib/ppx_expect/config -I /home/opam/.opam/4.05/lib/ppx_hash/runtime-lib -I /home/opam/.opam/4.05/lib/ppx_inline_test/config -I /home/opam/.opam/4.05/lib/ppx_inline_test/runtime-lib -I /home/opam/.opam/4.05/lib/re -I /home/opam/.opam/4.05/lib/re/emacs -I /home/opam/.opam/4.05/lib/re/posix -I /home/opam/.opam/4.05/lib/seq -I /home/opam/.opam/4.05/lib/sexplib -I /home/opam/.opam/4.05/lib/sexplib/0 -I /home/opam/.opam/4.05/lib/sexplib/unix -I /home/opam/.opam/4.05/lib/spawn -I /home/opam/.opam/4.05/lib/stdio -I /home/opam/.opam/4.05/lib/stdlib-shims -I /home/opam/.opam/4.05/lib/stringext -I /home/opam/.opam/4.05/lib/typerep -I /home/opam/.opam/4.05/lib/uri -I /home/opam/.opam/4.05/lib/uri/services -I /home/opam/.opam/4.05/lib/variantslib -I cohttp-async/src -I cohttp_server /home/opam/.opam/4.05/lib/logs/logs.cmxa /home/opam/.opam/4.05/lib/seq/seq.cmxa /home/opam/.opam/4.05/lib/stdlib-shims/stdlib_shims.cmxa /home/opam/.opam/4.05/lib/fmt/fmt.cmxa /home/opam/.opam/4.05/lib/logs/logs_fmt.cmxa /home/opam/.opam/4.05/lib/ocaml/unix.cmxa /home/opam/.opam/4.05/lib/ocaml/bigarray.cmxa /home/opam/.opam/4.05/lib/sexplib/0/sexplib0.cmxa /home/opam/.opam/4.05/lib/sexplib/sexplib.cmxa /home/opam/.opam/4.05/lib/base/caml/caml.cmxa /home/opam/.opam/4.05/lib/base/shadow_stdlib/shadow_stdlib.cmxa /home/opam/.opam/4.05/lib/base/base.cmxa /home/opam/.opam/4.05/lib/fieldslib/fieldslib.cmxa /home/opam/.opam/4.05/lib/ppx_inline_test/config/inline_test_config.cmxa /home/opam/.opam/4.05/lib/ppx_inline_test/runtime-lib/ppx_inline_test_lib.cmxa /home/opam/.opam/4.05/lib/ppx_compare/runtime-lib/ppx_compare_lib.cmxa /home/opam/.opam/4.05/lib/ppx_expect/common/expect_test_common.cmxa /home/opam/.opam/4.05/lib/ppx_expect/config/expect_test_config.cmxa /home/opam/.opam/4.05/lib/ppx_expect/collector/expect_test_collector.cmxa /home/opam/.opam/4.05/lib/variantslib/variantslib.cmxa /home/opam/.opam/4.05/lib/typerep/typerep_lib.cmxa /home/opam/.opam/4.05/lib/bin_prot/shape/bin_shape_lib.cmxa /home/opam/.opam/4.05/lib/bin_prot/bin_prot.cmxa /home/opam/.opam/4.05/lib/ppx_bench/runtime-lib/ppx_bench_lib.cmxa /home/opam/.opam/4.05/lib/ppx_assert/runtime-lib/ppx_assert_lib.cmxa /home/opam/.opam/4.05/lib/ppx_hash/runtime-lib/ppx_hash_lib.cmxa /home/opam/.opam/4.05/lib/core_kernel/base_for_tests/base_for_tests.cmxa /home/opam/.opam/4.05/lib/stdio/stdio.cmxa /home/opam/.opam/4.05/lib/jane-street-headers/jane_street_headers.cmxa /home/opam/.opam/4.05/lib/ocaml/nums.cmxa /home/opam/.opam/4.05/lib/core_kernel/core_kernel.cmxa /home/opam/.opam/4.05/lib/async_kernel/async_kernel.cmxa /home/opam/.opam/4.05/lib/async_rpc_kernel/async_rpc_kernel.cmxa /home/opam/.opam/4.05/lib/sexplib/unix/sexplib_unix.cmxa /home/opam/.opam/4.05/lib/spawn/spawn.cmxa /home/opam/.opam/4.05/lib/ocaml/threads/threads.cmxa /home/opam/.opam/4.05/lib/core/core.cmxa /home/opam/.opam/4.05/lib/async_unix/async_unix.cmxa /home/opam/.opam/4.05/lib/async_extra/async_extra.cmxa /home/opam/.opam/4.05/lib/async/async.cmxa /home/opam/.opam/4.05/lib/re/re.cmxa /home/opam/.opam/4.05/lib/re/posix/re_posix.cmxa /home/opam/.opam/4.05/lib/stringext/stringext.cmxa /home/opam/.opam/4.05/lib/uri/uri.cmxa /home/opam/.opam/4.05/lib/uri/services/uri_services.cmxa /home/opam/.opam/4.05/lib/ipaddr/ipaddr.cmxa /home/opam/.opam/4.05/lib/ipaddr/unix/ipaddr_unix.cmxa /home/opam/.opam/4.05/lib/astring/astring.cmxa /home/opam/.opam/4.05/lib/conduit/conduit.cmxa /home/opam/.opam/4.05/lib/conduit-async/conduit_async.cmxa /home/opam/.opam/4.05/lib/magic-mime/magic_mime_library.cmxa /home/opam/.opam/4.05/lib/base64/base64.cmxa /home/opam/.opam/4.05/lib/re/emacs/re_emacs.cmxa /home/opam/.opam/4.05/lib/cohttp/cohttp.cmxa cohttp-async/src/cohttp_async.cmxa cohttp_server/cohttp_server.cmxa /home/opam/.opam/4.05/lib/fmt/fmt_tty.cmxa cohttp-async/bin/.cohttp_curl_async.eobjs/native/cohttp_server_async.cmx)
- /usr/bin/ld: /home/opam/.opam/4.05/lib/core/libcore_stubs.a(unix_stubs.o): in function `unix_mknod_stub':
- /home/opam/.opam/4.05/.opam-switch/build/core.v0.9.2/_build/default/src/unix_stubs.c:558: undefined reference to `makedev'
- collect2: error: ld returned 1 exit status
- File "caml_startup", line 1:
- Error: Error during linking
-     ocamlopt cohttp-async/bin/cohttp_curl_async.exe (exit 2)
- (cd _build/default && /home/opam/.opam/4.05/bin/ocamlopt.opt -w -40 -g -o cohttp-async/bin/cohttp_curl_async.exe -I /home/opam/.opam/4.05/lib/astring -I /home/opam/.opam/4.05/lib/async -I /home/opam/.opam/4.05/lib/async_extra -I /home/opam/.opam/4.05/lib/async_kernel -I /home/opam/.opam/4.05/lib/async_rpc_kernel -I /home/opam/.opam/4.05/lib/async_unix -I /home/opam/.opam/4.05/lib/base -I /home/opam/.opam/4.05/lib/base/caml -I /home/opam/.opam/4.05/lib/base/shadow_stdlib -I /home/opam/.opam/4.05/lib/base64 -I /home/opam/.opam/4.05/lib/bin_prot -I /home/opam/.opam/4.05/lib/bin_prot/shape -I /home/opam/.opam/4.05/lib/bytes -I /home/opam/.opam/4.05/lib/cohttp -I /home/opam/.opam/4.05/lib/conduit -I /home/opam/.opam/4.05/lib/conduit-async -I /home/opam/.opam/4.05/lib/core -I /home/opam/.opam/4.05/lib/core_kernel -I /home/opam/.opam/4.05/lib/core_kernel/base_for_tests -I /home/opam/.opam/4.05/lib/fieldslib -I /home/opam/.opam/4.05/lib/fmt -I /home/opam/.opam/4.05/lib/ipaddr -I /home/opam/.opam/4.05/lib/ipaddr/unix -I /home/opam/.opam/4.05/lib/jane-street-headers -I /home/opam/.opam/4.05/lib/logs -I /home/opam/.opam/4.05/lib/magic-mime -I /home/opam/.opam/4.05/lib/num -I /home/opam/.opam/4.05/lib/ocaml/threads -I /home/opam/.opam/4.05/lib/ppx_assert/runtime-lib -I /home/opam/.opam/4.05/lib/ppx_bench/runtime-lib -I /home/opam/.opam/4.05/lib/ppx_compare/runtime-lib -I /home/opam/.opam/4.05/lib/ppx_expect/collector -I /home/opam/.opam/4.05/lib/ppx_expect/common -I /home/opam/.opam/4.05/lib/ppx_expect/config -I /home/opam/.opam/4.05/lib/ppx_hash/runtime-lib -I /home/opam/.opam/4.05/lib/ppx_inline_test/config -I /home/opam/.opam/4.05/lib/ppx_inline_test/runtime-lib -I /home/opam/.opam/4.05/lib/re -I /home/opam/.opam/4.05/lib/re/emacs -I /home/opam/.opam/4.05/lib/re/posix -I /home/opam/.opam/4.05/lib/seq -I /home/opam/.opam/4.05/lib/sexplib -I /home/opam/.opam/4.05/lib/sexplib/0 -I /home/opam/.opam/4.05/lib/sexplib/unix -I /home/opam/.opam/4.05/lib/spawn -I /home/opam/.opam/4.05/lib/stdio -I /home/opam/.opam/4.05/lib/stdlib-shims -I /home/opam/.opam/4.05/lib/stringext -I /home/opam/.opam/4.05/lib/typerep -I /home/opam/.opam/4.05/lib/uri -I /home/opam/.opam/4.05/lib/uri/services -I /home/opam/.opam/4.05/lib/variantslib -I cohttp-async/src -I cohttp_server /home/opam/.opam/4.05/lib/logs/logs.cmxa /home/opam/.opam/4.05/lib/seq/seq.cmxa /home/opam/.opam/4.05/lib/stdlib-shims/stdlib_shims.cmxa /home/opam/.opam/4.05/lib/fmt/fmt.cmxa /home/opam/.opam/4.05/lib/logs/logs_fmt.cmxa /home/opam/.opam/4.05/lib/ocaml/unix.cmxa /home/opam/.opam/4.05/lib/ocaml/bigarray.cmxa /home/opam/.opam/4.05/lib/sexplib/0/sexplib0.cmxa /home/opam/.opam/4.05/lib/sexplib/sexplib.cmxa /home/opam/.opam/4.05/lib/base/caml/caml.cmxa /home/opam/.opam/4.05/lib/base/shadow_stdlib/shadow_stdlib.cmxa /home/opam/.opam/4.05/lib/base/base.cmxa /home/opam/.opam/4.05/lib/fieldslib/fieldslib.cmxa /home/opam/.opam/4.05/lib/ppx_inline_test/config/inline_test_config.cmxa /home/opam/.opam/4.05/lib/ppx_inline_test/runtime-lib/ppx_inline_test_lib.cmxa /home/opam/.opam/4.05/lib/ppx_compare/runtime-lib/ppx_compare_lib.cmxa /home/opam/.opam/4.05/lib/ppx_expect/common/expect_test_common.cmxa /home/opam/.opam/4.05/lib/ppx_expect/config/expect_test_config.cmxa /home/opam/.opam/4.05/lib/ppx_expect/collector/expect_test_collector.cmxa /home/opam/.opam/4.05/lib/variantslib/variantslib.cmxa /home/opam/.opam/4.05/lib/typerep/typerep_lib.cmxa /home/opam/.opam/4.05/lib/bin_prot/shape/bin_shape_lib.cmxa /home/opam/.opam/4.05/lib/bin_prot/bin_prot.cmxa /home/opam/.opam/4.05/lib/ppx_bench/runtime-lib/ppx_bench_lib.cmxa /home/opam/.opam/4.05/lib/ppx_assert/runtime-lib/ppx_assert_lib.cmxa /home/opam/.opam/4.05/lib/ppx_hash/runtime-lib/ppx_hash_lib.cmxa /home/opam/.opam/4.05/lib/core_kernel/base_for_tests/base_for_tests.cmxa /home/opam/.opam/4.05/lib/stdio/stdio.cmxa /home/opam/.opam/4.05/lib/jane-street-headers/jane_street_headers.cmxa /home/opam/.opam/4.05/lib/ocaml/nums.cmxa /home/opam/.opam/4.05/lib/core_kernel/core_kernel.cmxa /home/opam/.opam/4.05/lib/async_kernel/async_kernel.cmxa /home/opam/.opam/4.05/lib/async_rpc_kernel/async_rpc_kernel.cmxa /home/opam/.opam/4.05/lib/sexplib/unix/sexplib_unix.cmxa /home/opam/.opam/4.05/lib/spawn/spawn.cmxa /home/opam/.opam/4.05/lib/ocaml/threads/threads.cmxa /home/opam/.opam/4.05/lib/core/core.cmxa /home/opam/.opam/4.05/lib/async_unix/async_unix.cmxa /home/opam/.opam/4.05/lib/async_extra/async_extra.cmxa /home/opam/.opam/4.05/lib/async/async.cmxa /home/opam/.opam/4.05/lib/re/re.cmxa /home/opam/.opam/4.05/lib/re/posix/re_posix.cmxa /home/opam/.opam/4.05/lib/stringext/stringext.cmxa /home/opam/.opam/4.05/lib/uri/uri.cmxa /home/opam/.opam/4.05/lib/uri/services/uri_services.cmxa /home/opam/.opam/4.05/lib/ipaddr/ipaddr.cmxa /home/opam/.opam/4.05/lib/ipaddr/unix/ipaddr_unix.cmxa /home/opam/.opam/4.05/lib/astring/astring.cmxa /home/opam/.opam/4.05/lib/conduit/conduit.cmxa /home/opam/.opam/4.05/lib/conduit-async/conduit_async.cmxa /home/opam/.opam/4.05/lib/magic-mime/magic_mime_library.cmxa /home/opam/.opam/4.05/lib/base64/base64.cmxa /home/opam/.opam/4.05/lib/re/emacs/re_emacs.cmxa /home/opam/.opam/4.05/lib/cohttp/cohttp.cmxa cohttp-async/src/cohttp_async.cmxa cohttp_server/cohttp_server.cmxa /home/opam/.opam/4.05/lib/fmt/fmt_tty.cmxa cohttp-async/bin/.cohttp_curl_async.eobjs/native/cohttp_curl_async.cmx)
- /usr/bin/ld: /home/opam/.opam/4.05/lib/core/libcore_stubs.a(unix_stubs.o): in function `unix_mknod_stub':
- /home/opam/.opam/4.05/.opam-switch/build/core.v0.9.2/_build/default/src/unix_stubs.c:558: undefined reference to `makedev'
- collect2: error: ld returned 1 exit status
- File "caml_startup", line 1:
- Error: Error during linking
[ERROR] The compilation of cohttp-async failed at "/home/opam/.opam/4.05/bin/jbuilder build -p cohttp-async -j 31".

#=== ERROR while compiling cohttp-async.0.99.0 ================================#
# context              2.0.10 | linux/x86_64 | ocaml-base-compiler.4.05.0 | file:///src
# path                 ~/.opam/4.05/.opam-switch/build/cohttp-async.0.99.0
# command              ~/.opam/4.05/bin/jbuilder build -p cohttp-async -j 31
# exit-code            1
# env-file             ~/.opam/log/cohttp-async-262-b20783.env
# output-file          ~/.opam/log/cohttp-async-262-b20783.out
### output ###
# The jbuilder binary is deprecated and will cease to be maintained in July 2019.
# Please switch to dune instead.
# File "cohttp/scripts/jbuild", line 1, characters 0-0:
# Warning: jbuild files are deprecated, please convert this file to a dune file
# instead.
# Note: You can use "dune upgrade" to convert your project to dune.
# File "cohttp/src/jbuild", line 1, characters 0-0:
# Warning: jbuild files are deprecated, please convert this file to a dune file
# instead.
# Note: You can use "dune upgrade" to convert your project to dune.
# File "cohttp/test/jbuild", line 1, characters 0-0:
# Warning: jbuild files are deprecated, please convert this file to a dune file
# instead.
# Note: You can use "dune upgrade" to convert your project to dune.
# File "cohttp-async/bin/jbuild", line 1, characters 0-0:
# Warning: jbuild files are deprecated, please convert this file to a dune file
# instead.
# Note: You can use "dune upgrade" to convert your project to dune.
# File "cohttp-async/src/jbuild", line 1, characters 0-0:
# Warning: jbuild files are deprecated, please convert this file to a dune file
# instead.
# Note: You can use "dune upgrade" to convert your project to dune.
# File "cohttp-async/test/jbuild", line 1, characters 0-0:
# Warning: jbuild files are deprecated, please convert this file to a dune file
# instead.
# Note: You can use "dune upgrade" to convert your project to dune.
# File "cohttp-lwt/src/jbuild", line 1, characters 0-0:
# Warning: jbuild files are deprecated, please convert this file to a dune file
# instead.
# Note: You can use "dune upgrade" to convert your project to dune.
# File "cohttp-lwt-jsoo/src/jbuild", line 1, characters 0-0:
# Warning: jbuild files are deprecated, please convert this file to a dune file
# instead.
# Note: You can use "dune upgrade" to convert your project to dune.
# File "cohttp-lwt-unix/bin/jbuild", line 1, characters 0-0:
# Warning: jbuild files are deprecated, please convert this file to a dune file
# instead.
# Note: You can use "dune upgrade" to convert your project to dune.
# File "cohttp-lwt-unix/src/jbuild", line 1, characters 0-0:
# Warning: jbuild files are deprecated, please convert this file to a dune file
# instead.
# Note: You can use "dune upgrade" to convert your project to dune.
# File "cohttp-lwt-unix/test/jbuild", line 1, characters 0-0:
# Warning: jbuild files are deprecated, please convert this file to a dune file
# instead.
# Note: You can use "dune upgrade" to convert your project to dune.
# File "cohttp-top/src/jbuild", line 1, characters 0-0:
# Warning: jbuild files are deprecated, please convert this file to a dune file
# instead.
# Note: You can use "dune upgrade" to convert your project to dune.
# File "cohttp_async_test/src/jbuild", line 1, characters 0-0:
# Warning: jbuild files are deprecated, please convert this file to a dune file
# instead.
# Note: You can use "dune upgrade" to convert your project to dune.
# File "cohttp_lwt_unix_test/src/jbuild", line 1, characters 0-0:
# Warning: jbuild files are deprecated, please convert this file to a dune file
# instead.
# Note: You can use "dune upgrade" to convert your project to dune.
# File "cohttp_server/jbuild", line 1, characters 0-0:
# Warning: jbuild files are deprecated, please convert this file to a dune file
# instead.
# Note: You can use "dune upgrade" to convert your project to dune.
# File "cohttp_test/src/jbuild", line 1, characters 0-0:
# Warning: jbuild files are deprecated, please convert this file to a dune file
# instead.
# Note: You can use "dune upgrade" to convert your project to dune.
# File "examples/async/jbuild", line 1, characters 0-0:
# Warning: jbuild files are deprecated, please convert this file to a dune file
# instead.
# Note: You can use "dune upgrade" to convert your project to dune.
# File "mirage-http/src/jbuild", line 1, characters 0-0:
# Warning: jbuild files are deprecated, please convert this file to a dune file
# instead.
# Note: You can use "dune upgrade" to convert your project to dune.
#     ocamlopt cohttp-async/bin/cohttp_server_async.exe (exit 2)
# (cd _build/default && /home/opam/.opam/4.05/bin/ocamlopt.opt -w -40 -g -o cohttp-async/bin/cohttp_server_async.exe -I /home/opam/.opam/4.05/lib/astring -I /home/opam/.opam/4.05/lib/async -I /home/opam/.opam/4.05/lib/async_extra -I /home/opam/.opam/4.05/lib/async_kernel -I /home/opam/.opam/4.05/lib/async_rpc_kernel -I /home/opam/.opam/4.05/lib/async_unix -I /home/opam/.opam/4.05/lib/base -I /home/opam/.opam/4.05/lib/base/caml -I /home/opam/.opam/4.05/lib/base/shadow_stdlib -I /home/opam/.opam/4.05/lib/base64 -I /home/opam/.opam/4.05/lib/bin_prot -I /home/opam/.opam/4.05/lib/bin_prot/shape -I /home/opam/.opam/4.05/lib/bytes -I /home/opam/.opam/4.05/lib/cohttp -I /home/opam/.opam/4.05/lib/conduit -I /home/opam/.opam/4.05/lib/conduit-async -I /home/opam/.opam/4.05/lib/core -I /home/opam/.opam/4.05/lib/core_kernel -I /home/opam/.opam/4.05/lib/core_kernel/base_for_tests -I /home/opam/.opam/4.05/lib/fieldslib -I /home/opam/.opam/4.05/lib/fmt -I /home/opam/.opam/4.05/lib/ipaddr -I /home/opam/.opam/4.05/lib/ipaddr/unix -I /home/opam/.opam/4.05/lib/jane-street-headers -I /home/opam/.opam/4.05/lib/logs -I /home/opam/.opam/4.05/lib/magic-mime -I /home/opam/.opam/4.05/lib/num -I /home/opam/.opam/4.05/lib/ocaml/threads -I /home/opam/.opam/4.05/lib/ppx_assert/runtime-lib -I /home/opam/.opam/4.05/lib/ppx_bench/runtime-lib -I /home/opam/.opam/4.05/lib/ppx_compare/runtime-lib -I /home/opam/.opam/4.05/lib/ppx_expect/collector -I /home/opam/.opam/4.05/lib/ppx_expect/common -I /home/opam/.opam/4.05/lib/ppx_expect/config -I /home/opam/.opam/4.05/lib/ppx_hash/runtime-lib -I /home/opam/.opam/4.05/lib/ppx_inline_test/config -I /home/opam/.opam/4.05/lib/ppx_inline_test/runtime-lib -I /home/opam/.opam/4.05/lib/re -I /home/opam/.opam/4.05/lib/re/emacs -I /home/opam/.opam/4.05/lib/re/posix -I /home/opam/.opam/4.05/lib/seq -I /home/opam/.opam/4.05/lib/sexplib -I /home/opam/.opam/4.05/lib/sexplib/0 -I /home/opam/.opam/4.05/lib/sexplib/unix -I /home/opam/.opam/4.05/lib/spawn -I /home/opam/.opam/4.05/lib/stdio -I /home/opam/.opam/4.05/lib/stdlib-shims -I /home/opam/.opam/4.05/lib/stringext -I /home/opam/.opam/4.05/lib/typerep -I /home/opam/.opam/4.05/lib/uri -I /home/opam/.opam/4.05/lib/uri/services -I /home/opam/.opam/4.05/lib/variantslib -I cohttp-async/src -I cohttp_server /home/opam/.opam/4.05/lib/logs/logs.cmxa /home/opam/.opam/4.05/lib/seq/seq.cmxa /home/opam/.opam/4.05/lib/stdlib-shims/stdlib_shims.cmxa /home/opam/.opam/4.05/lib/fmt/fmt.cmxa /home/opam/.opam/4.05/lib/logs/logs_fmt.cmxa /home/opam/.opam/4.05/lib/ocaml/unix.cmxa /home/opam/.opam/4.05/lib/ocaml/bigarray.cmxa /home/opam/.opam/4.05/lib/sexplib/0/sexplib0.cmxa /home/opam/.opam/4.05/lib/sexplib/sexplib.cmxa /home/opam/.opam/4.05/lib/base/caml/caml.cmxa /home/opam/.opam/4.05/lib/base/shadow_stdlib/shadow_stdlib.cmxa /home/opam/.opam/4.05/lib/base/base.cmxa /home/opam/.opam/4.05/lib/fieldslib/fieldslib.cmxa /home/opam/.opam/4.05/lib/ppx_inline_test/config/inline_test_config.cmxa /home/opam/.opam/4.05/lib/ppx_inline_test/runtime-lib/ppx_inline_test_lib.cmxa /home/opam/.opam/4.05/lib/ppx_compare/runtime-lib/ppx_compare_lib.cmxa /home/opam/.opam/4.05/lib/ppx_expect/common/expect_test_common.cmxa /home/opam/.opam/4.05/lib/ppx_expect/config/expect_test_config.cmxa /home/opam/.opam/4.05/lib/ppx_expect/collector/expect_test_collector.cmxa /home/opam/.opam/4.05/lib/variantslib/variantslib.cmxa /home/opam/.opam/4.05/lib/typerep/typerep_lib.cmxa /home/opam/.opam/4.05/lib/bin_prot/shape/bin_shape_lib.cmxa /home/opam/.opam/4.05/lib/bin_prot/bin_prot.cmxa /home/opam/.opam/4.05/lib/ppx_bench/runtime-lib/ppx_bench_lib.cmxa /home/opam/.opam/4.05/lib/ppx_assert/runtime-lib/ppx_assert_lib.cmxa /home/opam/.opam/4.05/lib/ppx_hash/runtime-lib/ppx_hash_lib.cmxa /home/opam/.opam/4.05/lib/core_kernel/base_for_tests/base_for_tests.cmxa /home/opam/.opam/4.05/lib/stdio/stdio.cmxa /home/opam/.opam/4.05/lib/jane-street-headers/jane_street_headers.cmxa /home/opam/.opam/4.05/lib/ocaml/nums.cmxa /home/opam/.opam/4.05/lib/core_kernel/core_kernel.cmxa /home/opam/.opam/4.05/lib/async_kernel/async_kernel.cmxa /home/opam/.opam/4.05/lib/async_rpc_kernel/async_rpc_kernel.cmxa /home/opam/.opam/4.05/lib/sexplib/unix/sexplib_unix.cmxa /home/opam/.opam/4.05/lib/spawn/spawn.cmxa /home/opam/.opam/4.05/lib/ocaml/threads/threads.cmxa /home/opam/.opam/4.05/lib/core/core.cmxa /home/opam/.opam/4.05/lib/async_unix/async_unix.cmxa /home/opam/.opam/4.05/lib/async_extra/async_extra.cmxa /home/opam/.opam/4.05/lib/async/async.cmxa /home/opam/.opam/4.05/lib/re/re.cmxa /home/opam/.opam/4.05/lib/re/posix/re_posix.cmxa /home/opam/.opam/4.05/lib/stringext/stringext.cmxa /home/opam/.opam/4.05/lib/uri/uri.cmxa /home/opam/.opam/4.05/lib/uri/services/uri_services.cmxa /home/opam/.opam/4.05/lib/ipaddr/ipaddr.cmxa /home/opam/.opam/4.05/lib/ipaddr/unix/ipaddr_unix.cmxa /home/opam/.opam/4.05/lib/astring/astring.cmxa /home/opam/.opam/4.05/lib/conduit/conduit.cmxa /home/opam/.opam/4.05/lib/conduit-async/conduit_async.cmxa /home/opam/.opam/4.05/lib/magic-mime/magic_mime_library.cmxa /home/opam/.opam/4.05/lib/base64/base64.cmxa /home/opam/.opam/4.05/lib/re/emacs/re_emacs.cmxa /home/opam/.opam/4.05/lib/cohttp/cohttp.cmxa cohttp-async/src/cohttp_async.cmxa cohttp_server/cohttp_server.cmxa /home/opam/.opam/4.05/lib/fmt/fmt_tty.cmxa cohttp-async/bin/.cohttp_curl_async.eobjs/native/cohttp_server_async.cmx)
# /usr/bin/ld: /home/opam/.opam/4.05/lib/core/libcore_stubs.a(unix_stubs.o): in function `unix_mknod_stub':
# /home/opam/.opam/4.05/.opam-switch/build/core.v0.9.2/_build/default/src/unix_stubs.c:558: undefined reference to `makedev'
# collect2: error: ld returned 1 exit status
# File "caml_startup", line 1:
# Error: Error during linking
#     ocamlopt cohttp-async/bin/cohttp_curl_async.exe (exit 2)
# (cd _build/default && /home/opam/.opam/4.05/bin/ocamlopt.opt -w -40 -g -o cohttp-async/bin/cohttp_curl_async.exe -I /home/opam/.opam/4.05/lib/astring -I /home/opam/.opam/4.05/lib/async -I /home/opam/.opam/4.05/lib/async_extra -I /home/opam/.opam/4.05/lib/async_kernel -I /home/opam/.opam/4.05/lib/async_rpc_kernel -I /home/opam/.opam/4.05/lib/async_unix -I /home/opam/.opam/4.05/lib/base -I /home/opam/.opam/4.05/lib/base/caml -I /home/opam/.opam/4.05/lib/base/shadow_stdlib -I /home/opam/.opam/4.05/lib/base64 -I /home/opam/.opam/4.05/lib/bin_prot -I /home/opam/.opam/4.05/lib/bin_prot/shape -I /home/opam/.opam/4.05/lib/bytes -I /home/opam/.opam/4.05/lib/cohttp -I /home/opam/.opam/4.05/lib/conduit -I /home/opam/.opam/4.05/lib/conduit-async -I /home/opam/.opam/4.05/lib/core -I /home/opam/.opam/4.05/lib/core_kernel -I /home/opam/.opam/4.05/lib/core_kernel/base_for_tests -I /home/opam/.opam/4.05/lib/fieldslib -I /home/opam/.opam/4.05/lib/fmt -I /home/opam/.opam/4.05/lib/ipaddr -I /home/opam/.opam/4.05/lib/ipaddr/unix -I /home/opam/.opam/4.05/lib/jane-street-headers -I /home/opam/.opam/4.05/lib/logs -I /home/opam/.opam/4.05/lib/magic-mime -I /home/opam/.opam/4.05/lib/num -I /home/opam/.opam/4.05/lib/ocaml/threads -I /home/opam/.opam/4.05/lib/ppx_assert/runtime-lib -I /home/opam/.opam/4.05/lib/ppx_bench/runtime-lib -I /home/opam/.opam/4.05/lib/ppx_compare/runtime-lib -I /home/opam/.opam/4.05/lib/ppx_expect/collector -I /home/opam/.opam/4.05/lib/ppx_expect/common -I /home/opam/.opam/4.05/lib/ppx_expect/config -I /home/opam/.opam/4.05/lib/ppx_hash/runtime-lib -I /home/opam/.opam/4.05/lib/ppx_inline_test/config -I /home/opam/.opam/4.05/lib/ppx_inline_test/runtime-lib -I /home/opam/.opam/4.05/lib/re -I /home/opam/.opam/4.05/lib/re/emacs -I /home/opam/.opam/4.05/lib/re/posix -I /home/opam/.opam/4.05/lib/seq -I /home/opam/.opam/4.05/lib/sexplib -I /home/opam/.opam/4.05/lib/sexplib/0 -I /home/opam/.opam/4.05/lib/sexplib/unix -I /home/opam/.opam/4.05/lib/spawn -I /home/opam/.opam/4.05/lib/stdio -I /home/opam/.opam/4.05/lib/stdlib-shims -I /home/opam/.opam/4.05/lib/stringext -I /home/opam/.opam/4.05/lib/typerep -I /home/opam/.opam/4.05/lib/uri -I /home/opam/.opam/4.05/lib/uri/services -I /home/opam/.opam/4.05/lib/variantslib -I cohttp-async/src -I cohttp_server /home/opam/.opam/4.05/lib/logs/logs.cmxa /home/opam/.opam/4.05/lib/seq/seq.cmxa /home/opam/.opam/4.05/lib/stdlib-shims/stdlib_shims.cmxa /home/opam/.opam/4.05/lib/fmt/fmt.cmxa /home/opam/.opam/4.05/lib/logs/logs_fmt.cmxa /home/opam/.opam/4.05/lib/ocaml/unix.cmxa /home/opam/.opam/4.05/lib/ocaml/bigarray.cmxa /home/opam/.opam/4.05/lib/sexplib/0/sexplib0.cmxa /home/opam/.opam/4.05/lib/sexplib/sexplib.cmxa /home/opam/.opam/4.05/lib/base/caml/caml.cmxa /home/opam/.opam/4.05/lib/base/shadow_stdlib/shadow_stdlib.cmxa /home/opam/.opam/4.05/lib/base/base.cmxa /home/opam/.opam/4.05/lib/fieldslib/fieldslib.cmxa /home/opam/.opam/4.05/lib/ppx_inline_test/config/inline_test_config.cmxa /home/opam/.opam/4.05/lib/ppx_inline_test/runtime-lib/ppx_inline_test_lib.cmxa /home/opam/.opam/4.05/lib/ppx_compare/runtime-lib/ppx_compare_lib.cmxa /home/opam/.opam/4.05/lib/ppx_expect/common/expect_test_common.cmxa /home/opam/.opam/4.05/lib/ppx_expect/config/expect_test_config.cmxa /home/opam/.opam/4.05/lib/ppx_expect/collector/expect_test_collector.cmxa /home/opam/.opam/4.05/lib/variantslib/variantslib.cmxa /home/opam/.opam/4.05/lib/typerep/typerep_lib.cmxa /home/opam/.opam/4.05/lib/bin_prot/shape/bin_shape_lib.cmxa /home/opam/.opam/4.05/lib/bin_prot/bin_prot.cmxa /home/opam/.opam/4.05/lib/ppx_bench/runtime-lib/ppx_bench_lib.cmxa /home/opam/.opam/4.05/lib/ppx_assert/runtime-lib/ppx_assert_lib.cmxa /home/opam/.opam/4.05/lib/ppx_hash/runtime-lib/ppx_hash_lib.cmxa /home/opam/.opam/4.05/lib/core_kernel/base_for_tests/base_for_tests.cmxa /home/opam/.opam/4.05/lib/stdio/stdio.cmxa /home/opam/.opam/4.05/lib/jane-street-headers/jane_street_headers.cmxa /home/opam/.opam/4.05/lib/ocaml/nums.cmxa /home/opam/.opam/4.05/lib/core_kernel/core_kernel.cmxa /home/opam/.opam/4.05/lib/async_kernel/async_kernel.cmxa /home/opam/.opam/4.05/lib/async_rpc_kernel/async_rpc_kernel.cmxa /home/opam/.opam/4.05/lib/sexplib/unix/sexplib_unix.cmxa /home/opam/.opam/4.05/lib/spawn/spawn.cmxa /home/opam/.opam/4.05/lib/ocaml/threads/threads.cmxa /home/opam/.opam/4.05/lib/core/core.cmxa /home/opam/.opam/4.05/lib/async_unix/async_unix.cmxa /home/opam/.opam/4.05/lib/async_extra/async_extra.cmxa /home/opam/.opam/4.05/lib/async/async.cmxa /home/opam/.opam/4.05/lib/re/re.cmxa /home/opam/.opam/4.05/lib/re/posix/re_posix.cmxa /home/opam/.opam/4.05/lib/stringext/stringext.cmxa /home/opam/.opam/4.05/lib/uri/uri.cmxa /home/opam/.opam/4.05/lib/uri/services/uri_services.cmxa /home/opam/.opam/4.05/lib/ipaddr/ipaddr.cmxa /home/opam/.opam/4.05/lib/ipaddr/unix/ipaddr_unix.cmxa /home/opam/.opam/4.05/lib/astring/astring.cmxa /home/opam/.opam/4.05/lib/conduit/conduit.cmxa /home/opam/.opam/4.05/lib/conduit-async/conduit_async.cmxa /home/opam/.opam/4.05/lib/magic-mime/magic_mime_library.cmxa /home/opam/.opam/4.05/lib/base64/base64.cmxa /home/opam/.opam/4.05/lib/re/emacs/re_emacs.cmxa /home/opam/.opam/4.05/lib/cohttp/cohttp.cmxa cohttp-async/src/cohttp_async.cmxa cohttp_server/cohttp_server.cmxa /home/opam/.opam/4.05/lib/fmt/fmt_tty.cmxa cohttp-async/bin/.cohttp_curl_async.eobjs/native/cohttp_curl_async.cmx)
# /usr/bin/ld: /home/opam/.opam/4.05/lib/core/libcore_stubs.a(unix_stubs.o): in function `unix_mknod_stub':
# /home/opam/.opam/4.05/.opam-switch/build/core.v0.9.2/_build/default/src/unix_stubs.c:558: undefined reference to `makedev'
# collect2: error: ld returned 1 exit status
# File "caml_startup", line 1:
# Error: Error during linking



<><> Error report <><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><>
+- The following actions were aborted
| - install horned_worm 0.3.1
+- 
+- The following actions failed
| - build cohttp-async 0.99.0
+- 
+- The following changes have been performed (the rest was aborted)
| - install astring                 0.8.5
| - install async                   v0.9.0
| - install async_extra             v0.9.0
| - install async_kernel            v0.9.0
| - install async_rpc_kernel        v0.9.0
| - install async_unix              v0.9.1
| - install base                    v0.9.4
| - install base-bytes              base
| - install base-num                base
| - install base64                  2.3.0
| - install bin_prot                v0.9.2
| - install cohttp                  0.99.0
| - install conduit                 1.0.3
| - install conduit-async           1.0.0
| - install configurator            v0.9.1
| - install core                    v0.9.2
| - install core_kernel             v0.9.1
| - install cppo                    1.6.9
| - install fieldslib               v0.9.0
| - install fmt                     0.8.9
| - install ipaddr                  2.9.0
| - install jane-street-headers     v0.9.0
| - install jbuilder                transition
| - install jsonm                   1.0.1
| - install logs                    0.7.0
| - install magic-mime              1.2.0
| - install num                     0
| - install ocaml-compiler-libs     v0.9.0
| - install ocaml-migrate-parsetree 1.8.0
| - install ocamlbuild              0.14.1
| - install octavius                1.2.2
| - install ppx_assert              v0.9.0
| - install ppx_ast                 v0.9.1
| - install ppx_base                v0.9.0
| - install ppx_bench               v0.9.1
| - install ppx_bin_prot            v0.9.0
| - install ppx_compare             v0.9.0
| - install ppx_core                v0.9.3
| - install ppx_custom_printf       v0.9.0
| - install ppx_derivers            1.2.1
| - install ppx_driver              v0.9.2
| - install ppx_enumerate           v0.9.0
| - install ppx_expect              v0.9.0
| - install ppx_fail                v0.9.0
| - install ppx_fields_conv         v0.9.0
| - install ppx_hash                v0.9.0
| - install ppx_here                v0.9.1
| - install ppx_inline_test         v0.9.2
| - install ppx_jane                v0.9.0
| - install ppx_js_style            v0.9.0
| - install ppx_let                 v0.9.0
| - install ppx_metaquot            v0.9.0
| - install ppx_optcomp             v0.9.0
| - install ppx_optional            v0.9.0
| - install ppx_pipebang            v0.9.0
| - install ppx_sexp_conv           v0.9.0
| - install ppx_sexp_message        v0.9.0
| - install ppx_sexp_value          v0.9.0
| - install ppx_traverse            v0.9.0
| - install ppx_traverse_builtins   v0.9.0
| - install ppx_type_conv           v0.9.1
| - install ppx_typerep_conv        v0.9.0
| - install ppx_variants_conv       v0.9.0
| - install re                      1.9.0
| - install result                  1.5
| - install seq                     0.2.2
| - install sexplib                 v0.9.3
| - install spawn                   v0.9.0
| - install stdio                   v0.9.1
| - install stdlib-shims            0.3.0
| - install stringext               1.6.0
| - install topkg                   1.0.5
| - install typerep                 v0.9.0
| - install uchar                   0.0.2
| - install uri                     1.9.7
| - install uutf                    1.0.3
| - install variantslib             v0.9.0
| - install yojson                  2.0.0
+- 

<><> jbuilder.transition installed successfully <><><><><><><><><><><><><><><><>
=> Jbuilder has been renamed and the jbuilder package is now a transition package. Use the dune package instead.

<><> configurator.v0.9.1 installed successfully <><><><><><><><><><><><><><><><>
=> configurator is deprecated. Please use dune-configurator in new code and consider switching to it in existing projects.
# Run eval $(opam env) to update the current shell environment

The former state can be restored with:
    opam switch import "/home/opam/.opam/4.05/.opam-switch/backup/state-20220825144309.export"
'opam install --verbose --yes horned_worm.0.3.1 astring.0.8.5 async.v0.9.0 async_extra.v0.9.0 async_kernel.v0.9.0 async_rpc_kernel.v0.9.0 async_unix.v0.9.1 base.v0.9.4 base-bytes.base base-num.base base64.2.3.0 bin_prot.v0.9.2 cohttp.0.99.0 cohttp-async.0.99.0 conduit.1.0.3 conduit-async.1.0.0 configurator.v0.9.1 core.v0.9.2 core_kernel.v0.9.1 cppo.1.6.9 dune.1.11.4 fieldslib.v0.9.0 fmt.0.8.9 ipaddr.2.9.0 jane-street-headers.v0.9.0 jbuilder.transition jsonm.1.0.1 logs.0.7.0 magic-mime.1.2.0 num.0 ocaml-compiler-libs.v0.9.0 ocaml-migrate-parsetree.1.8.0 ocamlbuild.0.14.1 ocamlfind.1.9.5 octavius.1.2.2 ppx_assert.v0.9.0 ppx_ast.v0.9.1 ppx_base.v0.9.0 ppx_bench.v0.9.1 ppx_bin_prot.v0.9.0 ppx_compare.v0.9.0 ppx_core.v0.9.3 ppx_custom_printf.v0.9.0 ppx_derivers.1.2.1 ppx_driver.v0.9.2 ppx_enumerate.v0.9.0 ppx_expect.v0.9.0 ppx_fail.v0.9.0 ppx_fields_conv.v0.9.0 ppx_hash.v0.9.0 ppx_here.v0.9.1 ppx_inline_test.v0.9.2 ppx_jane.v0.9.0 ppx_js_style.v0.9.0 ppx_let.v0.9.0 ppx_metaquot.v0.9.0 ppx_optcomp.v0.9.0 ppx_optional.v0.9.0 ppx_pipebang.v0.9.0 ppx_sexp_conv.v0.9.0 ppx_sexp_message.v0.9.0 ppx_sexp_value.v0.9.0 ppx_traverse.v0.9.0 ppx_traverse_builtins.v0.9.0 ppx_type_conv.v0.9.1 ppx_typerep_conv.v0.9.0 ppx_variants_conv.v0.9.0 re.1.9.0 result.1.5 seq.0.2.2 sexplib.v0.9.3 spawn.v0.9.0 stdio.v0.9.1 stdlib-shims.0.3.0 stringext.1.6.0 topkg.1.0.5 typerep.v0.9.0 uchar.0.0.2 uri.1.9.7 uutf.1.0.3 variantslib.v0.9.0 yojson.2.0.0' failed.