functoria-runtime

Runtime support library for functoria-generated code
README


About

MirageOS is a library operating system that constructs unikernels for
secure, high-performance network applications across various cloud
computing and mobile platforms. Developers can write code on a
traditional OS such as Linux or macOS. They can then compile their
code into a fully-standalone, specialised unikernel that runs under
the Xen or KVM hypervisors and lightweight hypervisors like FreeBSD's
BHyve, OpenBSD's VMM. These unikernels can deploy on public clouds,
like Amazon's Elastic Compute Cloud and Google Compute Engine, or
private deployments.

The most up-to-date documentation can be found at the
homepage. The site is a self-hosted
unikernel
. Simpler skeleton
applications
are also
available online. MirageOS unikernels repositories are also available
here or
there.

This repository

This repository contains the mirage command-line tool to create and
deploy applications with MirageOS. This tool wraps the specialised
configuration and build steps required to build MirageOS on all the
supported targets.

Local install

You will need the following:

  • a working OCaml compiler (4.08.0 or higher).

  • the Opam source package manager (2.1.0 or higher).

  • an x86_64 or armel Linux host to compile Xen kernels, or FreeBSD, OpenBSD or
    MacOS X for the solo5 and userlevel versions.

Then run:

$ opam install mirage
$ mirage --version

This should display at least version 4.0.0.

Using mirage

There are multiple stages to using mirage:

  • write config.ml to describe the components of your applications;

  • call mirage configure to generate the necessary code and metadata;

  • optionally call make depends to install external dependencies and
    download Opam packages in the current dune workspace.

  • call dune build to build a unikernel.

You can find documentation, walkthroughs and tutorials over on the
MirageOS website.
The install instructions
are a good place to begin!

Install
Maintainers
Sources
mirage-4.1.1.tbz
sha256=3ace4c8fd3326e95a0f2b7eb7ab07b1d9f36e37de1b0066cae27d36b4fc58715
sha512=e61d786e131f099d5fd2bc0b1e86de865749b677eb674f80977d028624e157d5eb81cc2662fdb1c26def7baa78487e0892e0779bb1cdbd5bde7c1e57d72a3cc2
Dependencies
fmt
>= "0.8.7"
cmdliner
>= "1.1.0"
dune
>= "2.9.0"
ocaml
>= "4.08.0"
Reverse Dependencies
docteur
< "0.0.2"
functoria
>= "4.1.1"
mirage-runtime
>= "4.1.1"