package cstruct

  1. Overview
  2. Docs
access C structures via a camlp4 extension

Install

Dune Dependency

Authors

Maintainers

Sources

ocaml-cstruct-0.6.2.tar.gz
sha256=348732761bc88cf0bd633728c887836436f400a06cfe671cff85348b4a93d6ce
md5=9a7cb13fd8c148ccc65b0f1992b1cda5

Description

Tags

org:mirage org:xapi-project

Published: 21 Nov 2013

Dependencies (5)

  1. ocamlbuild build & != "0.9.0"
  2. camlp4
  3. ocplib-endian
  4. ocamlfind
  5. ocaml < "4.06.0"

Dev Dependencies

None

Used by (93)

  1. albatross < "1.3.0"
  2. asn1-combinators = "0.2.0"
  3. balancer
  4. buffer-pool
  5. capnp-rpc-net >= "1.1" & < "1.2.1"
  6. channel
  7. charrua-client < "0.9"
  8. charrua-core < "0.3"
  9. charrua-unix < "0.3" | = "0.6"
  10. cohttp >= "0.9.7" & < "0.9.11"
  11. conduit-async = "3.0.0"
  12. conduit-lwt = "3.0.0"
  13. crunch >= "2.0.0" & < "3.0.0"
  14. cstruct-lwt < "3.0.0"
  15. cstruct-unix < "3.0.0"
  16. datakit-ci >= "0.10.0" & < "0.12.4"
  17. datakit-client < "0.9.0"
  18. datakit-server < "0.9.0"
  19. depyt < "0.3.0"
  20. dns >= "0.6.0" & < "0.7.0"
  21. dream < "1.0.0~alpha2"
  22. duff < "0.3"
  23. frenetic < "2.0.0"
  24. git >= "1.4.3" & < "1.6.0" | >= "2.0.0" & < "3.0.0"
  25. git-http < "1.11.0"
  26. git-mirage = "1.11.0"
  27. github-hooks >= "0.2.0"
  28. gluten-mirage < "0.3.0"
  29. gpt
  30. h2-mirage
  31. hacl-star >= "0.7.0"
  32. httpun-mirage
  33. hvsock < "1.0.0"
  34. ipaddr-cstruct < "5.2.0"
  35. irmin = "0.9.0"
  36. irmin-git >= "2.3.0"
  37. launchd < "1.2"
  38. letsencrypt = "0.2.5"
  39. letsencrypt-app < "0.4.0"
  40. macaddr-cstruct < "5.2.0"
  41. metrics-mirage
  42. mirage >= "0.7.2" & < "0.9.0"
  43. mirage-block < "1.0.0"
  44. mirage-block-ramdisk
  45. mirage-channel-lwt
  46. mirage-clock-unix < "1.0.0"
  47. mirage-clock-xen < "1.0.0"
  48. mirage-console-solo5 >= "0.2.0"
  49. mirage-console-unix < "2.3.2"
  50. mirage-console-xen = "4.0.0"
  51. mirage-console-xen-backend >= "2.3.2" & < "2.3.4" | = "4.0.0"
  52. mirage-console-xen-cli
  53. mirage-entropy < "0.5.0"
  54. mirage-flow < "1.2.0"
  55. mirage-flow-rawlink >= "1.1.0"
  56. mirage-fs >= "0.4.0" & < "1.0.0"
  57. mirage-fs-mem
  58. mirage-kv-lwt >= "2.0.0"
  59. mirage-nat < "2.2.4"
  60. mirage-net = "0.5.2"
  61. mirage-net-lwt
  62. mirage-profile < "0.7.0"
  63. mirage-qubes < "0.3"
  64. mirage-tc
  65. mirage-vnetif < "0.4.0"
  66. mirage-www < "0.4.0"
  67. monorobot
  68. noise
  69. openflow < "0.3.0"
  70. ox < "1.1.0"
  71. pbkdf = "1.1.0"
  72. pcap-format = "0.3.3"
  73. ppx_cstruct < "3.0.1"
  74. protocol-9p < "0.5.1"
  75. protocol-9p-tool = "0.12.0" | >= "2.0.0" & < "2.0.2"
  76. qcow < "0.11.0"
  77. qcow-format
  78. qcow-tool
  79. resp-mirage = "0.10.0"
  80. sendmail >= "0.4.1" & < "0.5.0"
  81. shared-memory-ring < "0.4.3" | = "1.1.1"
  82. slack
  83. ssh-agent
  84. tar-format >= "0.2.0" & < "0.5.0"
  85. tuntap = "0.5"
  86. u2f = "0.1.1"
  87. vchan < "0.9.6"
  88. vhd-format-lwt
  89. websocket = "2.2"
  90. xapi-rrd-transport
  91. xe
  92. xenstore >= "1.2.0" & < "1.3.0"
  93. xentropyd

Conflicts

None

OCaml

Innovation. Community. Security.