conf-libX11

Virtual package relying on an Xlib system installation

Error log

The package failed to build. The error log from opam follows.

Opam plugin "depext" may require upgrading/reinstalling. Reinstall the plugin on the current switch? [Y/n] y
The following actions will be performed:
  - recompile opam-depext 1.2.1-1

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved opam-depext.1.2.1-1  (cached)
-> removed   opam-depext.1.2.1-1
-> installed opam-depext.1.2.1-1
Done.

<><> opam-depext.1.2.1-1 installed successfully <><><><><><><><><><><><><><><><>
=> opam-depext is unnecessary when used with opam >= 2.1. Please use opam install directly instead
# Run eval $(opam env) to update the current shell environment

<><> Carrying on to "opam depext -viy graphics.4.08.0 conf-libX11.1 conf-pkg-config.2" 

You are using opam 2.1+, where external dependency handling has been integrated: consider calling opam directly, the 'depext' plugin interface is provided for backwards compatibility only
# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
[ERROR] No solution for graphics.4.08.0 & conf-libX11.1 & conf-pkg-config.2:   * Incompatible packages:
            - (invariant) -> ocaml-base-compiler = 4.08.1
            - graphics = 4.08.0 -> ocaml = 4.08.0 -> ocaml-system >= 4.08.0
            You can temporarily relax the switch invariant with `--update-invariant'
          * Missing dependency:
            - graphics = 4.08.0 -> ocaml = 4.08.0 -> ocaml-variants < 4.08.1~ -> ocaml-beta
            unmet availability conditions: 'enable-ocaml-beta-repository'


Command failed: opam --cli=2.1 list --readonly --external '--resolve=graphics.4.08.0,conf-libX11.1,conf-pkg-config.2' returned 20