package cohttp-mirage

  1. Overview
  2. No Docs
CoHTTP implementation for the MirageOS unikernel

Install

Dune Dependency

Authors

Maintainers

Sources

cohttp-5.3.0.tbz
sha256=b3bd91c704e5ea510e924b83ab2ede1fc46a2cce448b0f8cef4883b9a16eeddd
sha512=529930d9b1f38737d91f47cb94f8bae381df87ea941cb8e75ee798354763bdf5091f4f3be31d0ba14b9944dc68203a3d98e235c38c66e7e176a114be9ff4acf3

Description

This HTTP implementation uses the Cohttp portable implementaiton along with the Lwt threading library in order to provide a Cohttp_mirage functor that can be used in MirageOS unikernels to build very small and efficient HTTP clients and servers without having a hard dependency on an underlying operating system.

Please see https://mirage.io for a self-hosted explanation and instructions on how to use this library.

Tags

org:mirage org:xapi-project

Published: 24 Jul 2023

Dependencies (14)

  1. ppx_sexp_conv >= "v0.13.0"
  2. magic-mime
  3. astring
  4. fmt >= "0.8.7"
  5. cohttp-lwt >= "5.3.0" & <= "5.3.1"
  6. cohttp >= "5.3.0" & <= "5.3.1"
  7. lwt >= "2.4.3"
  8. mirage-kv >= "3.0.0"
  9. conduit-mirage >= "2.3.0"
  10. conduit >= "2.0.2"
  11. mirage-channel >= "4.0.0"
  12. mirage-flow >= "2.0.0"
  13. dune >= "2.0"
  14. ocaml >= "4.08"

Dev Dependencies

None

Used by (2)

  1. git-cohttp-mirage < "3.2.0"
  2. git-mirage >= "1.11.4" & < "3.0.0"

Conflicts

None