package bap-mips

  1. Overview
  2. Docs
On This Page
  1. Error log

bap-mips 2.1.0

Error log

The package failed to build. The error log from opam follows.

Opam plugin "depext" may require upgrading/reinstalling. Reinstall the plugin on the current switch? [Y/n] y
The following actions will be performed:
  - recompile opam-depext 1.2.1-1

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved opam-depext.1.2.1-1  (cached)
-> removed   opam-depext.1.2.1-1
-> installed opam-depext.1.2.1-1
Done.

<><> opam-depext.1.2.1-1 installed successfully <><><><><><><><><><><><><><><><>
=> opam-depext is unnecessary when used with opam >= 2.1. Please use opam install directly instead
# Run eval $(opam env) to update the current shell environment

<><> Carrying on to "opam depext -viy bap-veri.0.2.5 zed.3.2.1 zarith.1.13 z3.4.12.2-1 variantslib.v0.12.0 uutf.1.0.3 uuseg.15.0.0 uuidm.0.9.8 uucp.15.0.0 utop.2.12.1 uri.3.1.0 uchar.0.0.2 typerep.v0.12.0 trie.1.0.0 topkg.1.0.7 time_now.v0.12.0 textutils_kernel.v0.12.0 text-tags.2.1.0 stringext.1.6.0 stdlib-shims.0.3.0 stdio.v0.12.0 splittable_random.v0.12.0 sexplib0.v0.12.0 sexplib.v0.12.0 seq.base result.1.5 regular.2.1.0 react.1.2.2 re.1.11.0 ppxlib.0.8.1 ppx_variants_conv.v0.12.0 ppx_typerep_conv.v0.12.0 ppx_tools_versioned.5.4.0 ppx_stable.v0.12.0 ppx_sexp_value.v0.12.0 ppx_sexp_message.v0.12.0 ppx_sexp_conv.v0.12.0 ppx_pipebang.v0.12.0 ppx_optional.v0.12.0 ppx_optcomp.v0.12.0 ppx_module_timer.v0.12.0 ppx_let.v0.12.0 ppx_js_style.v0.12.0 ppx_jane.v0.12.0 ppx_inline_test.v0.12.0 ppx_here.v0.12.0 ppx_hash.v0.12.0 ppx_fields_conv.v0.12.0 ppx_fail.v0.12.0 ppx_expect.v0.12.0 ppx_enumerate.v0.12.0 ppx_derivers.1.2.1 ppx_custom_printf.v0.12.1 ppx_compare.v0.12.0 ppx_bin_prot.v0.12.1 ppx_bench.v0.12.0 ppx_base.v0.12.0 ppx_assert.v0.12.0 pcre.7.4.6 parsexp.v0.12.0 ounit2.2.2.7 ounit.2.2.7 ogre.2.1.0 octavius.1.2.2 ocplib-endian.1.2 ocamlmod.0.0.9 ocamlify.0.0.1 ocamlgraph.2.1.0 ocamlfind.1.9.6 ocamlbuild.0.14.2 ocaml-migrate-parsetree.1.8.0 ocaml-compiler-libs.v0.12.4 oasis.0.4.11 num.1.4 monads.2.1.0 mmap.1.2.0 mew_vi.0.5.0 mew.0.1.0 lwt_react.1.2.0 lwt.5.7.0 logs.0.7.0 lambda-term.3.3.2 jst-config.v0.12.0 jane-street-headers.v0.12.0 graphlib.2.1.0 fileutils.0.6.4 fieldslib.v0.12.0 FrontC.3.4.3-1 dune-configurator.3.10.0 dune.3.10.0 csexp.1.5.2 cppo.1.6.9 core_kernel.v0.12.3 conf-zlib.1 conf-which.1 conf-python-3.9.0.0 conf-pkg-config.3 conf-libpcre.1 conf-gmp.4 conf-env-travis.1 conf-c++.1.0 conf-binutils.0.2 conf-bap-llvm.1.8 cmdliner.1.2.0 camlzip.1.11 bitvec-sexp.2.1.0 bitvec-order.2.1.0 bitvec-binprot.2.1.0 bitvec.2.1.0 bitstring.3.1.1 bin_prot.v0.12.0 bigarray-compat.1.1.0 base_quickcheck.v0.12.1 base_bigstring.v0.12.0 base-bytes.base base.v0.12.2 bare.2.1.0 bap-x86.2.1.0 bap-warn-unused.2.1.0 bap-trivial-condition-form.2.1.0 bap-traces.2.1.0 bap-trace.2.1.0 bap-term-mapper.2.1.0 bap-taint-propagator.2.1.0 bap-taint.2.1.0 bap-symbol-reader.2.1.0 bap-stub-resolver.2.1.0 bap-strings.2.1.0 bap-std.2.1.0 bap-ssa.2.1.0 bap-signatures.2.5.0 bap-run.2.1.0 bap-report.2.1.0 bap-relocatable.2.1.0 bap-recipe-command.2.1.0 bap-recipe.2.1.0 bap-raw.2.1.0 bap-print.2.1.0 bap-primus-x86.2.1.0 bap-primus-test.2.1.0 bap-primus-systems.2.1.0 bap-primus-symbolic-executor.2.1.0 bap-primus-support.2.1.0 bap-primus-region.2.1.0 bap-primus-random.2.1.0 bap-primus-powerpc.2.1.0 bap-primus-lisp.2.1.0 bap-primus-dictionary.2.1.0 bap-primus.2.1.0 bap-powerpc.2.1.0 bap-plugins.2.1.0 bap-optimization.2.1.0 bap-objdump.2.1.0 bap-mips.2.1.0 bap-microx.2.1.0 bap-mc.2.1.0 bap-main.2.1.0 bap-llvm.2.1.0 bap-knowledge.2.1.0 bap-glibc-runtime.2.1.0 bap-future.2.1.0 bap-frontend.2.1.0 bap-frontc.2.1.0 bap-emacs-mode.0.1 bap-emacs-goodies.0.1 bap-emacs-dot.0.1 bap-elf.2.1.0 bap-elementary.2.1.0 bap-dwarf.2.1.0 bap-dump-symbols.2.1.0 bap-disassemble.2.1.0 bap-demangle.2.1.0 bap-cxxfilt.2.1.0 bap-core-theory.2.1.0 bap-constant-tracker.2.1.0 bap-callsites.2.1.0 bap-cache.2.1.0 bap-c.2.1.0 bap-byteweight.2.1.0 bap-bundle.2.1.0 bap-build.2.1.0 bap-bil.2.1.0 bap-beagle.2.1.0 bap-arm.2.1.0 bap-api.2.1.0 bap-abi.2.1.0 bap.2.1.0" 

You are using opam 2.1+, where external dependency handling has been integrated: consider calling opam directly, the 'depext' plugin interface is provided for backwards compatibility only
# Detecting depexts using vars: arch=x86_64, os=linux, os-distribution=debian, os-family=debian
[ERROR] No solution for bap-veri.0.2.5 & zed.3.2.1 & zarith.1.13 & z3.4.12.2-1 & variantslib.v0.12.0 & uutf.1.0.3 & uuseg.15.0.0 & uuidm.0.9.8 & uucp.15.0.0 & utop.2.12.1 & uri.3.1.0 & uchar.0.0.2 & typerep.v0.12.0 & trie.1.0.0 & topkg.1.0.7 & time_now.v0.12.0 & textutils_kernel.v0.12.0 & text-tags.2.1.0 & stringext.1.6.0 & stdlib-shims.0.3.0 & stdio.v0.12.0 & splittable_random.v0.12.0 & sexplib0.v0.12.0 & sexplib.v0.12.0 & seq.base & result.1.5 & regular.2.1.0 & react.1.2.2 & re.1.11.0 & ppxlib.0.8.1 & ppx_variants_conv.v0.12.0 & ppx_typerep_conv.v0.12.0 & ppx_tools_versioned.5.4.0 & ppx_stable.v0.12.0 & ppx_sexp_value.v0.12.0 & ppx_sexp_message.v0.12.0 & ppx_sexp_conv.v0.12.0 & ppx_pipebang.v0.12.0 & ppx_optional.v0.12.0 & ppx_optcomp.v0.12.0 & ppx_module_timer.v0.12.0 & ppx_let.v0.12.0 & ppx_js_style.v0.12.0 & ppx_jane.v0.12.0 & ppx_inline_test.v0.12.0 & ppx_here.v0.12.0 & ppx_hash.v0.12.0 & ppx_fields_conv.v0.12.0 & ppx_fail.v0.12.0 & ppx_expect.v0.12.0 & ppx_enumerate.v0.12.0 & ppx_derivers.1.2.1 & ppx_custom_printf.v0.12.1 & ppx_compare.v0.12.0 & ppx_bin_prot.v0.12.1 & ppx_bench.v0.12.0 & ppx_base.v0.12.0 & ppx_assert.v0.12.0 & pcre.7.4.6 & parsexp.v0.12.0 & ounit2.2.2.7 & ounit.2.2.7 & ogre.2.1.0 & octavius.1.2.2 & ocplib-endian.1.2 & ocamlmod.0.0.9 & ocamlify.0.0.1 & ocamlgraph.2.1.0 & ocamlfind.1.9.6 & ocamlbuild.0.14.2 & ocaml-migrate-parsetree.1.8.0 & ocaml-compiler-libs.v0.12.4 & oasis.0.4.11 & num.1.4 & monads.2.1.0 & mmap.1.2.0 & mew_vi.0.5.0 & mew.0.1.0 & lwt_react.1.2.0 & lwt.5.7.0 & logs.0.7.0 & lambda-term.3.3.2 & jst-config.v0.12.0 & jane-street-headers.v0.12.0 & graphlib.2.1.0 & fileutils.0.6.4 & fieldslib.v0.12.0 & FrontC.3.4.3-1 & dune-configurator.3.10.0 & dune.3.10.0 & csexp.1.5.2 & cppo.1.6.9 & core_kernel.v0.12.3 & conf-zlib.1 & conf-which.1 & conf-python-3.9.0.0 & conf-pkg-config.3 & conf-libpcre.1 & conf-gmp.4 & conf-env-travis.1 & conf-c++.1.0 & conf-binutils.0.2 & conf-bap-llvm.1.8 & cmdliner.1.2.0 & camlzip.1.11 & bitvec-sexp.2.1.0 & bitvec-order.2.1.0 & bitvec-binprot.2.1.0 & bitvec.2.1.0 & bitstring.3.1.1 & bin_prot.v0.12.0 & bigarray-compat.1.1.0 & base_quickcheck.v0.12.1 & base_bigstring.v0.12.0 & base-bytes.base & base.v0.12.2 & bare.2.1.0 & bap-x86.2.1.0 & bap-warn-unused.2.1.0 & bap-trivial-condition-form.2.1.0 & bap-traces.2.1.0 & bap-trace.2.1.0 & bap-term-mapper.2.1.0 & bap-taint-propagator.2.1.0 & bap-taint.2.1.0 & bap-symbol-reader.2.1.0 & bap-stub-resolver.2.1.0 & bap-strings.2.1.0 & bap-std.2.1.0 & bap-ssa.2.1.0 & bap-signatures.2.5.0 & bap-run.2.1.0 & bap-report.2.1.0 & bap-relocatable.2.1.0 & bap-recipe-command.2.1.0 & bap-recipe.2.1.0 & bap-raw.2.1.0 & bap-print.2.1.0 & bap-primus-x86.2.1.0 & bap-primus-test.2.1.0 & bap-primus-systems.2.1.0 & bap-primus-symbolic-executor.2.1.0 & bap-primus-support.2.1.0 & bap-primus-region.2.1.0 & bap-primus-random.2.1.0 & bap-primus-powerpc.2.1.0 & bap-primus-lisp.2.1.0 & bap-primus-dictionary.2.1.0 & bap-primus.2.1.0 & bap-powerpc.2.1.0 & bap-plugins.2.1.0 & bap-optimization.2.1.0 & bap-objdump.2.1.0 & bap-mips.2.1.0 & bap-microx.2.1.0 & bap-mc.2.1.0 & bap-main.2.1.0 & bap-llvm.2.1.0 & bap-knowledge.2.1.0 & bap-glibc-runtime.2.1.0 & bap-future.2.1.0 & bap-frontend.2.1.0 & bap-frontc.2.1.0 & bap-emacs-mode.0.1 & bap-emacs-goodies.0.1 & bap-emacs-dot.0.1 & bap-elf.2.1.0 & bap-elementary.2.1.0 & bap-dwarf.2.1.0 & bap-dump-symbols.2.1.0 & bap-disassemble.2.1.0 & bap-demangle.2.1.0 & bap-cxxfilt.2.1.0 & bap-core-theory.2.1.0 & bap-constant-tracker.2.1.0 & bap-callsites.2.1.0 & bap-cache.2.1.0 & bap-c.2.1.0 & bap-byteweight.2.1.0 & bap-bundle.2.1.0 & bap-build.2.1.0 & bap-bil.2.1.0 & bap-beagle.2.1.0 & bap-arm.2.1.0 & bap-api.2.1.0 & bap-abi.2.1.0 & bap.2.1.0:   * Missing dependency:
            - conf-bap-llvm >= 1.4
            depends on the unavailable system package 'llvm-9-dev'. Use `--no-depexts' to attempt installation anyway, or it is possible that a depext package name in the opam file is incorrect.


Command failed: opam --cli=2.1 list --readonly --external '--resolve=bap-veri.0.2.5,zed.3.2.1,zarith.1.13,z3.4.12.2-1,variantslib.v0.12.0,uutf.1.0.3,uuseg.15.0.0,uuidm.0.9.8,uucp.15.0.0,utop.2.12.1,uri.3.1.0,uchar.0.0.2,typerep.v0.12.0,trie.1.0.0,topkg.1.0.7,time_now.v0.12.0,textutils_kernel.v0.12.0,text-tags.2.1.0,stringext.1.6.0,stdlib-shims.0.3.0,stdio.v0.12.0,splittable_random.v0.12.0,sexplib0.v0.12.0,sexplib.v0.12.0,seq.base,result.1.5,regular.2.1.0,react.1.2.2,re.1.11.0,ppxlib.0.8.1,ppx_variants_conv.v0.12.0,ppx_typerep_conv.v0.12.0,ppx_tools_versioned.5.4.0,ppx_stable.v0.12.0,ppx_sexp_value.v0.12.0,ppx_sexp_message.v0.12.0,ppx_sexp_conv.v0.12.0,ppx_pipebang.v0.12.0,ppx_optional.v0.12.0,ppx_optcomp.v0.12.0,ppx_module_timer.v0.12.0,ppx_let.v0.12.0,ppx_js_style.v0.12.0,ppx_jane.v0.12.0,ppx_inline_test.v0.12.0,ppx_here.v0.12.0,ppx_hash.v0.12.0,ppx_fields_conv.v0.12.0,ppx_fail.v0.12.0,ppx_expect.v0.12.0,ppx_enumerate.v0.12.0,ppx_derivers.1.2.1,ppx_custom_printf.v0.12.1,ppx_compare.v0.12.0,ppx_bin_prot.v0.12.1,ppx_bench.v0.12.0,ppx_base.v0.12.0,ppx_assert.v0.12.0,pcre.7.4.6,parsexp.v0.12.0,ounit2.2.2.7,ounit.2.2.7,ogre.2.1.0,octavius.1.2.2,ocplib-endian.1.2,ocamlmod.0.0.9,ocamlify.0.0.1,ocamlgraph.2.1.0,ocamlfind.1.9.6,ocamlbuild.0.14.2,ocaml-migrate-parsetree.1.8.0,ocaml-compiler-libs.v0.12.4,oasis.0.4.11,num.1.4,monads.2.1.0,mmap.1.2.0,mew_vi.0.5.0,mew.0.1.0,lwt_react.1.2.0,lwt.5.7.0,logs.0.7.0,lambda-term.3.3.2,jst-config.v0.12.0,jane-street-headers.v0.12.0,graphlib.2.1.0,fileutils.0.6.4,fieldslib.v0.12.0,FrontC.3.4.3-1,dune-configurator.3.10.0,dune.3.10.0,csexp.1.5.2,cppo.1.6.9,core_kernel.v0.12.3,conf-zlib.1,conf-which.1,conf-python-3.9.0.0,conf-pkg-config.3,conf-libpcre.1,conf-gmp.4,conf-env-travis.1,conf-c++.1.0,conf-binutils.0.2,conf-bap-llvm.1.8,cmdliner.1.2.0,camlzip.1.11,bitvec-sexp.2.1.0,bitvec-order.2.1.0,bitvec-binprot.2.1.0,bitvec.2.1.0,bitstring.3.1.1,bin_prot.v0.12.0,bigarray-compat.1.1.0,base_quickcheck.v0.12.1,base_bigstring.v0.12.0,base-bytes.base,base.v0.12.2,bare.2.1.0,bap-x86.2.1.0,bap-warn-unused.2.1.0,bap-trivial-condition-form.2.1.0,bap-traces.2.1.0,bap-trace.2.1.0,bap-term-mapper.2.1.0,bap-taint-propagator.2.1.0,bap-taint.2.1.0,bap-symbol-reader.2.1.0,bap-stub-resolver.2.1.0,bap-strings.2.1.0,bap-std.2.1.0,bap-ssa.2.1.0,bap-signatures.2.5.0,bap-run.2.1.0,bap-report.2.1.0,bap-relocatable.2.1.0,bap-recipe-command.2.1.0,bap-recipe.2.1.0,bap-raw.2.1.0,bap-print.2.1.0,bap-primus-x86.2.1.0,bap-primus-test.2.1.0,bap-primus-systems.2.1.0,bap-primus-symbolic-executor.2.1.0,bap-primus-support.2.1.0,bap-primus-region.2.1.0,bap-primus-random.2.1.0,bap-primus-powerpc.2.1.0,bap-primus-lisp.2.1.0,bap-primus-dictionary.2.1.0,bap-primus.2.1.0,bap-powerpc.2.1.0,bap-plugins.2.1.0,bap-optimization.2.1.0,bap-objdump.2.1.0,bap-mips.2.1.0,bap-microx.2.1.0,bap-mc.2.1.0,bap-main.2.1.0,bap-llvm.2.1.0,bap-knowledge.2.1.0,bap-glibc-runtime.2.1.0,bap-future.2.1.0,bap-frontend.2.1.0,bap-frontc.2.1.0,bap-emacs-mode.0.1,bap-emacs-goodies.0.1,bap-emacs-dot.0.1,bap-elf.2.1.0,bap-elementary.2.1.0,bap-dwarf.2.1.0,bap-dump-symbols.2.1.0,bap-disassemble.2.1.0,bap-demangle.2.1.0,bap-cxxfilt.2.1.0,bap-core-theory.2.1.0,bap-constant-tracker.2.1.0,bap-callsites.2.1.0,bap-cache.2.1.0,bap-c.2.1.0,bap-byteweight.2.1.0,bap-bundle.2.1.0,bap-build.2.1.0,bap-bil.2.1.0,bap-beagle.2.1.0,bap-arm.2.1.0,bap-api.2.1.0,bap-abi.2.1.0,bap.2.1.0' returned 20